aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-17 19:28:12 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-17 19:28:12 +0000
commit428102e835766e2d2df6dd2b9501afd62c756c08 (patch)
tree579ef94e3ca7dc1affef6cdfba3499c3404c4f12 /editors
parentc74a19fa6fe29a8a48b696b9ab2d1371b7bd20b2 (diff)
downloadports-428102e835766e2d2df6dd2b9501afd62c756c08.tar.gz
ports-428102e835766e2d2df6dd2b9501afd62c756c08.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/AbiWord2/Makefile6
-rw-r--r--editors/AbiWord2/files/patch-src_af_util_xp_ut_iconv.cpp13
-rw-r--r--editors/abiword-devel/Makefile6
-rw-r--r--editors/abiword-devel/files/patch-src_af_util_xp_ut_iconv.cpp13
-rw-r--r--editors/abiword/Makefile6
-rw-r--r--editors/abiword/files/patch-src_af_util_xp_ut_iconv.cpp13
6 files changed, 57 insertions, 0 deletions
diff --git a/editors/AbiWord2/Makefile b/editors/AbiWord2/Makefile
index ff51fddfaa8d..3e9a8d489d09 100644
--- a/editors/AbiWord2/Makefile
+++ b/editors/AbiWord2/Makefile
@@ -70,6 +70,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%AUTOMAKE%%|${AUTOMAKE}|g ; \
s|%%ACLOCAL%%|${ACLOCAL}|g ; \
s|%%AUTOCONF%%|${AUTOCONF}|g' ${WRKSRC}/autogen.sh
+ @${FIND} ${WRKSRC}/ac-helpers -name "*.m4" | ${XARGS} ${REINPLACE_CMD} \
+ 's|-ansi||g ; \
+ s|-pedantic||g'
+ @${FIND} ${WRKSRC}/src/config/platforms -name "*.mk" | ${XARGS} \
+ ${REINPLACE_CMD} 's|-ansi||g ; \
+ s|-pedantic||g'
pre-configure:
@cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog INSTALL
diff --git a/editors/AbiWord2/files/patch-src_af_util_xp_ut_iconv.cpp b/editors/AbiWord2/files/patch-src_af_util_xp_ut_iconv.cpp
new file mode 100644
index 000000000000..72ff257a611b
--- /dev/null
+++ b/editors/AbiWord2/files/patch-src_af_util_xp_ut_iconv.cpp
@@ -0,0 +1,13 @@
+--- src/af/util/xp/ut_iconv.cpp.orig Thu Jul 17 15:12:55 2003
++++ src/af/util/xp/ut_iconv.cpp Thu Jul 17 15:16:40 2003
+@@ -295,8 +295,8 @@
+ return (size_t)-1;
+
+
+- ICONV_CONST char ** buf = const_cast<ICONV_CONST char**>(inbuf);
+- return iconv( cd, buf, inbytesleft, outbuf, outbytesleft );
++ //ICONV_CONST char ** buf = const_cast<ICONV_CONST char**>(inbuf);
++ return iconv( cd, inbuf, inbytesleft, outbuf, outbytesleft );
+ }
+
+ int UT_iconv_close( UT_iconv_t cd )
diff --git a/editors/abiword-devel/Makefile b/editors/abiword-devel/Makefile
index ff51fddfaa8d..3e9a8d489d09 100644
--- a/editors/abiword-devel/Makefile
+++ b/editors/abiword-devel/Makefile
@@ -70,6 +70,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%AUTOMAKE%%|${AUTOMAKE}|g ; \
s|%%ACLOCAL%%|${ACLOCAL}|g ; \
s|%%AUTOCONF%%|${AUTOCONF}|g' ${WRKSRC}/autogen.sh
+ @${FIND} ${WRKSRC}/ac-helpers -name "*.m4" | ${XARGS} ${REINPLACE_CMD} \
+ 's|-ansi||g ; \
+ s|-pedantic||g'
+ @${FIND} ${WRKSRC}/src/config/platforms -name "*.mk" | ${XARGS} \
+ ${REINPLACE_CMD} 's|-ansi||g ; \
+ s|-pedantic||g'
pre-configure:
@cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog INSTALL
diff --git a/editors/abiword-devel/files/patch-src_af_util_xp_ut_iconv.cpp b/editors/abiword-devel/files/patch-src_af_util_xp_ut_iconv.cpp
new file mode 100644
index 000000000000..72ff257a611b
--- /dev/null
+++ b/editors/abiword-devel/files/patch-src_af_util_xp_ut_iconv.cpp
@@ -0,0 +1,13 @@
+--- src/af/util/xp/ut_iconv.cpp.orig Thu Jul 17 15:12:55 2003
++++ src/af/util/xp/ut_iconv.cpp Thu Jul 17 15:16:40 2003
+@@ -295,8 +295,8 @@
+ return (size_t)-1;
+
+
+- ICONV_CONST char ** buf = const_cast<ICONV_CONST char**>(inbuf);
+- return iconv( cd, buf, inbytesleft, outbuf, outbytesleft );
++ //ICONV_CONST char ** buf = const_cast<ICONV_CONST char**>(inbuf);
++ return iconv( cd, inbuf, inbytesleft, outbuf, outbytesleft );
+ }
+
+ int UT_iconv_close( UT_iconv_t cd )
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index ff51fddfaa8d..3e9a8d489d09 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -70,6 +70,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%AUTOMAKE%%|${AUTOMAKE}|g ; \
s|%%ACLOCAL%%|${ACLOCAL}|g ; \
s|%%AUTOCONF%%|${AUTOCONF}|g' ${WRKSRC}/autogen.sh
+ @${FIND} ${WRKSRC}/ac-helpers -name "*.m4" | ${XARGS} ${REINPLACE_CMD} \
+ 's|-ansi||g ; \
+ s|-pedantic||g'
+ @${FIND} ${WRKSRC}/src/config/platforms -name "*.mk" | ${XARGS} \
+ ${REINPLACE_CMD} 's|-ansi||g ; \
+ s|-pedantic||g'
pre-configure:
@cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog INSTALL
diff --git a/editors/abiword/files/patch-src_af_util_xp_ut_iconv.cpp b/editors/abiword/files/patch-src_af_util_xp_ut_iconv.cpp
new file mode 100644
index 000000000000..72ff257a611b
--- /dev/null
+++ b/editors/abiword/files/patch-src_af_util_xp_ut_iconv.cpp
@@ -0,0 +1,13 @@
+--- src/af/util/xp/ut_iconv.cpp.orig Thu Jul 17 15:12:55 2003
++++ src/af/util/xp/ut_iconv.cpp Thu Jul 17 15:16:40 2003
+@@ -295,8 +295,8 @@
+ return (size_t)-1;
+
+
+- ICONV_CONST char ** buf = const_cast<ICONV_CONST char**>(inbuf);
+- return iconv( cd, buf, inbytesleft, outbuf, outbytesleft );
++ //ICONV_CONST char ** buf = const_cast<ICONV_CONST char**>(inbuf);
++ return iconv( cd, inbuf, inbytesleft, outbuf, outbytesleft );
+ }
+
+ int UT_iconv_close( UT_iconv_t cd )