aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2004-04-09 08:47:39 +0000
committerMaho Nakata <maho@FreeBSD.org>2004-04-09 08:47:39 +0000
commit7ead418e9b515590dda33e738e0f5e34b36a712b (patch)
treeebb7c61ab03ff66cc6ab680179742f59fcd134b6 /editors
parentebfc6e8877c948213790224c295258b45fb2a1f8 (diff)
downloadports-7ead418e9b515590dda33e738e0f5e34b36a712b.tar.gz
ports-7ead418e9b515590dda33e738e0f5e34b36a712b.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-1.1-devel/Makefile55
-rw-r--r--editors/openoffice-1.1-devel/distinfo4
-rw-r--r--editors/openoffice-1.1-devel/files/patch-setup2+wrapper+install.sh13
-rw-r--r--editors/openoffice-1.1-devel/files/patch-solenv+inc+unxfbsdi.mk11
-rw-r--r--editors/openoffice-1.1-devel/files/patch-sw+source+filter+ww8+ww8scan.cxx16
-rw-r--r--editors/openoffice-1.1-devel/pkg-message5
-rw-r--r--editors/openoffice.org-1.1-devel/Makefile55
-rw-r--r--editors/openoffice.org-1.1-devel/distinfo4
-rw-r--r--editors/openoffice.org-1.1-devel/files/patch-setup2+wrapper+install.sh13
-rw-r--r--editors/openoffice.org-1.1-devel/files/patch-solenv+inc+unxfbsdi.mk11
-rw-r--r--editors/openoffice.org-1.1-devel/files/patch-sw+source+filter+ww8+ww8scan.cxx16
-rw-r--r--editors/openoffice.org-1.1-devel/pkg-message5
12 files changed, 108 insertions, 100 deletions
diff --git a/editors/openoffice-1.1-devel/Makefile b/editors/openoffice-1.1-devel/Makefile
index 01d8bbc6d451..7898ff43c399 100644
--- a/editors/openoffice-1.1-devel/Makefile
+++ b/editors/openoffice-1.1-devel/Makefile
@@ -6,27 +6,23 @@
#
PORTNAME= openoffice
-PORTVERSION= 1.1.1.RC1
+PORTVERSION= 1.1.2.${SNAPDATE}
CATEGORIES+= editors
-MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/&,} \
- ftp://sunsite.cnlab-switch.ch/mirror/OpenOffice/%SUBDIR%/ \
- ftp://ftp.kddlabs.co.jp/office/openoffice/%SUBDIR%/ \
- ftp://ftp.tu-chemnitz.de/pub/openoffice/%SUBDIR%/ \
- http://ftp.stardiv.de/pub/OpenOffice.org/%SUBDIR%/ \
- http://ftp.gwdg.de/pub/misc/openoffice/%SUBDIR%/ \
+MASTER_SITES+= http://people.freebsd.org/~maho/ \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/contrib/helpcontent/&,}:help \
ftp://ftp.kddlabs.co.jp/office/openoffice/contrib/helpcontent/:help \
ftp://sunsite.cnlab-switch.ch/mirror/OpenOffice/contrib/helpcontent/:help \
http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/helpcontent/:help \
http://people.freebsd.org/~mbr/ooo/:moz
-MASTER_SITE_SUBDIR= contrib/rc/1.1.1rc
-DISTFILES+= OOo_1.1.1rc_source.tar.bz2 gpc231.tar.Z:gpc \
+MASTER_SITE_SUBDIR= maho/openoffice.org
+LATEST_LINK= ${PORTNAME}-${PORTVERSION}-devel
+DISTFILES+= OOo_${PORTVERSION}_source.tar.bz2 gpc231.tar.Z:gpc \
patch-openoffice-mozilla101-2002-10-14:moz mozilla-vendor-1.0.2a.tgz:moz
.if defined(L10NHELP)
DISTFILES+= ${L10NHELP:S/$/:help/}
.endif
-EXTRACT_ONLY= OOo_1.1.1rc_source.tar.bz2
+EXTRACT_ONLY= OOo_${PORTVERSION}_source.tar.bz2
ZIP?= ${PREFIX}/bin/zip
UNZIP?= ${PREFIX}/bin/unzip
@@ -40,10 +36,12 @@ USE_REINPLACE= yes
BUILD_NR= 645
RELEASE_NR= 1.1
-FRELEASE_NR= 1.1.1
+FRELEASE_NR= 1.1.2
+SNAPDATE= 20040408
INSTALLATION_BASEDIR= OpenOffice.org${FRELEASE_NR}
DIST_SUBDIR= openoffice1.1
DICT_DIR= ${PREFIX}/${INSTALLATION_BASEDIR}/share/dict/ooo/
+SIMPLEOSVER!= ${UNAME} -r | sed -e 's/\.//' | sed -e 's/\..*//'
#
# configuration for language specific slave ports
@@ -91,6 +89,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
# OOo requires gcc 3.2 (currently 3.3 is not supported)
BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
USE_GCC=3.2
+# XXX dirty
CC= gcc32
CXX= g++32
@@ -303,6 +302,7 @@ pre-fetch:
@${ECHO}
@${FALSE}
.endif
+ @${ECHO} "If you want SDK and/or solver, please type make sdk and/or make solver"
post-extract:
@for file in ${EXTRACT_REST}; do \
@@ -400,9 +400,9 @@ build-mozilla:
< ${WRKDIR}/mozilla/Makefile.new > ${WRKDIR}/mozilla/Makefile
.endif
.if defined(USE_GCC)
- @cd ${WRKDIR}/mozilla && ${MAKE} CXX=${CXX} CC=${CC} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build WRKDIRPREFIX=""
+ @cd ${WRKDIR}/mozilla && ${MAKE} CXX="${CXX}" CC="${CC}" CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build WRKDIRPREFIX=""
.else
- @cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build WRKDIRPREFIX=""
+ @cd ${WRKDIR}/mozilla && ${MAKE} CXX="${CXX}" CC="${CC}" CFLAGS="${CFLAGS}" build WRKDIRPREFIX=""
.endif
@${CP} ${FILESDIR}/zipmoz.sh ${WRKDIR}
@${CHMOD} 755 ${WRKDIR}/zipmoz.sh
@@ -533,13 +533,34 @@ post-install:
package-rename:
@${ECHO_MSG} "===> Rename package for OO.org mirror upload";
.if defined(LANG_SUFFIX)
- @${MV} ${WRKDIR}/../${PKGNAMEPREFIX}openoffice-${LANG_SUFFIX}-${PORTVERSION}_${PORTREVISION}.tbz \
- ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}-${LANG_SUFFIX}.tbz
+ @${MV} ${PKGFILE} \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}${SIMPLEOSVER}Intel_install_${LANG_PKGNAME}-${LANG_SUFFIX}${PKG_SUFX}
+.elif defined(LANG_PKGNAME)
+ @${MV} ${PKGFILE} \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}${SIMPLEOSVER}Intel_install_${LANG_PKGNAME}${PKG_SUFX}
.else
- @${MV} ${WRKDIR}/../${PKGNAMEPREFIX}openoffice-${PORTVERSION}_${PORTREVISION}.tbz \
- ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}.tbz
+ @${MV} ${PKGFILE} \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}${SIMPLEOSVER}Intel_install${PKG_SUFX}
.endif
+sdk:
+ @${ECHO_MSG} "===> Make SDK of OpenOffice.org"
+.if !defined(DISPLAY)
+ @cd ${WRKSRC}/.. && DISPLAY=${DISPLAYHACK} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
+ ${TCSH} -c 'source FreeBSDEnv.Set && unsetenv TOP && cd sdk_oo && build.pl && deliver.pl'
+ @-${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill
+ @${RM} -f ${WRKDIR}/.Xvfb.pid
+.else
+ @cd ${WRKSRC}/.. && DISPLAY=${DISPLAY} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
+ ${TCSH} -c 'source FreeBSDEnv.Set && unsetenv TOP && cd sdk_oo && build.pl && deliver.pl'
+.endif
+ ${MV} ${WRKSRC}/../solver/${BUILD_NR}/unxfbsd.pro/bin/OpenOffice.org${FRELEASE_NR}_SDK.tar.gz ${WRKDIR}/../OOo_${FRELEASE_NR}_${OPSYS}${SIMPLEOSVER}Intel_sdk.tar.gz
+
+
+solver:
+ @${ECHO_MSG} "===> Make Solver of OpenOffice.org"
+ @cd ${WRKSRC}/.. ; ${TAR} cfz ${WRKDIR}/../OOo_${FRELEASE_NR}_${OPSYS}${SIMPLEOSVER}Intel_solver.tar.gz solver
+
update:
@${MAKE} fetch
@${MAKE} extract
diff --git a/editors/openoffice-1.1-devel/distinfo b/editors/openoffice-1.1-devel/distinfo
index 98162ed0911b..d220f9389aec 100644
--- a/editors/openoffice-1.1-devel/distinfo
+++ b/editors/openoffice-1.1-devel/distinfo
@@ -1,5 +1,5 @@
-MD5 (openoffice1.1/OOo_1.1.1rc_source.tar.bz2) = 24ed3d57a01a59edfae95fe575476719
-SIZE (openoffice1.1/OOo_1.1.1rc_source.tar.bz2) = 194278533
+MD5 (openoffice1.1/OOo_1.1.2.20040408_source.tar.bz2) = d4d721c9f6f1505611cedbe8884ea665
+SIZE (openoffice1.1/OOo_1.1.2.20040408_source.tar.bz2) = 194210597
MD5 (openoffice1.1/gpc231.tar.Z) = fdb06fdb5a4670b172f9fb738b717be9
SIZE (openoffice1.1/gpc231.tar.Z) = 27917
MD5 (openoffice1.1/patch-openoffice-mozilla101-2002-10-14) = 463058a33377a9226f919d00e39dc28a
diff --git a/editors/openoffice-1.1-devel/files/patch-setup2+wrapper+install.sh b/editors/openoffice-1.1-devel/files/patch-setup2+wrapper+install.sh
new file mode 100644
index 000000000000..0ab0e49caeca
--- /dev/null
+++ b/editors/openoffice-1.1-devel/files/patch-setup2+wrapper+install.sh
@@ -0,0 +1,13 @@
+--- ../setup2/wrapper/install.sh.org Fri Apr 9 17:29:34 2004
++++ ../setup2/wrapper/install.sh Sat Jan 10 03:53:17 2004
+@@ -4,8 +4,8 @@
+ cd `dirname $0`
+
+ # Set the Defaults Here
+-oo_version="OpenOffice.org 1.1.1"
+-oo_home=OpenOffice.org1.1.1
++oo_version="OpenOffice.org 1.1.2"
++oo_home=OpenOffice.org1.1.2
+ oo_default_prefix=/usr/local
+ oo_default_netflg=-net
+ oo_default_interact=no
diff --git a/editors/openoffice-1.1-devel/files/patch-solenv+inc+unxfbsdi.mk b/editors/openoffice-1.1-devel/files/patch-solenv+inc+unxfbsdi.mk
deleted file mode 100644
index dd0dbb067109..000000000000
--- a/editors/openoffice-1.1-devel/files/patch-solenv+inc+unxfbsdi.mk
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../solenv/inc/unxfbsdi.mk.orig Sat Jan 10 03:59:13 2004
-+++ ../solenv/inc/unxfbsdi.mk Fri Mar 12 21:39:05 2004
-@@ -211,7 +211,7 @@
- LIBSALCPPRT*=-Wl,--whole-archive -lsalcpprt -Wl,--no-whole-archive
-
- # STLport always needs pthread.
--LIBSTLPORT=$(DYNAMIC) -lstlport_gcc $(PTHREAD_LIBS)
-+LIBSTLPORT=$(DYNAMIC) -lstlport_gcc $(STDLIBCPP) $(PTHREAD_LIBS)
- LIBSTLPORTST=$(STATIC) -lstlport_gcc $(DYNAMIC) $(PTHREAD_LIBS)
-
- # name of library manager
diff --git a/editors/openoffice-1.1-devel/files/patch-sw+source+filter+ww8+ww8scan.cxx b/editors/openoffice-1.1-devel/files/patch-sw+source+filter+ww8+ww8scan.cxx
deleted file mode 100644
index fad83b3f2be0..000000000000
--- a/editors/openoffice-1.1-devel/files/patch-sw+source+filter+ww8+ww8scan.cxx
+++ /dev/null
@@ -1,16 +0,0 @@
---- ../sw/source/filter/ww8/ww8scan.cxx.orig 2003-12-17 19:32:50.000000000 +0100
-+++ ../sw/source/filter/ww8/ww8scan.cxx 2004-01-06 06:29:48.000000000 +0100
-@@ -198,8 +198,13 @@
- ++pIter;
- }
- if (bBroken)
-+#if defined( UNX ) && !defined( DBG_UTIL )
-+ DBG_ERROR(rtl::OUStringToOString(sError, RTL_TEXTENCODING_ASCII_US));
-+#else
- DbgError(rtl::OUStringToOString(sError, RTL_TEXTENCODING_ASCII_US));
- #endif
-+
-+#endif
- }
-
- //Find an entry, return its address if found and 0 if not
diff --git a/editors/openoffice-1.1-devel/pkg-message b/editors/openoffice-1.1-devel/pkg-message
index c0b82e62b38f..d0f5c8cc7261 100644
--- a/editors/openoffice-1.1-devel/pkg-message
+++ b/editors/openoffice-1.1-devel/pkg-message
@@ -1,10 +1,7 @@
-OpenOffice.org Build 1.1.0 Personal Install How-To
+OpenOffice.org Build 1.1.1 Personal Install How-To
Written by: Martin Blapp <mbr@freebsd.org>
-OpenOffice.org 1.1Beta will soon been installed in
-${PREFIX}/OpenOffice.org-1.1.0
-
1 User installation
-------------------
diff --git a/editors/openoffice.org-1.1-devel/Makefile b/editors/openoffice.org-1.1-devel/Makefile
index 01d8bbc6d451..7898ff43c399 100644
--- a/editors/openoffice.org-1.1-devel/Makefile
+++ b/editors/openoffice.org-1.1-devel/Makefile
@@ -6,27 +6,23 @@
#
PORTNAME= openoffice
-PORTVERSION= 1.1.1.RC1
+PORTVERSION= 1.1.2.${SNAPDATE}
CATEGORIES+= editors
-MASTER_SITES+= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/&,} \
- ftp://sunsite.cnlab-switch.ch/mirror/OpenOffice/%SUBDIR%/ \
- ftp://ftp.kddlabs.co.jp/office/openoffice/%SUBDIR%/ \
- ftp://ftp.tu-chemnitz.de/pub/openoffice/%SUBDIR%/ \
- http://ftp.stardiv.de/pub/OpenOffice.org/%SUBDIR%/ \
- http://ftp.gwdg.de/pub/misc/openoffice/%SUBDIR%/ \
+MASTER_SITES+= http://people.freebsd.org/~maho/ \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,misc/openoffice/contrib/helpcontent/&,}:help \
ftp://ftp.kddlabs.co.jp/office/openoffice/contrib/helpcontent/:help \
ftp://sunsite.cnlab-switch.ch/mirror/OpenOffice/contrib/helpcontent/:help \
http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/helpcontent/:help \
http://people.freebsd.org/~mbr/ooo/:moz
-MASTER_SITE_SUBDIR= contrib/rc/1.1.1rc
-DISTFILES+= OOo_1.1.1rc_source.tar.bz2 gpc231.tar.Z:gpc \
+MASTER_SITE_SUBDIR= maho/openoffice.org
+LATEST_LINK= ${PORTNAME}-${PORTVERSION}-devel
+DISTFILES+= OOo_${PORTVERSION}_source.tar.bz2 gpc231.tar.Z:gpc \
patch-openoffice-mozilla101-2002-10-14:moz mozilla-vendor-1.0.2a.tgz:moz
.if defined(L10NHELP)
DISTFILES+= ${L10NHELP:S/$/:help/}
.endif
-EXTRACT_ONLY= OOo_1.1.1rc_source.tar.bz2
+EXTRACT_ONLY= OOo_${PORTVERSION}_source.tar.bz2
ZIP?= ${PREFIX}/bin/zip
UNZIP?= ${PREFIX}/bin/unzip
@@ -40,10 +36,12 @@ USE_REINPLACE= yes
BUILD_NR= 645
RELEASE_NR= 1.1
-FRELEASE_NR= 1.1.1
+FRELEASE_NR= 1.1.2
+SNAPDATE= 20040408
INSTALLATION_BASEDIR= OpenOffice.org${FRELEASE_NR}
DIST_SUBDIR= openoffice1.1
DICT_DIR= ${PREFIX}/${INSTALLATION_BASEDIR}/share/dict/ooo/
+SIMPLEOSVER!= ${UNAME} -r | sed -e 's/\.//' | sed -e 's/\..*//'
#
# configuration for language specific slave ports
@@ -91,6 +89,7 @@ LANG_SORTED=`${ECHO} ${LANG_LIST} | ${TR} " " "\n" | ${PASTE} -d " " - -`
# OOo requires gcc 3.2 (currently 3.3 is not supported)
BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
USE_GCC=3.2
+# XXX dirty
CC= gcc32
CXX= g++32
@@ -303,6 +302,7 @@ pre-fetch:
@${ECHO}
@${FALSE}
.endif
+ @${ECHO} "If you want SDK and/or solver, please type make sdk and/or make solver"
post-extract:
@for file in ${EXTRACT_REST}; do \
@@ -400,9 +400,9 @@ build-mozilla:
< ${WRKDIR}/mozilla/Makefile.new > ${WRKDIR}/mozilla/Makefile
.endif
.if defined(USE_GCC)
- @cd ${WRKDIR}/mozilla && ${MAKE} CXX=${CXX} CC=${CC} CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build WRKDIRPREFIX=""
+ @cd ${WRKDIR}/mozilla && ${MAKE} CXX="${CXX}" CC="${CC}" CFLAGS="${CFLAGS}" USE_GCC=${USE_GCC} build WRKDIRPREFIX=""
.else
- @cd ${WRKDIR}/mozilla && ${MAKE} CFLAGS="${CFLAGS}" build WRKDIRPREFIX=""
+ @cd ${WRKDIR}/mozilla && ${MAKE} CXX="${CXX}" CC="${CC}" CFLAGS="${CFLAGS}" build WRKDIRPREFIX=""
.endif
@${CP} ${FILESDIR}/zipmoz.sh ${WRKDIR}
@${CHMOD} 755 ${WRKDIR}/zipmoz.sh
@@ -533,13 +533,34 @@ post-install:
package-rename:
@${ECHO_MSG} "===> Rename package for OO.org mirror upload";
.if defined(LANG_SUFFIX)
- @${MV} ${WRKDIR}/../${PKGNAMEPREFIX}openoffice-${LANG_SUFFIX}-${PORTVERSION}_${PORTREVISION}.tbz \
- ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}-${LANG_SUFFIX}.tbz
+ @${MV} ${PKGFILE} \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}${SIMPLEOSVER}Intel_install_${LANG_PKGNAME}-${LANG_SUFFIX}${PKG_SUFX}
+.elif defined(LANG_PKGNAME)
+ @${MV} ${PKGFILE} \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}${SIMPLEOSVER}Intel_install_${LANG_PKGNAME}${PKG_SUFX}
.else
- @${MV} ${WRKDIR}/../${PKGNAMEPREFIX}openoffice-${PORTVERSION}_${PORTREVISION}.tbz \
- ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}.tbz
+ @${MV} ${PKGFILE} \
+ ${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}${SIMPLEOSVER}Intel_install${PKG_SUFX}
.endif
+sdk:
+ @${ECHO_MSG} "===> Make SDK of OpenOffice.org"
+.if !defined(DISPLAY)
+ @cd ${WRKSRC}/.. && DISPLAY=${DISPLAYHACK} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
+ ${TCSH} -c 'source FreeBSDEnv.Set && unsetenv TOP && cd sdk_oo && build.pl && deliver.pl'
+ @-${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill
+ @${RM} -f ${WRKDIR}/.Xvfb.pid
+.else
+ @cd ${WRKSRC}/.. && DISPLAY=${DISPLAY} PATH="${PATH}:${LOCALBASE}/bin:${LOCALBASE}/sbin" && \
+ ${TCSH} -c 'source FreeBSDEnv.Set && unsetenv TOP && cd sdk_oo && build.pl && deliver.pl'
+.endif
+ ${MV} ${WRKSRC}/../solver/${BUILD_NR}/unxfbsd.pro/bin/OpenOffice.org${FRELEASE_NR}_SDK.tar.gz ${WRKDIR}/../OOo_${FRELEASE_NR}_${OPSYS}${SIMPLEOSVER}Intel_sdk.tar.gz
+
+
+solver:
+ @${ECHO_MSG} "===> Make Solver of OpenOffice.org"
+ @cd ${WRKSRC}/.. ; ${TAR} cfz ${WRKDIR}/../OOo_${FRELEASE_NR}_${OPSYS}${SIMPLEOSVER}Intel_solver.tar.gz solver
+
update:
@${MAKE} fetch
@${MAKE} extract
diff --git a/editors/openoffice.org-1.1-devel/distinfo b/editors/openoffice.org-1.1-devel/distinfo
index 98162ed0911b..d220f9389aec 100644
--- a/editors/openoffice.org-1.1-devel/distinfo
+++ b/editors/openoffice.org-1.1-devel/distinfo
@@ -1,5 +1,5 @@
-MD5 (openoffice1.1/OOo_1.1.1rc_source.tar.bz2) = 24ed3d57a01a59edfae95fe575476719
-SIZE (openoffice1.1/OOo_1.1.1rc_source.tar.bz2) = 194278533
+MD5 (openoffice1.1/OOo_1.1.2.20040408_source.tar.bz2) = d4d721c9f6f1505611cedbe8884ea665
+SIZE (openoffice1.1/OOo_1.1.2.20040408_source.tar.bz2) = 194210597
MD5 (openoffice1.1/gpc231.tar.Z) = fdb06fdb5a4670b172f9fb738b717be9
SIZE (openoffice1.1/gpc231.tar.Z) = 27917
MD5 (openoffice1.1/patch-openoffice-mozilla101-2002-10-14) = 463058a33377a9226f919d00e39dc28a
diff --git a/editors/openoffice.org-1.1-devel/files/patch-setup2+wrapper+install.sh b/editors/openoffice.org-1.1-devel/files/patch-setup2+wrapper+install.sh
new file mode 100644
index 000000000000..0ab0e49caeca
--- /dev/null
+++ b/editors/openoffice.org-1.1-devel/files/patch-setup2+wrapper+install.sh
@@ -0,0 +1,13 @@
+--- ../setup2/wrapper/install.sh.org Fri Apr 9 17:29:34 2004
++++ ../setup2/wrapper/install.sh Sat Jan 10 03:53:17 2004
+@@ -4,8 +4,8 @@
+ cd `dirname $0`
+
+ # Set the Defaults Here
+-oo_version="OpenOffice.org 1.1.1"
+-oo_home=OpenOffice.org1.1.1
++oo_version="OpenOffice.org 1.1.2"
++oo_home=OpenOffice.org1.1.2
+ oo_default_prefix=/usr/local
+ oo_default_netflg=-net
+ oo_default_interact=no
diff --git a/editors/openoffice.org-1.1-devel/files/patch-solenv+inc+unxfbsdi.mk b/editors/openoffice.org-1.1-devel/files/patch-solenv+inc+unxfbsdi.mk
deleted file mode 100644
index dd0dbb067109..000000000000
--- a/editors/openoffice.org-1.1-devel/files/patch-solenv+inc+unxfbsdi.mk
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../solenv/inc/unxfbsdi.mk.orig Sat Jan 10 03:59:13 2004
-+++ ../solenv/inc/unxfbsdi.mk Fri Mar 12 21:39:05 2004
-@@ -211,7 +211,7 @@
- LIBSALCPPRT*=-Wl,--whole-archive -lsalcpprt -Wl,--no-whole-archive
-
- # STLport always needs pthread.
--LIBSTLPORT=$(DYNAMIC) -lstlport_gcc $(PTHREAD_LIBS)
-+LIBSTLPORT=$(DYNAMIC) -lstlport_gcc $(STDLIBCPP) $(PTHREAD_LIBS)
- LIBSTLPORTST=$(STATIC) -lstlport_gcc $(DYNAMIC) $(PTHREAD_LIBS)
-
- # name of library manager
diff --git a/editors/openoffice.org-1.1-devel/files/patch-sw+source+filter+ww8+ww8scan.cxx b/editors/openoffice.org-1.1-devel/files/patch-sw+source+filter+ww8+ww8scan.cxx
deleted file mode 100644
index fad83b3f2be0..000000000000
--- a/editors/openoffice.org-1.1-devel/files/patch-sw+source+filter+ww8+ww8scan.cxx
+++ /dev/null
@@ -1,16 +0,0 @@
---- ../sw/source/filter/ww8/ww8scan.cxx.orig 2003-12-17 19:32:50.000000000 +0100
-+++ ../sw/source/filter/ww8/ww8scan.cxx 2004-01-06 06:29:48.000000000 +0100
-@@ -198,8 +198,13 @@
- ++pIter;
- }
- if (bBroken)
-+#if defined( UNX ) && !defined( DBG_UTIL )
-+ DBG_ERROR(rtl::OUStringToOString(sError, RTL_TEXTENCODING_ASCII_US));
-+#else
- DbgError(rtl::OUStringToOString(sError, RTL_TEXTENCODING_ASCII_US));
- #endif
-+
-+#endif
- }
-
- //Find an entry, return its address if found and 0 if not
diff --git a/editors/openoffice.org-1.1-devel/pkg-message b/editors/openoffice.org-1.1-devel/pkg-message
index c0b82e62b38f..d0f5c8cc7261 100644
--- a/editors/openoffice.org-1.1-devel/pkg-message
+++ b/editors/openoffice.org-1.1-devel/pkg-message
@@ -1,10 +1,7 @@
-OpenOffice.org Build 1.1.0 Personal Install How-To
+OpenOffice.org Build 1.1.1 Personal Install How-To
Written by: Martin Blapp <mbr@freebsd.org>
-OpenOffice.org 1.1Beta will soon been installed in
-${PREFIX}/OpenOffice.org-1.1.0
-
1 User installation
-------------------