aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2012-07-06 14:02:04 +0000
committerAlex Dupre <ale@FreeBSD.org>2012-07-06 14:02:04 +0000
commitd9d59ef9bbf9f3fc2b07d3a8e07ef4c179ea9c84 (patch)
treefbdf491e91d853295f1da1beb1d22bceddf764d8 /editors
parentfaa46732062ae935357812da8e5c4a5423842f91 (diff)
downloadports-d9d59ef9bbf9f3fc2b07d3a8e07ef4c179ea9c84.tar.gz
ports-d9d59ef9bbf9f3fc2b07d3a8e07ef4c179ea9c84.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/libreoffice/Makefile8
-rw-r--r--editors/libreoffice/files/patch-avmedia__source__gstreamer__gstplayer.cxx11
-rw-r--r--editors/libreoffice/files/patch-filter__source__graphicfilter__icgm__bitmap.cxx14
-rw-r--r--editors/libreoffice/files/patch-sd__source__filter__eppt__pptx-epptbase.cxx29
-rw-r--r--editors/libreoffice/files/patch-sd__source__filter__eppt__pptx-epptooxml.cxx56
5 files changed, 115 insertions, 3 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index a8e538f207cd..d1a63345107c 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -66,6 +66,7 @@ LO_COMPONENTS= help
USE_XZ= yes
USE_PYTHON= yes
+USE_QT4= # empty but required
#l10n
INSTALL_TARGET= distro-pack-install
@@ -281,9 +282,9 @@ CONFIGURE_ARGS+= --disable-neon
.if ${PORT_OPTIONS:MKDE4}
USE_KDE4= kdelibs
-USE_QT4= yes
-CONFIGURE_ARGS+= --enable-kde4 QT4DIR="${QT_PREFIX}" QT4LIB="${QT_LIBDIR}" QT4INC="${QT_INCDIR}" KDE4DIR="${KDE4_PREFIX}"
-QT_COMPONENTS+= moc_build
+USE_QT4+= moc_build qmake_build
+CONFIGURE_ENV+= QT4DIR="${QT_PREFIX}" QT4LIB="${QT_LIBDIR}" QT4INC="${QT_INCDIR}" KDE4DIR="${KDE4_PREFIX}"
+CONFIGURE_ARGS+= --enable-kde4
.else
CONFIGURE_ARGS+= --disable-kde4
.endif
@@ -378,6 +379,7 @@ post-patch:
@${REINPLACE_CMD} -e 's#5.1 5.0#${BDB_VER}#g' \
-e 's,-ldb$$dash$$dbver,-l${BDB_LIB_NAME},g' \
-e 's,"Linux" \&\& test "z$$enable_graphite","FreeBSD" \&\& test "z$$enable_graphite",g' \
+ -e 's,`dirname $$qt_lib_dir`/bin:,,g' \
${WRKSRC}/configure
#install-gdb-printer is failing
@${REINPLACE_CMD} -e "/gdb/d" ${WRKSRC}/solenv/prj/build.lst
diff --git a/editors/libreoffice/files/patch-avmedia__source__gstreamer__gstplayer.cxx b/editors/libreoffice/files/patch-avmedia__source__gstreamer__gstplayer.cxx
new file mode 100644
index 000000000000..d3eabb67bb72
--- /dev/null
+++ b/editors/libreoffice/files/patch-avmedia__source__gstreamer__gstplayer.cxx
@@ -0,0 +1,11 @@
+--- avmedia/source/gstreamer/gstplayer.cxx.orig 2012-07-05 18:26:32.000000000 -0300
++++ avmedia/source/gstreamer/gstplayer.cxx 2012-07-05 18:15:27.000000000 -0300
+@@ -380,7 +380,7 @@
+ if( !isPlaying() )
+ gst_element_set_state( mpPlaybin, GST_STATE_PAUSED );
+
+- DBG( "seek to: %"SAL_PRIdINT64" ns original: %lf s", gst_position, fTime );
++ DBG( "seek to: %" SAL_PRIdINT64 " ns original: %lf s", gst_position, fTime );
+ }
+ }
+
diff --git a/editors/libreoffice/files/patch-filter__source__graphicfilter__icgm__bitmap.cxx b/editors/libreoffice/files/patch-filter__source__graphicfilter__icgm__bitmap.cxx
new file mode 100644
index 000000000000..4976f1c64860
--- /dev/null
+++ b/editors/libreoffice/files/patch-filter__source__graphicfilter__icgm__bitmap.cxx
@@ -0,0 +1,14 @@
+--- filter/source/graphicfilter/icgm/bitmap.cxx.orig 2012-07-06 12:01:36.000000000 +0200
++++ filter/source/graphicfilter/icgm/bitmap.cxx 2012-07-06 12:02:30.000000000 +0200
+@@ -254,9 +254,9 @@
+ rDesc.mnY = mpCGM->ImplGetUI( nPrecision );
+ rDesc.mnLocalColorPrecision = mpCGM->ImplGetI( nPrecision );
+ rDesc.mnScanSize = 0;
+- switch( rDesc.mnLocalColorPrecision )
++ switch( (int) rDesc.mnLocalColorPrecision )
+ {
+- case 0x80000001 : // monochrome ( bit = 0->backgroundcolor )
++ case -0x7FFFFFFF : // monochrome ( bit = 0->backgroundcolor )
+ case 0 : // bit = 1->fillcolor
+ rDesc.mnDstBitsPerPixel = 1;
+ break;
diff --git a/editors/libreoffice/files/patch-sd__source__filter__eppt__pptx-epptbase.cxx b/editors/libreoffice/files/patch-sd__source__filter__eppt__pptx-epptbase.cxx
new file mode 100644
index 000000000000..bd146326a7cf
--- /dev/null
+++ b/editors/libreoffice/files/patch-sd__source__filter__eppt__pptx-epptbase.cxx
@@ -0,0 +1,29 @@
+--- sd/source/filter/eppt/pptx-epptbase.cxx.orig 2012-07-05 15:05:54.000000000 +0200
++++ sd/source/filter/eppt/pptx-epptbase.cxx 2012-07-05 15:06:11.000000000 +0200
+@@ -237,7 +237,7 @@
+
+ for ( i = 0; i < mnPages; i++ )
+ {
+- DBG(printf( "call ImplCreateSlide( %"SAL_PRIuUINT32" )\n", i));
++ DBG(printf( "call ImplCreateSlide( %" SAL_PRIuUINT32 " )\n", i));
+ if ( !CreateSlide( i ) )
+ return;
+ }
+@@ -455,7 +455,7 @@
+ if ( GetPropertyValue( aAny, rXPropSet, String( RTL_CONSTASCII_USTRINGPARAM( "Layout" ) ) ), sal_True )
+ aAny >>= nLayout;
+
+- DBG(printf("GetLayoutOffset %"SAL_PRIdINT32"\n", nLayout));
++ DBG(printf("GetLayoutOffset %" SAL_PRIdINT32 "\n", nLayout));
+
+ return nLayout;
+ }
+@@ -486,7 +486,7 @@
+ if( nOffset >= 0 && nOffset < EPP_LAYOUT_SIZE )
+ return pPHLayout[ nOffset ];
+
+- DBG(printf("asked %"SAL_PRIdINT32" for layout outside of 0,%d array scope\n", nOffset, EPP_LAYOUT_SIZE ));
++ DBG(printf("asked %" SAL_PRIdINT32 " for layout outside of 0,%d array scope\n", nOffset, EPP_LAYOUT_SIZE ));
+
+ return pPHLayout[ 0 ];
+ }
diff --git a/editors/libreoffice/files/patch-sd__source__filter__eppt__pptx-epptooxml.cxx b/editors/libreoffice/files/patch-sd__source__filter__eppt__pptx-epptooxml.cxx
new file mode 100644
index 000000000000..9d5e9770a403
--- /dev/null
+++ b/editors/libreoffice/files/patch-sd__source__filter__eppt__pptx-epptooxml.cxx
@@ -0,0 +1,56 @@
+--- sd/source/filter/eppt/pptx-epptooxml.cxx.orig 2012-07-05 15:07:26.000000000 +0200
++++ sd/source/filter/eppt/pptx-epptooxml.cxx 2012-07-05 15:07:42.000000000 +0200
+@@ -1377,7 +1377,7 @@
+ void PowerPointExport::ImplWriteSlide( sal_uInt32 nPageNum, sal_uInt32 nMasterNum, sal_uInt16 /* nMode */,
+ sal_Bool bHasBackground, Reference< XPropertySet > aXBackgroundPropSet )
+ {
+- DBG(printf("write slide: %"SAL_PRIuUINT32"\n----------------\n", nPageNum));
++ DBG(printf("write slide: %" SAL_PRIuUINT32 "\n----------------\n", nPageNum));
+
+ // slides list
+ if( nPageNum == 0 )
+@@ -1466,7 +1466,7 @@
+ if( !mbCreateNotes || !ContainsOtherShapeThanPlaceholders( sal_True ) )
+ return;
+
+- DBG(printf("write Notes %"SAL_PRIuUINT32"\n----------------\n", nPageNum));
++ DBG(printf("write Notes %" SAL_PRIuUINT32 "\n----------------\n", nPageNum));
+
+ FSHelperPtr pFS = openFragmentStreamWithSerializer( OUStringBuffer()
+ .appendAscii( "ppt/notesSlides/notesSlide" )
+@@ -1575,7 +1575,7 @@
+
+ void PowerPointExport::ImplWriteSlideMaster( sal_uInt32 nPageNum, Reference< XPropertySet > aXBackgroundPropSet )
+ {
+- DBG(printf("write slide master: %"SAL_PRIuUINT32"\n----------------\n", nPageNum));
++ DBG(printf("write slide master: %" SAL_PRIuUINT32 "\n----------------\n", nPageNum));
+
+ // slides list
+ if( nPageNum == 0 )
+@@ -1669,7 +1669,7 @@
+
+ sal_Int32 PowerPointExport::GetLayoutFileId( sal_Int32 nOffset, sal_uInt32 nMasterNum )
+ {
+- DBG(printf("GetLayoutFileId offset: %"SAL_PRIdINT32" master: %"SAL_PRIuUINT32"", nOffset, nMasterNum));
++ DBG(printf("GetLayoutFileId offset: %" SAL_PRIdINT32 " master: %" SAL_PRIuUINT32 "", nOffset, nMasterNum));
+ if( mLayoutInfo[ nOffset ].mnFileIdArray.size() <= nMasterNum )
+ return 0;
+
+@@ -1684,7 +1684,7 @@
+
+ void PowerPointExport::ImplWritePPTXLayout( sal_Int32 nOffset, sal_uInt32 nMasterNum )
+ {
+- DBG(printf("write layout: %"SAL_PRIdINT32"\n", nOffset));
++ DBG(printf("write layout: %" SAL_PRIdINT32 "\n", nOffset));
+
+ Reference< drawing::XDrawPagesSupplier > xDPS( getModel(), uno::UNO_QUERY );
+ Reference< drawing::XDrawPages > xDrawPages( xDPS->getDrawPages(), uno::UNO_QUERY );
+@@ -2272,7 +2272,7 @@
+ if( value >>= strValue )
+ printf ("\"%s\"\n", USS( strValue ) );
+ else if( value >>= intValue )
+- printf ("%"SAL_PRIdINT32" (hex: %"SAL_PRIxUINT32")\n", intValue, intValue);
++ printf ("%" SAL_PRIdINT32 " (hex: %" SAL_PRIxUINT32 ")\n", intValue, intValue);
+ else if( value >>= boolValue )
+ printf ("%d (bool)\n", boolValue);
+ else if( value >>= pointValue )