aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-11-22 19:49:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-11-22 19:49:43 +0000
commit8c2aab382d5ceff395ed38e45399378035c4968e (patch)
treeea623aea7a81d860cc89359721fd92c71b84534d /editors
parente9cf7164b93e5dbdb7bef22c3dc3980161a34dad (diff)
downloadports-8c2aab382d5ceff395ed38e45399378035c4968e.tar.gz
ports-8c2aab382d5ceff395ed38e45399378035c4968e.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/texmakerx/Makefile1
-rw-r--r--editors/thoteditor/Makefile1
-rw-r--r--editors/vim5/Makefile1
-rw-r--r--editors/vim6/Makefile1
-rw-r--r--editors/wily/Makefile1
-rw-r--r--editors/xcoral/Makefile1
-rw-r--r--editors/yudit/Makefile2
7 files changed, 7 insertions, 1 deletions
diff --git a/editors/texmakerx/Makefile b/editors/texmakerx/Makefile
index 09386bb70036..35249aaa843f 100644
--- a/editors/texmakerx/Makefile
+++ b/editors/texmakerx/Makefile
@@ -25,6 +25,7 @@ QT_COMPONENTS= gui network xml moc_build qmake_build rcc_build \
uic_build qtestlib
HAS_CONFIGURE= yes
INSTALLS_ICONS= yes
+MAKE_JOBS_UNSAFE= yes
OPTIONS= XDVI "view dvi with xdvi" On \
GV "view ps with gv" On
diff --git a/editors/thoteditor/Makefile b/editors/thoteditor/Makefile
index 15f712c630e3..6b202d97d7ab 100644
--- a/editors/thoteditor/Makefile
+++ b/editors/thoteditor/Makefile
@@ -26,6 +26,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-thot --enable-plugin --without-insure --without-amaya --disable-java --disable-intr --disable-jit --disable-math --disable-ilu
USE_GMAKE= yes
ALL_TARGET= all schemas
+MAKE_JOBS_UNSAFE= yes
MAN1= cextract.1
MAN5= cextrc.5
diff --git a/editors/vim5/Makefile b/editors/vim5/Makefile
index c11a0caa7d6b..3c393471f2ae 100644
--- a/editors/vim5/Makefile
+++ b/editors/vim5/Makefile
@@ -33,6 +33,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
PATCH_DIST_ARGS= -d ${WRKDIR}/${DISTNAME} --forward --quiet -E ${PATCH_DIST_STRIP}
MAKE_ARGS+= CONF_ARGS="--prefix=${PREFIX} --with-tlib=termlib --disable-pythoninterp"
ALL_TARGET= #
+MAKE_JOBS_UNSAFE= yes
PLIST_SUB= VIM_VER=${DISTNAME:S/-//:S/.//}
MAN1= vim.1 vimtutor.1 xxd.1
MLINKS= vim.1 rvim.1 vim.1 rview.1 ectags.1 etags.1
diff --git a/editors/vim6/Makefile b/editors/vim6/Makefile
index 9bbdc68acc18..268c6518e421 100644
--- a/editors/vim6/Makefile
+++ b/editors/vim6/Makefile
@@ -43,6 +43,7 @@ PATCH_DIST_ARGS= -d ${WRKSRC:S/src$//} --batch --forward --quiet -E ${PATCH_DIST
#PATCH_DIST_ARGS= -t
MAKE_ARGS+= CONF_ARGS="--prefix=${PREFIX} --with-tlib=termlib ${CSCOPE_ARG}"
ALL_TARGET= #
+MAKE_JOBS_UNSAFE= yes
_DATADIR= ${DISTNAME:S/-//g:S/.//g}
DATADIR= ${PREFIX}/share/vim/${_DATADIR}
PLIST_SUB= VIM_VER=${_DATADIR}
diff --git a/editors/wily/Makefile b/editors/wily/Makefile
index 5c6908d3ee4d..6815295c1bc4 100644
--- a/editors/wily/Makefile
+++ b/editors/wily/Makefile
@@ -21,6 +21,7 @@ USE_XORG= x11 ice xt
GNU_CONFIGURE= YES
USE_GMAKE= YES
MAN1= wgoto.1 win.1 wreplace.1 Tag.1 mktags.1 Man.1
+MAKE_JOBS_UNSAFE= yes
PORTDOCS= index.html intro.html download.html credits.html FAQ.html \
onepage.html user.html idioms.html C.html python.html \
diff --git a/editors/xcoral/Makefile b/editors/xcoral/Makefile
index 5057783453bf..b2f8d67c90d5 100644
--- a/editors/xcoral/Makefile
+++ b/editors/xcoral/Makefile
@@ -17,6 +17,7 @@ USE_XORG= x11
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-lgnuregex"
CONFIGURE_ARGS= --libdir=${PREFIX}/share
+MAKE_JOBS_UNSAFE= yes
PLIST_SUB= VERSION="${PORTVERSION}"
diff --git a/editors/yudit/Makefile b/editors/yudit/Makefile
index 78cd6b4c1242..ec640514ac4d 100644
--- a/editors/yudit/Makefile
+++ b/editors/yudit/Makefile
@@ -21,10 +21,10 @@ CONFLICTS= uniconvertor-[0-9]*
USE_XORG= x11
USE_GNOME= gnometarget
USE_GMAKE= yes
+MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LC_ALL=
MAKE_ENV= LC_ALL=
MAN1= mytool.1 uniconv.1 uniprint.1
-USE_GMAKE= YES
.include <bsd.port.mk>