aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-03-08 07:28:36 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-03-08 07:28:36 +0000
commite244b8bcccf929bfb91b2bc9027c62bc28d342ad (patch)
treeca87e050de03316d0e07487ad68cd159a62ba2e8 /editors
parent5426e8d9867e628f524b8a559ce7f2583ca3345b (diff)
downloadports-e244b8bcccf929bfb91b2bc9027c62bc28d342ad.tar.gz
ports-e244b8bcccf929bfb91b2bc9027c62bc28d342ad.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs/Makefile8
-rw-r--r--editors/emacs19/Makefile8
-rw-r--r--editors/emacs20-dl/Makefile6
-rw-r--r--editors/emacs20/Makefile8
-rw-r--r--editors/emacs22/Makefile8
-rw-r--r--editors/emacs23/Makefile8
-rw-r--r--editors/mule-common/Makefile8
-rw-r--r--editors/mule/Makefile5
-rw-r--r--editors/xemacs21-mule-common/pkg-plist4
-rw-r--r--editors/xemacs21-mule/Makefile5
-rw-r--r--editors/xemacs21-mule/pkg-plist62
11 files changed, 65 insertions, 65 deletions
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index 480951ed501f..f33d5dd72256 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.35 1999/01/23 14:28:19 simokawa Exp $
+# $Id: Makefile,v 1.36 1999/01/27 07:41:10 fenner Exp $
#
DISTNAME= emacs-19.34b
@@ -14,14 +14,14 @@ MASTER_SITE_SUBDIR= emacs
MAINTAINER= ports@FreeBSD.ORG
EMACS_VERSION= 19.34
-EMACS_ARCH= ${MACHINE_ARCH}--freebsd
-PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${EMACS_ARCH}
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
+PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${CONFIGURE_TARGET}
NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/emacs-19.34
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= ${EMACS_ARCH} --with-x-toolkit --sharedstatedir=/var/run
+CONFIGURE_ARGS= --with-x-toolkit --sharedstatedir=/var/run
STRIP=
MAN1= emacs.1 etags.1 ctags.1
diff --git a/editors/emacs19/Makefile b/editors/emacs19/Makefile
index 480951ed501f..f33d5dd72256 100644
--- a/editors/emacs19/Makefile
+++ b/editors/emacs19/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.35 1999/01/23 14:28:19 simokawa Exp $
+# $Id: Makefile,v 1.36 1999/01/27 07:41:10 fenner Exp $
#
DISTNAME= emacs-19.34b
@@ -14,14 +14,14 @@ MASTER_SITE_SUBDIR= emacs
MAINTAINER= ports@FreeBSD.ORG
EMACS_VERSION= 19.34
-EMACS_ARCH= ${MACHINE_ARCH}--freebsd
-PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${EMACS_ARCH}
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
+PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${CONFIGURE_TARGET}
NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/emacs-19.34
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= ${EMACS_ARCH} --with-x-toolkit --sharedstatedir=/var/run
+CONFIGURE_ARGS= --with-x-toolkit --sharedstatedir=/var/run
STRIP=
MAN1= emacs.1 etags.1 ctags.1
diff --git a/editors/emacs20-dl/Makefile b/editors/emacs20-dl/Makefile
index dd7b8ff08148..af4fc05e2299 100644
--- a/editors/emacs20-dl/Makefile
+++ b/editors/emacs20-dl/Makefile
@@ -3,7 +3,7 @@
# Date created: 10 October 1998
# Whom: shige
#
-# $Id: Makefile,v 1.5 1999/01/27 07:41:11 fenner Exp $
+# $Id: Makefile,v 1.6 1999/03/01 09:17:43 shige Exp $
#
DISTNAME= emacs-20.3
@@ -25,9 +25,9 @@ USE_XLIB= yes
USE_GMAKE= yes
MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
EMACS_VER= 20.3
-EMACS_ARCH= ${MACHINE_ARCH}--freebsd
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
CONFIGURE_ARGS= ${EMACS_ARCH} --with-x-toolkit --with-pop
-PLIST_SUB= EMACS_VER=${EMACS_VER} EMACS_ARCH=${EMACS_ARCH}
+PLIST_SUB= EMACS_VER=${EMACS_VER} EMACS_ARCH=${CONFIGURE_TARGET}
.if defined(USE_XPGLIB)
.if (${USE_XPGLIB} == "YES")
diff --git a/editors/emacs20/Makefile b/editors/emacs20/Makefile
index e5b75720ec8e..6680c65dc938 100644
--- a/editors/emacs20/Makefile
+++ b/editors/emacs20/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.37 1999/01/27 07:41:11 fenner Exp $
+# $Id: Makefile,v 1.38 1999/03/01 11:55:45 shige Exp $
#
DISTNAME= emacs-20.3
@@ -16,12 +16,12 @@ MAINTAINER= jseger@FreeBSD.org
USE_AUTOCONF= yes
USE_XLIB= yes
USE_GMAKE= yes
-EMACS_ARCH= ${MACHINE_ARCH}--freebsd
-CONFIGURE_ARGS= ${EMACS_ARCH} --with-x-toolkit --with-pop
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
+CONFIGURE_ARGS= --with-x-toolkit --with-pop
MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
MAN1= emacs.1 etags.1 ctags.1
-PLIST_SUB= EMACS_VER=20.3 EMACS_ARCH=${EMACS_ARCH}
+PLIST_SUB= EMACS_VER=20.3 EMACS_ARCH=${CONFIGURE_TARGET}
.if defined(USE_XPGLIB)
.if (${USE_XPGLIB} == "YES")
diff --git a/editors/emacs22/Makefile b/editors/emacs22/Makefile
index 480951ed501f..f33d5dd72256 100644
--- a/editors/emacs22/Makefile
+++ b/editors/emacs22/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.35 1999/01/23 14:28:19 simokawa Exp $
+# $Id: Makefile,v 1.36 1999/01/27 07:41:10 fenner Exp $
#
DISTNAME= emacs-19.34b
@@ -14,14 +14,14 @@ MASTER_SITE_SUBDIR= emacs
MAINTAINER= ports@FreeBSD.ORG
EMACS_VERSION= 19.34
-EMACS_ARCH= ${MACHINE_ARCH}--freebsd
-PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${EMACS_ARCH}
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
+PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${CONFIGURE_TARGET}
NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/emacs-19.34
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= ${EMACS_ARCH} --with-x-toolkit --sharedstatedir=/var/run
+CONFIGURE_ARGS= --with-x-toolkit --sharedstatedir=/var/run
STRIP=
MAN1= emacs.1 etags.1 ctags.1
diff --git a/editors/emacs23/Makefile b/editors/emacs23/Makefile
index 480951ed501f..f33d5dd72256 100644
--- a/editors/emacs23/Makefile
+++ b/editors/emacs23/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.35 1999/01/23 14:28:19 simokawa Exp $
+# $Id: Makefile,v 1.36 1999/01/27 07:41:10 fenner Exp $
#
DISTNAME= emacs-19.34b
@@ -14,14 +14,14 @@ MASTER_SITE_SUBDIR= emacs
MAINTAINER= ports@FreeBSD.ORG
EMACS_VERSION= 19.34
-EMACS_ARCH= ${MACHINE_ARCH}--freebsd
-PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${EMACS_ARCH}
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
+PLIST_SUB= EMACS_VERSION=${EMACS_VERSION} EMACS_ARCH=${CONFIGURE_TARGET}
NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/emacs-19.34
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= ${EMACS_ARCH} --with-x-toolkit --sharedstatedir=/var/run
+CONFIGURE_ARGS= --with-x-toolkit --sharedstatedir=/var/run
STRIP=
MAN1= emacs.1 etags.1 ctags.1
diff --git a/editors/mule-common/Makefile b/editors/mule-common/Makefile
index 160d605236b9..246c35f0011b 100644
--- a/editors/mule-common/Makefile
+++ b/editors/mule-common/Makefile
@@ -3,7 +3,7 @@
# Date created: 7 July 1997
# Whom: Satoshi Taoka <taoka@infonets.hiroshima-u.ac.jp>
#
-# $Id: Makefile,v 1.36 1999/01/23 14:28:27 simokawa Exp $
+# $Id: Makefile,v 1.37 1999/02/03 11:11:42 asami Exp $
#
DISTNAME= mule-2.3
@@ -58,15 +58,15 @@ BROKEN= You should build install one of the other mule ports first
INSTALL_COOKIE= ${WRKDIR}/.install_done-${PKGNAME}
PACKAGE_COOKIE= ${WRKDIR}/.package_done-${PKGNAME}
TMPPLIST= ${WRKDIR}/.PLIST.mktmp-${PKGNAME}
-EMACS_ARCH= ${MACHINE_ARCH}--freebsd
-PLIST_SUB= EMACS_VERSION=19.34 EMACS_ARCH=${EMACS_ARCH}
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
+PLIST_SUB= EMACS_VERSION=19.34 EMACS_ARCH=${CONFIGURE_TARGET}
USE_XLIB= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
EMACS_PREFIX= mule
EMACS_EXECUTABLE = mule
-CONFIGURE_ARGS= ${EMACS_ARCH} --with-executable=${EMACS_EXECUTABLE} \
+CONFIGURE_ARGS= --with-executable=${EMACS_EXECUTABLE} \
--with-emacs-prefix=${EMACS_PREFIX} \
--with-terminal-face \
--x-includes=${X11BASE}/include --x-libraries=${X11BASE}/lib
diff --git a/editors/mule/Makefile b/editors/mule/Makefile
index eaafb5ec72bd..953b3555941b 100644
--- a/editors/mule/Makefile
+++ b/editors/mule/Makefile
@@ -3,7 +3,7 @@
# Date created: 6 July 1997
# Whom: Satoshi Taoka <taoka@infonets.hiroshima-u.ac.jp>
#
-# $Id: Makefile,v 1.35 1999/01/23 14:28:25 simokawa Exp $
+# $Id: Makefile,v 1.36 1999/02/03 11:11:41 asami Exp $
#
DISTNAME= mule-2.3
@@ -41,8 +41,7 @@ MAKE_ENV= LIBDIR="${LIBDIR}"
CONFIGURE_ENV= PATH=/usr/bin:$$PATH
EMACS_PREFIX= mule
EMACS_EXECUTABLE = mule
-EMACS_ARCH= ${MACHINE_ARCH}--freebsd
-CONFIGURE_ARGS= ${EMACS_ARCH} --with-executable=${EMACS_EXECUTABLE} \
+CONFIGURE_ARGS= --with-executable=${EMACS_EXECUTABLE} \
--with-emacs-prefix=${EMACS_PREFIX} \
--with-terminal-face \
--x-includes=${X11BASE}/include --x-libraries=${X11BASE}/lib \
diff --git a/editors/xemacs21-mule-common/pkg-plist b/editors/xemacs21-mule-common/pkg-plist
index d7bdfc676e50..51d78d3b7ff7 100644
--- a/editors/xemacs21-mule-common/pkg-plist
+++ b/editors/xemacs21-mule-common/pkg-plist
@@ -3628,5 +3628,5 @@ lib/%%XEMACS_DIR%%/lisp/x11/x-win-xfree86.elc
@dirrm lib/%%XEMACS_DIR%%/lisp/mule
@dirrm lib/%%XEMACS_DIR%%/lisp/skk
@dirrm lib/%%XEMACS_DIR%%/lisp
-@unexec mkdir -p %D/lib/%%XEMACS_DIR%%/i386-unknown-freebsd
-@dirrm lib/%%XEMACS_DIR%%/i386-unknown-freebsd
+@unexec mkdir -p %D/lib/%%XEMACS_DIR%%/i386--freebsd
+@dirrm lib/%%XEMACS_DIR%%/i386--freebsd
diff --git a/editors/xemacs21-mule/Makefile b/editors/xemacs21-mule/Makefile
index c3098f6f5067..647d5ef027a3 100644
--- a/editors/xemacs21-mule/Makefile
+++ b/editors/xemacs21-mule/Makefile
@@ -3,7 +3,7 @@
# Date created: 5 Dec 1997
# Whom: Kazuyuki IENAGA <ienaga@jsys.co.jp>
#
-# $Id: Makefile,v 1.13 1999/01/18 03:05:25 steve Exp $
+# $Id: Makefile,v 1.14 1999/01/23 07:05:33 vanilla Exp $
#
DISTNAME= xemacs-20.4
@@ -38,7 +38,7 @@ INSTALL_COOKIE= ${WRKDIR}/.install_done-${PKGNAME}
PACKAGE_COOKIE= ${WRKDIR}/.package_done-${PKGNAME}
GNU_CONFIGURE= yes
USE_AUTOCONF= yes
-CONFIGURE_ARGS= i386-unknown-freebsd \
+CONFIGURE_ARGS= \
--with-clash-detection \
--lockdir=/var/run/emacs/lock \
--with-x11 \
@@ -50,6 +50,7 @@ CONFIGURE_ARGS= i386-unknown-freebsd \
--sitelispdir=${PREFIX}/lib/${XEMACS_DIR}/lisp:${PREFIX}/lib/${XEMACS_DIR}/site-lisp:${PREFIX}/lib/xemacs/site-lisp:${PREFIX}/share/emacs/site-lisp \
--infopath=${PREFIX}/lib/xemacs/info:${PREFIX}/info:${X11BASE}/info:/usr/info:${PREFIX}/lib/texmf/doc/info:/usr/lib/texmf/doc:/usr/share/info \
${MISC_OPTIONS} ${WITH_INPUT_METHOD} ${WITH_WIDGETS}
+CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
STRIP=
diff --git a/editors/xemacs21-mule/pkg-plist b/editors/xemacs21-mule/pkg-plist
index c50c3a16b872..d65f9461868d 100644
--- a/editors/xemacs21-mule/pkg-plist
+++ b/editors/xemacs21-mule/pkg-plist
@@ -11,34 +11,34 @@ bin/gnuattach
bin/xemacs-20.4
@exec ln -sf %D/%F %B/xemacs
@unexec rm %B/xemacs
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/make-path
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/wakeup
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/profile
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/make-docfile
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/digest-doc
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/sorted-doc
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/movemail
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/cvtmail
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/fakemail
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/yow
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/hexl
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/gnuserv
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/mmencode
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/rcs2log
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/vcdiff
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/gzip-el.sh
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/install-sid
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/send-pr
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/tm-au
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/tm-file
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/tm-html
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/tm-image
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/tm-mpeg
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/tm-plain
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/tm-ps
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/tmdecode
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/add-little-package.sh
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/add-big-package.sh
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/DOC
-lib/%%XEMACS_DIR%%/i386-unknown-freebsd/config.values
-@dirrm lib/%%XEMACS_DIR%%/i386-unknown-freebsd
+lib/%%XEMACS_DIR%%/i386--freebsd/make-path
+lib/%%XEMACS_DIR%%/i386--freebsd/wakeup
+lib/%%XEMACS_DIR%%/i386--freebsd/profile
+lib/%%XEMACS_DIR%%/i386--freebsd/make-docfile
+lib/%%XEMACS_DIR%%/i386--freebsd/digest-doc
+lib/%%XEMACS_DIR%%/i386--freebsd/sorted-doc
+lib/%%XEMACS_DIR%%/i386--freebsd/movemail
+lib/%%XEMACS_DIR%%/i386--freebsd/cvtmail
+lib/%%XEMACS_DIR%%/i386--freebsd/fakemail
+lib/%%XEMACS_DIR%%/i386--freebsd/yow
+lib/%%XEMACS_DIR%%/i386--freebsd/hexl
+lib/%%XEMACS_DIR%%/i386--freebsd/gnuserv
+lib/%%XEMACS_DIR%%/i386--freebsd/mmencode
+lib/%%XEMACS_DIR%%/i386--freebsd/rcs2log
+lib/%%XEMACS_DIR%%/i386--freebsd/vcdiff
+lib/%%XEMACS_DIR%%/i386--freebsd/gzip-el.sh
+lib/%%XEMACS_DIR%%/i386--freebsd/install-sid
+lib/%%XEMACS_DIR%%/i386--freebsd/send-pr
+lib/%%XEMACS_DIR%%/i386--freebsd/tm-au
+lib/%%XEMACS_DIR%%/i386--freebsd/tm-file
+lib/%%XEMACS_DIR%%/i386--freebsd/tm-html
+lib/%%XEMACS_DIR%%/i386--freebsd/tm-image
+lib/%%XEMACS_DIR%%/i386--freebsd/tm-mpeg
+lib/%%XEMACS_DIR%%/i386--freebsd/tm-plain
+lib/%%XEMACS_DIR%%/i386--freebsd/tm-ps
+lib/%%XEMACS_DIR%%/i386--freebsd/tmdecode
+lib/%%XEMACS_DIR%%/i386--freebsd/add-little-package.sh
+lib/%%XEMACS_DIR%%/i386--freebsd/add-big-package.sh
+lib/%%XEMACS_DIR%%/i386--freebsd/DOC
+lib/%%XEMACS_DIR%%/i386--freebsd/config.values
+@dirrm lib/%%XEMACS_DIR%%/i386--freebsd