aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-29 16:35:19 +0000
commit4ca0e60800b90ba4a6de31beabeee8ccce611649 (patch)
tree8324ab31f68eba587c532d238cd3f502d0a56322 /editors
parent7530f93a62fb8bcd686d08f2bfa5dc0f623f3c73 (diff)
downloadports-4ca0e60800b90ba4a6de31beabeee8ccce611649.tar.gz
ports-4ca0e60800b90ba4a6de31beabeee8ccce611649.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/gedit/Makefile2
-rw-r--r--editors/gedit2/Makefile2
-rw-r--r--editors/ghex/Makefile2
-rw-r--r--editors/ghex2/Makefile2
-rw-r--r--editors/glimmer/Makefile2
-rw-r--r--editors/gmanedit/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index daa6e9181b01..790ccebe424a 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gedit.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/editors/gedit2/Makefile b/editors/gedit2/Makefile
index daa6e9181b01..790ccebe424a 100644
--- a/editors/gedit2/Makefile
+++ b/editors/gedit2/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gedit.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/editors/ghex/Makefile b/editors/ghex/Makefile
index a369cf69e2b1..115052f36b39 100644
--- a/editors/ghex/Makefile
+++ b/editors/ghex/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/editors/ghex2/Makefile b/editors/ghex2/Makefile
index a369cf69e2b1..115052f36b39 100644
--- a/editors/ghex2/Makefile
+++ b/editors/ghex2/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/editors/glimmer/Makefile b/editors/glimmer/Makefile
index 2b2ef2ed00c6..92fa7878cd51 100644
--- a/editors/glimmer/Makefile
+++ b/editors/glimmer/Makefile
@@ -29,7 +29,7 @@ PYTHON_LIBS= -lssl -lcrypto
PYTHON_LIBS+= -lutil -lreadline -lcrypt -lpython
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|-lpython|${PYTHON_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
diff --git a/editors/gmanedit/Makefile b/editors/gmanedit/Makefile
index 0012d8f7d91a..e3744176574f 100644
--- a/editors/gmanedit/Makefile
+++ b/editors/gmanedit/Makefile
@@ -28,7 +28,7 @@ post-extract:
@${RM} -rf ${WRKSRC}/config.cache
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \