aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-20 18:45:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-20 18:45:29 +0000
commit57a18f1763a3f0599f10c0efd5ce3599cb4e64fa (patch)
tree9b55ce11ab3ebc3da7f31e68913837bfe7bf7790 /editors
parentdf18a2554361c9bdba2afd82bb9d9239cdd55dfd (diff)
downloadports-57a18f1763a3f0599f10c0efd5ce3599cb4e64fa.tar.gz
ports-57a18f1763a3f0599f10c0efd5ce3599cb4e64fa.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/e93/Makefile22
-rw-r--r--editors/e93/files/patch-af11
-rw-r--r--editors/e93/files/patch-ag11
-rw-r--r--editors/e93/files/patch-ah11
-rw-r--r--editors/e93/files/patch-channels.c20
-rw-r--r--editors/e93/files/patch-machdef.mk (renamed from editors/e93/files/patch-ae)6
-rw-r--r--editors/e93/files/patch-shell.c11
-rw-r--r--editors/e93/files/patch-shellcmd.c111
8 files changed, 19 insertions, 184 deletions
diff --git a/editors/e93/Makefile b/editors/e93/Makefile
index f0bf4d297343..e700ae6748ce 100644
--- a/editors/e93/Makefile
+++ b/editors/e93/Makefile
@@ -7,19 +7,29 @@
PORTNAME= e93
PORTVERSION= 1.3.4
-CATEGORIES= editors tcl82 tk82
-MASTER_SITES= ftp://ftp.e93.org/pub/
+PORTREVISION= 1
+CATEGORIES= editors tcl84 tk84
+MASTER_SITES= ftp://ftp.e93.org/pub/ \
+ http://www.crpetsmoker.net/distfiles/ \
+ http://www.xs4all.nl/~tournoij/distfiles/
DISTNAME= ${PORTNAME}-1.3r4X
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= carpetsmoker@xs4all.nl
COMMENT= A nifty editor based on Tcl/Tk
-LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82 \
- tk82.1:${PORTSDIR}/x11-toolkits/tk82
-
+USE_TCL= yes
+USE_TCL_BUILD= yes
+USE_TK= yes
+USE_TK_BUILD= yes
+USE_XLIB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+post-patch:
+ @${REINPLACE_CMD} 's|wish|wish${TK_VER}|' ${WRKSRC}/e93r
+ @${REINPLACE_CMD} 's|CFLAGS=|CFLAGS+=$$(TK_INCLUDE) -I${LOCALBASE}/include |' \
+ ${WRKSRC}/Makefile ${WRKSRC}/xgui/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/e93 ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/e93r ${PREFIX}/bin
diff --git a/editors/e93/files/patch-af b/editors/e93/files/patch-af
deleted file mode 100644
index 5e06c12b6335..000000000000
--- a/editors/e93/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Sun Sep 24 18:33:49 2000
-+++ Makefile Sun Sep 24 18:34:49 2000
-@@ -21,7 +21,7 @@
- # Include machine/platform specific information
- include machdef.mk
-
--CFLAGS=-I. $(TCL_INCLUDE) $(X_INCLUDE) $(OPTIONS) $(MACHINESPEC)
-+CFLAGS+=-I. $(TCL_INCLUDE) ${TK_INCLUDE} $(X_INCLUDE) $(OPTIONS) $(MACHINESPEC)
-
- OBJECTS = \
- e93.o \
diff --git a/editors/e93/files/patch-ag b/editors/e93/files/patch-ag
deleted file mode 100644
index 644ff35ef78d..000000000000
--- a/editors/e93/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- xgui/Makefile.orig Sun Sep 24 23:32:13 2000
-+++ xgui/Makefile Sun Sep 24 23:32:30 2000
-@@ -17,7 +17,7 @@
- # Include machine/platform specific information into the build
- include ../machdef.mk
-
--CFLAGS=-I. $(TCL_INCLUDE) $(X_INCLUDE) $(OPTIONS) $(MACHINESPEC) -DPREFIX=\"$(PREFIX)\"
-+CFLAGS+=-I. $(TCL_INCLUDE) $(TK_INCLUDE) $(X_INCLUDE) $(OPTIONS) $(MACHINESPEC) -DPREFIX=\"$(PREFIX)\"
-
- OBJECTS = \
- globals.o \
diff --git a/editors/e93/files/patch-ah b/editors/e93/files/patch-ah
deleted file mode 100644
index cd0d45343b45..000000000000
--- a/editors/e93/files/patch-ah
+++ /dev/null
@@ -1,11 +0,0 @@
---- e93r.orig Fri Sep 29 03:29:30 2000
-+++ e93r Fri Sep 29 03:33:59 2000
-@@ -25,7 +25,7 @@
-
- # NOTE: you may have to adjust the wish to e.g. /usr/local/bin/wish8.3
- # restart using wish \
--exec wish "$0" "$@"
-+exec wish8.2 "$0" "$@"
-
- # check presence of another e93
- set e93present ""
diff --git a/editors/e93/files/patch-channels.c b/editors/e93/files/patch-channels.c
deleted file mode 100644
index 9684436394de..000000000000
--- a/editors/e93/files/patch-channels.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./channels.c.orig Sat May 29 12:01:41 2004
-+++ ./channels.c Wed Dec 20 14:35:21 2006
-@@ -54,7 +54,7 @@
- return(TCL_OK); // nothing for us to do, but this proc must exist
- }
-
--static int StdoutOutputProc(ClientData clientData,const char *buf,int charsToWrite,int *errorCode)
-+static int StdoutOutputProc(ClientData clientData,char *buf,int charsToWrite,int *errorCode)
- // Writes the given output on the IO channel. Returns count of how
- // many characters were actually written, and an error indication.
- {
-@@ -76,7 +76,7 @@
- return(charsWritten);
- }
-
--static int StderrOutputProc(ClientData clientData,const char *buf,int charsToWrite,int *errorCode)
-+static int StderrOutputProc(ClientData clientData,char *buf,int charsToWrite,int *errorCode)
- // Writes the given output on the IO channel. Returns count of how
- // many characters were actually written, and an error indication.
- {
diff --git a/editors/e93/files/patch-ae b/editors/e93/files/patch-machdef.mk
index fdca9bd90079..b4a2bf1e6597 100644
--- a/editors/e93/files/patch-ae
+++ b/editors/e93/files/patch-machdef.mk
@@ -11,12 +11,12 @@
# files are located elsewhere on your system:
-TCL_INCLUDE=-I/usr/local/include
-TCL_LIB=-L/usr/local/lib
-+TCL_INCLUDE=-I${LOCALBASE}/include/tcl8.2
++TCL_INCLUDE=-I${LOCALBASE}/include/tcl8.4
+TCL_LIB=-L${LOCALBASE}/lib
# uncomment and change if you want to link with specific versions of Tcl/Tk
-#TCL_VERSION=8.3
-+TCL_VERSION=82
-+TK_INCLUDE=-I${LOCALBASE}/include/tk8.2
++TCL_VERSION=84
++TK_INCLUDE=-I${LOCALBASE}/include/tk8.4
# The following lines may need to be altered if the X include and library
diff --git a/editors/e93/files/patch-shell.c b/editors/e93/files/patch-shell.c
deleted file mode 100644
index 17ac9c84bde3..000000000000
--- a/editors/e93/files/patch-shell.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./shell.c.orig Mon May 31 19:37:29 2004
-+++ ./shell.c Wed Dec 20 14:24:36 2006
-@@ -935,7 +935,7 @@
- return(TCL_ERROR);
- }
-
--static void TraceCheckAbortProc(ClientData theClientData,Tcl_Interp *theInterpreter,int theLevel,char *theCommand,Tcl_CmdProc *theProc,ClientData cmdClientData,int argc,const char *argv[])
-+static void TraceCheckAbortProc(ClientData theClientData,Tcl_Interp *theInterpreter,int theLevel,char *theCommand,Tcl_CmdProc *theProc,ClientData cmdClientData,int argc,char *argv[])
- // This is a small trick on Tcl. We tell it we want to trace, but really, we want
- // to check to see if the user is trying to abort the execution of a script.
- // So, every time we are called, we check to see if the user is aborting, and
diff --git a/editors/e93/files/patch-shellcmd.c b/editors/e93/files/patch-shellcmd.c
deleted file mode 100644
index 1d92b1a5aade..000000000000
--- a/editors/e93/files/patch-shellcmd.c
+++ /dev/null
@@ -1,111 +0,0 @@
---- ./shellcmd.c.orig Thu Dec 1 16:16:19 2005
-+++ ./shellcmd.c Wed Dec 20 14:34:05 2006
-@@ -199,7 +199,7 @@
- return(false);
- }
-
--static bool GetUINT32String(Tcl_Interp *localInterpreter,const char *theString,UINT32 *theNumber)
-+static bool GetUINT32String(Tcl_Interp *localInterpreter,char *theString,UINT32 *theNumber)
- // convert theString to a UINT32
- // return false if the conversion failed, and fill the Tcl result
- {
-@@ -668,7 +668,7 @@
- {
- for(theIndex=1;!fail&&(int)theIndex<objc;theIndex++)
- {
-- if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[theIndex],NULL),&pathArgc,&pathArgv)==TCL_OK)
-+ if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[theIndex],NULL),&pathArgc,(char ***)&pathArgv)==TCL_OK)
- {
- theMenu=NULL; // start at the root
- if(GetEditorMenu(pathArgc,pathArgv,&theMenu))
-@@ -720,7 +720,7 @@
- {
- if(GetBoolean(localInterpreter,objv[3],&active))
- {
-- if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[1],NULL),&pathArgc,&pathArgv)==TCL_OK)
-+ if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[1],NULL),&pathArgc,(char ***)&pathArgv)==TCL_OK)
- {
- if(CreateEditorMenu(pathArgc,pathArgv,theRelationship,Tcl_GetStringFromObj(objv[4],NULL),Tcl_GetStringFromObj(objv[5],NULL),Tcl_GetStringFromObj(objv[6],NULL),active))
- {
-@@ -1223,7 +1223,7 @@
- fail=false;
- if(objc==3)
- {
-- if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[2],NULL),&listArgc,&listArgv)==TCL_OK)
-+ if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[2],NULL),&listArgc,(char ***)&listArgv)==TCL_OK)
- {
- if((selectedElements=(bool *)MNewPtrClr(sizeof(bool)*listArgc))) // get array of "falses"
- {
-@@ -3696,19 +3696,19 @@
- {
- if(ShellBufferNotBusy(localInterpreter,theBuffer))
- {
-- if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[2],NULL),&listArgc,&listArgv)==TCL_OK)
-+ if(Tcl_SplitList(localInterpreter,Tcl_GetStringFromObj(objv[2],NULL),&listArgc,(char ***)&listArgv)==TCL_OK)
- {
- EditorStartSelectionChange(theBuffer);
- fail=false;
- for(i=0;!fail&&i<listArgc;i++)
- {
-- if(Tcl_SplitList(localInterpreter,listArgv[i],&elementArgc,&elementArgv)==TCL_OK)
-+ if(Tcl_SplitList(localInterpreter,listArgv[i],&elementArgc,(char ***)&elementArgv)==TCL_OK)
- {
- if(elementArgc==2)
- {
-- if(GetUINT32String(localInterpreter,elementArgv[0],&startPosition))
-+ if(GetUINT32String(localInterpreter,(char *)elementArgv[0],&startPosition))
- {
-- if(GetUINT32String(localInterpreter,elementArgv[1],&endPosition))
-+ if(GetUINT32String(localInterpreter,(char *)elementArgv[1],&endPosition))
- {
- startPosition=ForcePositionIntoRange(theBuffer,startPosition);
- endPosition=ForcePositionIntoRange(theBuffer,endPosition);
-@@ -4604,7 +4604,7 @@
- fail;
-
- fail=false;
-- if(Tcl_SplitList(localInterpreter,endExpressionList,&argc,&argv)==TCL_OK) // get list of end expressions
-+ if(Tcl_SplitList(localInterpreter,endExpressionList,&argc,(char ***)&argv)==TCL_OK) // get list of end expressions
- {
- for(i=0;!fail&&i<argc;i++)
- {
-@@ -4654,11 +4654,11 @@
- SetMappingStartExpressionPiece(theMapping,expressionPiece);
- if(ParseEndExpressions(localInterpreter,theMap,theMapping,argv[2]))
- {
-- if(GetUINT32String(localInterpreter,argv[3],&startStyle))
-+ if(GetUINT32String(localInterpreter,(char *)argv[3],&startStyle))
- {
-- if(GetUINT32String(localInterpreter,argv[4],&betweenStyle))
-+ if(GetUINT32String(localInterpreter,(char *)argv[4],&betweenStyle))
- {
-- if(GetUINT32String(localInterpreter,argv[5],&endStyle))
-+ if(GetUINT32String(localInterpreter,(char *)argv[5],&endStyle))
- {
- SetMappingStyles(theMapping,startStyle,betweenStyle,endStyle);
- return(true);
-@@ -4704,13 +4704,13 @@
- i,j;
-
- fail=false;
-- if(Tcl_SplitList(localInterpreter,mapContents,&listArgc,&listArgv)==TCL_OK) // make list of command/parameter
-+ if(Tcl_SplitList(localInterpreter,mapContents,&listArgc,(char ***)&listArgv)==TCL_OK) // make list of command/parameter
- {
- for(i=0;(i<listArgc)&&!fail;i+=2) // step over each command, parameter list pair
- {
- if(MatchToken(listArgv[i],syntaxMapCommands,&syntaxMapToken))
- {
-- if(Tcl_SplitList(localInterpreter,listArgv[i+1],&argc,&argv)==TCL_OK) // make parameters into arguments
-+ if(Tcl_SplitList(localInterpreter,listArgv[i+1],&argc,(char ***)&argv)==TCL_OK) // make parameters into arguments
- {
- switch(syntaxMapToken)
- {
-@@ -4749,7 +4749,7 @@
- {
- if((theMapping=LocateSyntaxStyleMapping(theMap,argv[0])))
- {
-- if(Tcl_SplitList(localInterpreter,argv[1],&mappinglistArgc,&mappinglistArgv)==TCL_OK) // make parameters into arguments
-+ if(Tcl_SplitList(localInterpreter,argv[1],&mappinglistArgc,(char ***)&mappinglistArgv)==TCL_OK) // make parameters into arguments
- {
- for(j=0;j<mappinglistArgc&&!fail;j++)
- {