aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-11-20 03:05:14 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-11-20 03:05:14 +0000
commitbf78d1a03f2900c02ab87ad498acdc0c723d6ff0 (patch)
tree4c0e439f23d18d06f39a95fd3fbc3b3b710169cb /editors
parenta67b59ce5ef84a30238cab663427bc7a60fab079 (diff)
downloadports-bf78d1a03f2900c02ab87ad498acdc0c723d6ff0.tar.gz
ports-bf78d1a03f2900c02ab87ad498acdc0c723d6ff0.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile2
-rw-r--r--editors/coedit/distinfo3
-rw-r--r--editors/coedit/pkg-plist3
-rw-r--r--editors/dexed/Makefile (renamed from editors/coedit/Makefile)16
-rw-r--r--editors/dexed/distinfo3
-rw-r--r--editors/dexed/files/patch-dastworx_build.sh (renamed from editors/coedit/files/patch-dastworx_build.sh)24
-rw-r--r--editors/dexed/files/patch-src_ce__compilers.pas (renamed from editors/coedit/files/patch-src_ce__compilers.pas)0
-rw-r--r--editors/dexed/pkg-descr (renamed from editors/coedit/pkg-descr)4
-rw-r--r--editors/dexed/pkg-plist8
9 files changed, 38 insertions, 25 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 36d0d3d2745d..e4e103f22f07 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -20,11 +20,11 @@
SUBDIR += calligraplan
SUBDIR += chexedit
SUBDIR += codelite
- SUBDIR += coedit
SUBDIR += conglomerate
SUBDIR += cooledit
SUBDIR += cream
SUBDIR += deforaos-editor
+ SUBDIR += dexed
SUBDIR += dhex
SUBDIR += diakonos
SUBDIR += dkns
diff --git a/editors/coedit/distinfo b/editors/coedit/distinfo
deleted file mode 100644
index cb706ae130b6..000000000000
--- a/editors/coedit/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1528011225
-SHA256 (BBasile-Coedit-v3.6.15_GH0.tar.gz) = 0ba71193560784460a7b36ae24e96be211f91aec14776b2bcafeb0597f0fdedd
-SIZE (BBasile-Coedit-v3.6.15_GH0.tar.gz) = 3879879
diff --git a/editors/coedit/pkg-plist b/editors/coedit/pkg-plist
deleted file mode 100644
index 1b2335bba490..000000000000
--- a/editors/coedit/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/coedit
-bin/dastworx
-share/pixmaps/coedit.png
diff --git a/editors/coedit/Makefile b/editors/dexed/Makefile
index 64f1b1a348c4..11a2cb7daae8 100644
--- a/editors/coedit/Makefile
+++ b/editors/dexed/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
-PORTNAME= coedit
-PORTVERSION= 3.6.15
+PORTNAME= dexed
+PORTVERSION= 3.6.21
DISTVERSIONPREFIX=v
CATEGORIES= editors
PKGNAMESUFFIX= ${LAZARUS_PKGNAMESUFFIX}
@@ -24,7 +24,7 @@ RUN_DEPENDS= ldmd2:lang/ldc \
USE_GITHUB= yes
GH_ACCOUNT= BBasile
-GH_PROJECT= Coedit
+#GH_PROJECT= dexed
USES= fpc lazarus:flavors
USE_FPC= chm fcl-base fcl-db fcl-image fcl-json fcl-net fcl-registry \
@@ -32,9 +32,9 @@ USE_FPC= chm fcl-base fcl-db fcl-image fcl-json fcl-net fcl-registry \
regexpr rtl-extra x11
USE_XORG= x11
-DESKTOP_ENTRIES="Coedit" \
+DESKTOP_ENTRIES="Dexed" \
"IDE for the D programming language" \
- "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}32.png" \
"${PREFIX}/bin/${PORTNAME}" \
"Application;IDE;Development;" \
${TRUE}
@@ -42,7 +42,7 @@ DESKTOP_ENTRIES="Coedit" \
D_LIB_DIR= ${LOCALBASE}/lib/d
D_INCLUDE_DIR= ${LOCALBASE}/include/d
-LAZARUS_PROJECT_FILES= anchordocking/anchordocking.lpk lazproj/coedit.lpi
+LAZARUS_PROJECT_FILES= anchordocking/anchordocking.lpk lazproj/dexed.lpi
LAZBUILD_ARGS= -d
@@ -73,8 +73,8 @@ pre-build:
@cd ${WRKSRC}/dastworx && ${SH} build.sh
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/coedit ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
${INSTALL_PROGRAM} ${WRKSRC}/bin/dastworx ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/logo/coedit.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/logo/*.png ${STAGEDIR}${PREFIX}/share/pixmaps/
.include <bsd.port.mk>
diff --git a/editors/dexed/distinfo b/editors/dexed/distinfo
new file mode 100644
index 000000000000..adc585a505ee
--- /dev/null
+++ b/editors/dexed/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1541485057
+SHA256 (BBasile-dexed-v3.6.21_GH0.tar.gz) = 36887f4da9ddb68a98b1135e6cb442e3edd713f743f032f7a0b2fe9b4dad2802
+SIZE (BBasile-dexed-v3.6.21_GH0.tar.gz) = 3769679
diff --git a/editors/coedit/files/patch-dastworx_build.sh b/editors/dexed/files/patch-dastworx_build.sh
index 6a8c0317fdfe..cc250c3f81e1 100644
--- a/editors/coedit/files/patch-dastworx_build.sh
+++ b/editors/dexed/files/patch-dastworx_build.sh
@@ -1,6 +1,11 @@
---- dastworx/build.sh 2018-06-03 02:41:09.063965000 -0500
-+++ dastworx/build.sh 2018-06-03 02:42:21.888100000 -0500
-@@ -1,18 +1,3 @@
+--- dastworx/build.sh 2018-10-22 01:38:52.000000000 -0500
++++ dastworx/build.sh 2018-11-06 01:09:50.779324000 -0500
+@@ -1,35 +1,14 @@
+-if [[ -z "$DC" ]]; then DC=dmd; fi
+-if [[ "$DC" == "ldc" ]]; then DC=ldmd2; fi
+-if [[ "$DC" == "gdc" ]]; then DC=gdmd; fi
+-if [[ -z "$MFLAGS" ]]; then MFLAGS=-m64; fi
+-
-#iz sources
-cd ../etc/iz/import/
-iz=$(find `pwd` -type f -name \*.d)
@@ -19,15 +24,18 @@
#dast sources
cd src/
dast=$(find `pwd` -type f -name \*.d)
-@@ -21,10 +6,10 @@
- echo building...
+ cd ../
+-echo building using $DC...
+-
#build
--dmd ${dast[@]} ${dparse[@]} ${iz[@]} ${stdxalloc[@]} \
-+%%LDMD2_CMD%% ${dast} \
- -O -release -inline -boundscheck=off \
+-$DC ${dast[@]} ${dparse[@]} ${iz[@]} ${stdxalloc[@]} \
+--O -release -inline -boundscheck=off $MFLAGS \
--Isrc -I../etc/iz/import -I../etc/libdparse/src -I../etc/stdx-allocator/source \
--of../bin/dastworx
++
++%%LDMD2_CMD%% ${dast} \
++ -O -release -inline -boundscheck=off \
+-Isrc -I%%D_INCLUDE_DIR%% -L%%D_LIB_DIR%%/libiz.a -L%%D_LIB_DIR%%/libdparse.a \
+-L%%D_LIB_DIR%%/libstdx-allocator.a -of../bin/dastworx
diff --git a/editors/coedit/files/patch-src_ce__compilers.pas b/editors/dexed/files/patch-src_ce__compilers.pas
index b30428423f07..b30428423f07 100644
--- a/editors/coedit/files/patch-src_ce__compilers.pas
+++ b/editors/dexed/files/patch-src_ce__compilers.pas
diff --git a/editors/coedit/pkg-descr b/editors/dexed/pkg-descr
index be8a4169c6c8..739f4a23f4f7 100644
--- a/editors/coedit/pkg-descr
+++ b/editors/dexed/pkg-descr
@@ -1,4 +1,4 @@
-Coedit is an IDE for the D programming language, its compilers, tools and
+Dexed is an IDE for the D programming language, its compilers, tools and
libraries.
- available for Windows, Linux and FreeBSD.
- supports all the D compilers (DMD-GDC-LDC).
@@ -21,4 +21,4 @@ libraries.
- user-defined tools powered by a string interpolation system.
- mini file browser, dfmt interface, search & replace and more
-WWW: https://github.com/BBasile/Coedit
+WWW: https://github.com/BBasile/dexed
diff --git a/editors/dexed/pkg-plist b/editors/dexed/pkg-plist
new file mode 100644
index 000000000000..16a464d6bb73
--- /dev/null
+++ b/editors/dexed/pkg-plist
@@ -0,0 +1,8 @@
+bin/dexed
+bin/dastworx
+share/pixmaps/dexed128.png
+share/pixmaps/dexed16.png
+share/pixmaps/dexed256.png
+share/pixmaps/dexed32.png
+share/pixmaps/dexed48.png
+share/pixmaps/dexed64.png