aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-08-05 19:40:23 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-08-05 19:40:23 +0000
commitd5557c5600f61becf9dcbd16669a409300f1e659 (patch)
treef02de854e2a3f034bbb94efda5d3fe9818a13150 /editors
parent59449d6e30fec1443e667a5c5cba51b933df0acc (diff)
downloadports-d5557c5600f61becf9dcbd16669a409300f1e659.tar.gz
ports-d5557c5600f61becf9dcbd16669a409300f1e659.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/texmaker/Makefile24
-rw-r--r--editors/texmaker/distinfo6
-rw-r--r--editors/texmaker/files/patch-texmaker.pro26
-rw-r--r--editors/texmaker/pkg-plist118
4 files changed, 103 insertions, 71 deletions
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 90a2910421fb..ad5842c32446 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= texmaker
-PORTVERSION= 1.8
-PORTREVISION= 1
+PORTVERSION= 1.9.2
PORTEPOCH= 1
CATEGORIES= editors
MASTER_SITES= http://www.xm1math.net/texmaker/
@@ -23,14 +22,18 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
USE_BZIP2= yes
USE_GHOSTSCRIPT=yes
USE_QT_VER= 4
-QT_COMPONENTS= gui network moc_build qmake_build rcc_build uic_build
+QT_COMPONENTS= gui network xml moc_build qmake_build rcc_build uic_build
HAS_CONFIGURE= yes
-INSTALLS_ICONS= yes
+QMAKE_ARGS= PREFIX=${PREFIX} ICONDIR=${PREFIX}/share/pixmaps \
+ DESKTOPDIR=${DESKTOPDIR} -unix
+MAKE_JOBS_SAFE= yes
OPTIONS= XDVI "view dvi with xdvi" On \
GV "view ps with gv" On \
XPDF "view pdf with xpdf" On
+STRIP_FILES= bin/texmaker
+
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_XDVI)
@@ -45,12 +48,15 @@ RUN_DEPENDS+= gv:${PORTSDIR}/print/gv
RUN_DEPENDS+= xpdf:${PORTSDIR}/graphics/xpdf
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's,^\(utilities.path =\).*,\1 ${DATADIR},' \
- ${WRKSRC}/texmaker.pro
-
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} -unix PREFIX=${PREFIX} texmaker.pro
+ ${QMAKE} ${QMAKE_ARGS} texmaker.pro
+
+post-configure:
+ @${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|^CC .*|CC=${CC}|; s|^CXX .*|CXX=${CXX}|; s|^LINK .*|LINK=${CXX}|'
+
+post-install:
+ ${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
.include <bsd.port.post.mk>
diff --git a/editors/texmaker/distinfo b/editors/texmaker/distinfo
index a0811b2b1069..7f9d1038cec9 100644
--- a/editors/texmaker/distinfo
+++ b/editors/texmaker/distinfo
@@ -1,3 +1,3 @@
-MD5 (texmaker-1.8.tar.bz2) = c25bdd9d0dae2be802d53bcc3189d6ea
-SHA256 (texmaker-1.8.tar.bz2) = 1268f43a548c6c194ea848d5c70c429386b962f5685f16eb427267921f7ad944
-SIZE (texmaker-1.8.tar.bz2) = 1767680
+MD5 (texmaker-1.9.2.tar.bz2) = 61842ccacf7d843e497aa74f7135d04a
+SHA256 (texmaker-1.9.2.tar.bz2) = 6b479788cbce4b940eb78fa011d1ee52c4959c4dc01441ed9a82b045131a10c6
+SIZE (texmaker-1.9.2.tar.bz2) = 3094044
diff --git a/editors/texmaker/files/patch-texmaker.pro b/editors/texmaker/files/patch-texmaker.pro
index 4063290471ce..e3a4207141e1 100644
--- a/editors/texmaker/files/patch-texmaker.pro
+++ b/editors/texmaker/files/patch-texmaker.pro
@@ -1,20 +1,23 @@
---- ./texmaker.pro.orig 2008-04-23 17:30:45.000000000 +0400
-+++ ./texmaker.pro 2008-05-26 22:12:38.000000000 +0400
-@@ -161,16 +161,26 @@
- utilities/fr_FR.dic \
+--- ./texmaker.pro.orig 2009-05-12 14:43:45.000000000 +0400
++++ ./texmaker.pro 2009-07-06 11:00:46.000000000 +0400
+@@ -200,13 +200,6 @@
utilities/AUTHORS \
utilities/COPYING \
-- utilities/CHANGELOG.txt \
+ utilities/CHANGELOG.txt \
- utilities/texmaker16x16.png \
- utilities/texmaker22x22.png \
- utilities/texmaker32x32.png \
- utilities/texmaker48x48.png \
- utilities/texmaker64x64.png \
- utilities/texmaker128x128.png \
-- utilities/texmaker.desktop \
-- utilities/texmaker.svg
-+ utilities/CHANGELOG.txt
- INSTALLS += utilities
+- utilities/texmaker.svg \
+ locale/qt_de.qm \
+ locale/qt_es.qm \
+ locale/qt_fr.qm \
+@@ -246,6 +239,21 @@
+ icon.path = $${ICONDIR}
+ icon.files = utilities/texmaker.png
+ INSTALLS += icon
+icon16.path = $${PREFIX}/share/icons/hicolor/16x16/apps
+icon16.files= utilities/texmaker16x16.png
+icon22.path = $${PREFIX}/share/icons/hicolor/22x22/apps
@@ -30,9 +33,6 @@
+iconscale.path=$${PREFIX}/share/icons/hicolor/scalable/apps
+iconscale.files=utilities/texmaker.svg
+INSTALLS += icon16 icon22 icon32 icon48 icon64 icon128 iconscale
-+desktop.path = $${PREFIX}/share/applications
-+desktop.files= utilities/texmaker.desktop
-+INSTALLS += desktop
}
################################
- win32 { \ No newline at end of file
+ win32 {
diff --git a/editors/texmaker/pkg-plist b/editors/texmaker/pkg-plist
index 5cac3cbee025..eaf5c636d95e 100644
--- a/editors/texmaker/pkg-plist
+++ b/editors/texmaker/pkg-plist
@@ -7,50 +7,76 @@ share/icons/hicolor/32x32/apps/texmaker32x32.png
share/icons/hicolor/48x48/apps/texmaker48x48.png
share/icons/hicolor/64x64/apps/texmaker64x64.png
share/icons/hicolor/scalable/apps/texmaker.svg
-%%DATADIR%%/AUTHORS
-%%DATADIR%%/CHANGELOG.txt
-%%DATADIR%%/COPYING
-%%DATADIR%%/blank.png
-%%DATADIR%%/doc1.png
-%%DATADIR%%/doc10.png
-%%DATADIR%%/doc11.png
-%%DATADIR%%/doc12.png
-%%DATADIR%%/doc13.png
-%%DATADIR%%/doc14.png
-%%DATADIR%%/doc15.png
-%%DATADIR%%/doc16.png
-%%DATADIR%%/doc17.png
-%%DATADIR%%/doc18.png
-%%DATADIR%%/doc19.png
-%%DATADIR%%/doc2.png
-%%DATADIR%%/doc20.png
-%%DATADIR%%/doc3.png
-%%DATADIR%%/doc4.png
-%%DATADIR%%/doc5.png
-%%DATADIR%%/doc6.png
-%%DATADIR%%/doc7.png
-%%DATADIR%%/doc8.png
-%%DATADIR%%/doc9.png
-%%DATADIR%%/en_GB.aff
-%%DATADIR%%/en_GB.dic
-%%DATADIR%%/fr_FR.aff
-%%DATADIR%%/fr_FR.dic
-%%DATADIR%%/latexhelp.html
-%%DATADIR%%/next.gif
-%%DATADIR%%/next_d.gif
-%%DATADIR%%/prev.gif
-%%DATADIR%%/prev_d.gif
-%%DATADIR%%/qt_de.qm
-%%DATADIR%%/qt_fr.qm
-%%DATADIR%%/qt_zh.qm
-%%DATADIR%%/psheader.txt
-%%DATADIR%%/style.css
-%%DATADIR%%/texmaker_de.qm
-%%DATADIR%%/texmaker_fr.qm
-%%DATADIR%%/texmaker_zh.qm
-%%DATADIR%%/up.gif
-%%DATADIR%%/up_d.gif
-%%DATADIR%%/usermanual_en.html
-%%DATADIR%%/usermanual_fr.html
-@dirrm %%DATADIR%%
+share/pixmaps/texmaker.png
+share/texmaker/AUTHORS
+share/texmaker/CHANGELOG.txt
+share/texmaker/COPYING
+share/texmaker/README_DIC_fr_FR.txt
+share/texmaker/README_de_DE_frami.txt
+share/texmaker/README_es_ES.txt
+share/texmaker/blank.png
+share/texmaker/de_DE.aff
+share/texmaker/de_DE.dic
+share/texmaker/doc1.png
+share/texmaker/doc10.png
+share/texmaker/doc11.png
+share/texmaker/doc12.png
+share/texmaker/doc13.png
+share/texmaker/doc14.png
+share/texmaker/doc15.png
+share/texmaker/doc16.png
+share/texmaker/doc17.png
+share/texmaker/doc18.png
+share/texmaker/doc19.png
+share/texmaker/doc2.png
+share/texmaker/doc20.png
+share/texmaker/doc21.png
+share/texmaker/doc22.png
+share/texmaker/doc3.png
+share/texmaker/doc4.png
+share/texmaker/doc5.png
+share/texmaker/doc6.png
+share/texmaker/doc6bis.png
+share/texmaker/doc7.png
+share/texmaker/doc8.png
+share/texmaker/doc9.png
+share/texmaker/en_GB.aff
+share/texmaker/en_GB.dic
+share/texmaker/es_ES.aff
+share/texmaker/es_ES.dic
+share/texmaker/fr_FR.aff
+share/texmaker/fr_FR.dic
+share/texmaker/it_IT.aff
+share/texmaker/it_IT.dic
+share/texmaker/it_IT_README.txt
+share/texmaker/latexhelp.html
+share/texmaker/next.gif
+share/texmaker/next_d.gif
+share/texmaker/prev.gif
+share/texmaker/prev_d.gif
+share/texmaker/psheader.txt
+share/texmaker/qt_de.qm
+share/texmaker/qt_es.qm
+share/texmaker/qt_fr.qm
+share/texmaker/qt_pt.qm
+share/texmaker/qt_ru.qm
+share/texmaker/qt_zh_CN.qm
+share/texmaker/qt_zh_TW.qm
+share/texmaker/style.css
+share/texmaker/texmaker_ca.qm
+share/texmaker/texmaker_de.qm
+share/texmaker/texmaker_es.qm
+share/texmaker/texmaker_fa.qm
+share/texmaker/texmaker_fr.qm
+share/texmaker/texmaker_gl.qm
+share/texmaker/texmaker_it.qm
+share/texmaker/texmaker_pt_BR.qm
+share/texmaker/texmaker_ru.qm
+share/texmaker/texmaker_zh_CN.qm
+share/texmaker/texmaker_zh_TW.qm
+share/texmaker/up.gif
+share/texmaker/up_d.gif
+share/texmaker/usermanual_en.html
+share/texmaker/usermanual_fr.html
+@dirrm share/texmaker
@dirrmtry share/applications