aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-05-16 03:33:40 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-05-16 03:33:40 +0000
commite9c55e7cb5ce0b2830cac136aa0883024d679c4e (patch)
treef8afd72a0a0f0e0e12100663b8fdfaa366c8890c /editors
parent2a50e4e47cfb89df4666f2ebb061d67d0ec2306b (diff)
downloadports-e9c55e7cb5ce0b2830cac136aa0883024d679c4e.tar.gz
ports-e9c55e7cb5ce0b2830cac136aa0883024d679c4e.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/cooledit/Makefile44
-rw-r--r--editors/cooledit/distinfo2
-rw-r--r--editors/cooledit/files/patch-ac11
-rw-r--r--editors/cooledit/files/patch-ad11
-rw-r--r--editors/cooledit/files/patch-ae11
-rw-r--r--editors/cooledit/files/patch-af11
-rw-r--r--editors/cooledit/files/patch-ag11
-rw-r--r--editors/cooledit/files/patch-ah29
-rw-r--r--editors/cooledit/files/patch-ai11
-rw-r--r--editors/cooledit/files/patch-aj23
-rw-r--r--editors/cooledit/files/patch-al11
-rw-r--r--editors/cooledit/files/patch-config.h14
-rw-r--r--editors/cooledit/files/patch-icon::Makefile.in11
-rw-r--r--editors/cooledit/files/patch-icon::coolicon.c (renamed from editors/cooledit/files/patch-ak)0
-rw-r--r--editors/cooledit/files/patch-intl::Makefile.in11
-rw-r--r--editors/cooledit/files/patch-ltmain.sh33
-rw-r--r--editors/cooledit/pkg-plist8
17 files changed, 87 insertions, 165 deletions
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index 3cca878c9573..54e455f6c0e1 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -6,43 +6,37 @@
#
PORTNAME= cooledit
-PORTVERSION= 3.17.5
-PORTREVISION= 1
+PORTVERSION= 3.17.7
CATEGORIES= editors
-MASTER_SITES= http://cooledit.sourceforge.net/ \
- ${MASTER_SITE_SUNSITE} \
- http://www.netins.net/showcase/Comput-IT/cooledit/src/
-MASTER_SITE_SUBDIR= apps/editors/X/cooledit
+MASTER_SITES= http://cooledit.sourceforge.net/
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Suite of utilities, including a GUI editor
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
vga.1:${PORTSDIR}/graphics/svgalib
-USE_LIBTOOL= yes
-INSTALLS_SHLIB= yes
-USE_XLIB= yes
USE_XPM= yes
+USE_PYTHON= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --with-libs='-lcrypt -lreadline -lvga -lintl' \
+ --disable-mail-author
+INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --with-libs='-lcrypt -lreadline -lvga' \
- --disable-mail-author --without-included-gettext
-CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-MAN1= cooledit.1 smalledit.1 coolman.1 coolicon.1
-
-pre-install:
- @${ECHO_MSG} "Installing in ${PREFIX}/bin"
- @if [ ! -f ${PREFIX}/etc/coolicon.config ]; then \
- ${INSTALL_SCRIPT} ${WRKSRC}/pixmap/coolicon.config \
- ${PREFIX}/etc ; \
- fi
- ${INSTALL_SCRIPT} ${WRKSRC}/pixmap/coolicon.config \
- ${PREFIX}/etc/coolicon.config.dist
+MAN1= cooledit.1 coolicon.1 coolman.1 smalledit.1
post-install:
+ ${INSTALL_DATA} ${WRKSRC}/pixmap/coolicon.config \
+ ${PREFIX}/etc/coolicon.config.dist
+.if !exists(${PREFIX}/etc/coolicon.config)
+ ${INSTALL_DATA} ${WRKSRC}/pixmap/coolicon.config \
+ ${PREFIX}/etc/coolicon.config
+.endif
@${LN} -sf ${PREFIX}/share/cooledit/global.py \
${PREFIX}/share/coolicon/global.py
diff --git a/editors/cooledit/distinfo b/editors/cooledit/distinfo
index 2b2f8fbc3d2f..7f937c5c5565 100644
--- a/editors/cooledit/distinfo
+++ b/editors/cooledit/distinfo
@@ -1 +1 @@
-MD5 (cooledit-3.17.5.tar.gz) = 087b2ad31a4d63d8d6da31da5ade35a0
+MD5 (cooledit-3.17.7.tar.gz) = 06e16994ebc2108e04dc7c6bd29981de
diff --git a/editors/cooledit/files/patch-ac b/editors/cooledit/files/patch-ac
deleted file mode 100644
index bce2dd765710..000000000000
--- a/editors/cooledit/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- icon/Makefile.in.orig Sun May 30 07:47:33 1999
-+++ icon/Makefile.in Mon Jun 7 14:54:23 1999
-@@ -119,7 +119,7 @@
- datadir = $(prefix)/@DATADIRNAME@
- localedir = $(datadir)/locale
-
--DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/coolicon\" @DEFS@
-+DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/coolicon\" -DSYSCONFDIR=\"$(sysconfdir)\" -DDATADIR=\"$(datadir)/coolicon\" @DEFS@
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
- CONFIG_CLEAN_FILES =
diff --git a/editors/cooledit/files/patch-ad b/editors/cooledit/files/patch-ad
deleted file mode 100644
index b31264e0e7e4..000000000000
--- a/editors/cooledit/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- icon/iconmanager.c.orig Mon Jun 7 14:43:54 1999
-+++ icon/iconmanager.c Mon Jun 7 14:44:08 1999
-@@ -443,7 +443,7 @@
- if (p->x + 20 > WidthOfScreen (DefaultScreenOfDisplay (CDisplay)))
- p->x = WidthOfScreen (DefaultScreenOfDisplay (CDisplay)) - 20;
- if (*p->xpm_filename != '/')
-- f = catstrs (LIBDIR, "/", p->xpm_filename, 0);
-+ f = catstrs (DATADIR, "/", p->xpm_filename, 0);
- else
- f = p->xpm_filename;
- w = CDrawIcon (catstrs ("_icon", itoa (n), 0), CRoot, p->x, p->y, f, p->title);
diff --git a/editors/cooledit/files/patch-ae b/editors/cooledit/files/patch-ae
deleted file mode 100644
index 309103896a48..000000000000
--- a/editors/cooledit/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- syntax/Makefile.in.orig Tue Nov 30 02:34:36 1999
-+++ syntax/Makefile.in Wed Jan 26 18:35:05 2000
-@@ -99,7 +99,7 @@
- VERSION = @VERSION@
- l = @l@
-
--syntaxdir = $(libdir)/cooledit/syntax
-+syntaxdir = $(datadir)/cooledit/syntax
-
- syntax_DATA = c.syntax changelog.syntax diff.syntax diffc.syntax html.syntax java.syntax latex.syntax lsm.syntax makefile.syntax ml.syntax nroff.syntax pascal.syntax perl.syntax python.syntax sh.syntax smalltalk.syntax texinfo.syntax unknown.syntax swig.syntax mail.syntax ada95.syntax
-
diff --git a/editors/cooledit/files/patch-af b/editors/cooledit/files/patch-af
deleted file mode 100644
index 8a15854d8a49..000000000000
--- a/editors/cooledit/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- widget/syntax.c.orig Tue Nov 30 02:34:27 1999
-+++ widget/syntax.c Wed Jan 26 18:36:26 2000
-@@ -590,7 +590,7 @@
- f = fopen (p, "r");
- if (f)
- return f;
-- strcpy (p, LIBDIR "/syntax/");
-+ strcpy (p, DATADIR "/cooledit/syntax/");
- strcat (p, filename);
- syntax_free (error_file_name);
- error_file_name = (char *) strdup (p);
diff --git a/editors/cooledit/files/patch-ag b/editors/cooledit/files/patch-ag
deleted file mode 100644
index 0c5244b8beb7..000000000000
--- a/editors/cooledit/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- widget/Makefile.in.orig Mon Jun 7 15:15:24 1999
-+++ widget/Makefile.in Mon Jun 7 15:17:00 1999
-@@ -113,7 +113,7 @@
-
- libCw_la_LDFLAGS = -version-info 1:0:0
-
--DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/cooledit\" @DEFS@
-+DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/cooledit\" -DDATADIR=\"$(datadir)\" @DEFS@
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
- CONFIG_CLEAN_FILES =
diff --git a/editors/cooledit/files/patch-ah b/editors/cooledit/files/patch-ah
deleted file mode 100644
index 14504b9fd61f..000000000000
--- a/editors/cooledit/files/patch-ah
+++ /dev/null
@@ -1,29 +0,0 @@
---- editor/coolpython.c.orig Thu Jan 27 22:59:34 2000
-+++ editor/coolpython.c Thu Jan 27 23:00:34 2000
-@@ -1487,7 +1487,7 @@
- PyDict_SetItemString (d, "Mod3Mask", PyInt_FromLong ((long) Mod3Mask));
- PyDict_SetItemString (d, "Mod4Mask", PyInt_FromLong ((long) Mod4Mask));
- PyDict_SetItemString (d, "Mod5Mask", PyInt_FromLong ((long) Mod5Mask));
-- PyDict_SetItemString (d, "LIBDIR", PyString_FromString (LIBDIR));
-+ PyDict_SetItemString (d, "DATADIR", PyString_FromString (DATADIR));
-
- PyDict_SetItemString (d, "Mod5Mask", PyInt_FromLong ((long) Mod5Mask));
-
-@@ -1569,7 +1569,7 @@
- import sys\n\
- sys.path.append('%s')\n\
- sys.path.append('%s%s')\n\
--", LIBDIR, home_dir, EDIT_DIR);
-+", DATADIR, home_dir, EDIT_DIR);
- e = PyRun_String (s, Py_file_input, name_space, name_space);
- if (!e) {
- PyErr_Print ();
-@@ -1578,7 +1578,7 @@
- }
- Py_DECREF (e);
- coolpython_constants (name_space);
-- sprintf (s, "%s/%s", LIBDIR, GLOBAL_STARTUP_FILE);
-+ sprintf (s, "%s/%s", DATADIR, GLOBAL_STARTUP_FILE);
- coolpython_run_file (s);
- sprintf (s, "%s%s/%s", home_dir, EDIT_DIR, GLOBAL_STARTUP_FILE);
- if ((fd = open (s, O_RDONLY)) >= 0)
diff --git a/editors/cooledit/files/patch-ai b/editors/cooledit/files/patch-ai
deleted file mode 100644
index db8a14013322..000000000000
--- a/editors/cooledit/files/patch-ai
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Mon Jun 7 15:25:44 1999
-+++ lib/Makefile.in Mon Jun 7 15:25:54 1999
-@@ -99,7 +99,7 @@
- VERSION = @VERSION@
- l = @l@
-
--pythondir = $(libdir)/cooledit
-+pythondir = $(datadir)/cooledit
-
- python_DATA = global.py
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/editors/cooledit/files/patch-aj b/editors/cooledit/files/patch-aj
deleted file mode 100644
index 3f56b16090c2..000000000000
--- a/editors/cooledit/files/patch-aj
+++ /dev/null
@@ -1,23 +0,0 @@
---- pixmap/Makefile.in.orig Mon Jun 7 14:39:02 1999
-+++ pixmap/Makefile.in Mon Jun 7 14:40:45 1999
-@@ -99,9 +99,9 @@
- VERSION = @VERSION@
- l = @l@
-
--pixmapdir = $(libdir)/coolicon
-+pixmapdir = $(datadir)/coolicon
-
--pixmap_DATA = browse.xpm cooledit.xpm coolicon.config dynamite.xpm e.data launch.xpm manual.xpm mc.xpm netscape.xpm nscape.xpm phonedown.xpm phoneup.xpm printer.xpm spanner.xpm xterm.xpm xv.xpm cdrom_eject.xpm cdrom_view.xpm modify-xinitrc gmc.xpm lyx.xpm
-+pixmap_DATA = browse.xpm cooledit.xpm dynamite.xpm e.data launch.xpm manual.xpm mc.xpm netscape.xpm nscape.xpm phonedown.xpm phoneup.xpm printer.xpm spanner.xpm xterm.xpm xv.xpm cdrom_eject.xpm cdrom_view.xpm gmc.xpm lyx.xpm
-
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
-@@ -227,8 +227,6 @@
-
-
- install-data-local:
-- chmod 0755 $(libdir)/coolicon/modify-xinitrc
-- $(libdir)/coolicon/modify-xinitrc
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/editors/cooledit/files/patch-al b/editors/cooledit/files/patch-al
deleted file mode 100644
index 73ee55c9b3f4..000000000000
--- a/editors/cooledit/files/patch-al
+++ /dev/null
@@ -1,11 +0,0 @@
---- editor/Makefile.in.orig Fri Jan 28 22:41:04 2000
-+++ editor/Makefile.in Fri Jan 28 22:41:32 2000
-@@ -116,7 +116,7 @@
- datadir = $(prefix)/@DATADIRNAME@
- localedir = $(datadir)/locale
-
--DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/cooledit\" @DEFS@
-+DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/lib/cooledit\" -DSYSCONFDIR=\"$(sysconfdir)\" -DDATADIR=\"$(datadir)/coolicon\" @DEFS@
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
- CONFIG_CLEAN_FILES =
diff --git a/editors/cooledit/files/patch-config.h b/editors/cooledit/files/patch-config.h
index 4473cf9aaa92..f63cd065b655 100644
--- a/editors/cooledit/files/patch-config.h
+++ b/editors/cooledit/files/patch-config.h
@@ -1,11 +1,11 @@
---- config.h.in.old Thu Aug 23 19:43:12 2001
-+++ config.h.in Thu Aug 23 19:43:44 2001
-@@ -420,7 +420,7 @@
- #undef HAVE_UNISTD_H
+--- config.h.in.orig Sat Aug 3 20:04:12 2002
++++ config.h.in Thu May 1 00:37:22 2003
+@@ -330,7 +330,7 @@
+ #undef HAVE_VPRINTF
- /* Define if you have the <wchar.h> header file. */
+ /* Define to 1 if you have the <wchar.h> header file. */
-#undef HAVE_WCHAR_H
+/* #undef HAVE_WCHAR_H */
- /* Define if you have the i library (-li). */
- #undef HAVE_LIBI
+ /* 0 */
+ #undef HAVE_XPOINTER
diff --git a/editors/cooledit/files/patch-icon::Makefile.in b/editors/cooledit/files/patch-icon::Makefile.in
new file mode 100644
index 000000000000..652d8bf6d1eb
--- /dev/null
+++ b/editors/cooledit/files/patch-icon::Makefile.in
@@ -0,0 +1,11 @@
+--- icon/Makefile.in.orig Sat Aug 3 20:04:13 2002
++++ icon/Makefile.in Thu May 1 00:44:36 2003
+@@ -158,7 +158,7 @@
+ coolinput_LDADD = ../widget/libCw.la -lX11 @LIBINTL@
+ localedir = $(datadir)/locale
+
+-DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/share/coolicon\" @DEFS@
++DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"${exec_prefix}/share/coolicon\" -DSYSCONFDIR=\"$(sysconfdir)\" @DEFS@
+ subdir = icon
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = $(top_builddir)/config.h
diff --git a/editors/cooledit/files/patch-ak b/editors/cooledit/files/patch-icon::coolicon.c
index 4e98815650f4..4e98815650f4 100644
--- a/editors/cooledit/files/patch-ak
+++ b/editors/cooledit/files/patch-icon::coolicon.c
diff --git a/editors/cooledit/files/patch-intl::Makefile.in b/editors/cooledit/files/patch-intl::Makefile.in
new file mode 100644
index 000000000000..228226376e2c
--- /dev/null
+++ b/editors/cooledit/files/patch-intl::Makefile.in
@@ -0,0 +1,11 @@
+--- intl/Makefile.in.orig Sat Aug 3 20:04:13 2002
++++ intl/Makefile.in Fri May 9 12:03:32 2003
+@@ -141,7 +141,7 @@
+ # separate library.
+ # If you want to use the one which comes with this version of the
+ # package, you have to use `configure --with-included-gettext'.
+-install: install-exec install-data
++install: # install-exec install-data
+ install-exec: all
+ if test "$(PACKAGE)" = "gettext" \
+ && test '@INTLOBJS@' = '$(GETTOBJS)'; then \
diff --git a/editors/cooledit/files/patch-ltmain.sh b/editors/cooledit/files/patch-ltmain.sh
new file mode 100644
index 000000000000..132696966936
--- /dev/null
+++ b/editors/cooledit/files/patch-ltmain.sh
@@ -0,0 +1,33 @@
+--- ltmain.sh.orig Sat Aug 3 20:03:26 2002
++++ ltmain.sh Sat May 10 15:52:10 2003
+@@ -1043,7 +1043,7 @@
+ # These systems don't actually have a C library (as such)
+ test "X$arg" = "X-lc" && continue
+ ;;
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ test "X$arg" = "X-lc" && continue
+ ;;
+@@ -2441,7 +2441,7 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
+ *)
+@@ -4210,10 +4210,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/editors/cooledit/pkg-plist b/editors/cooledit/pkg-plist
index 550eeb958390..cfe3deeaeda9 100644
--- a/editors/cooledit/pkg-plist
+++ b/editors/cooledit/pkg-plist
@@ -15,14 +15,13 @@ etc/coolicon.config.dist
lib/libCw.a
lib/libCw.so
lib/libCw.so.1
-share/cooledit/Xmlrpclib.py
share/cooledit/c_utils.py
share/cooledit/global.py
share/cooledit/sh_utils.py
-share/cooledit/zope_utils.py
share/cooledit/syntax/ada95.syntax
share/cooledit/syntax/bapc.syntax
share/cooledit/syntax/c.syntax
+share/cooledit/syntax/css.syntax
share/cooledit/syntax/changelog.syntax
share/cooledit/syntax/diff.syntax
share/cooledit/syntax/fortran.syntax
@@ -44,14 +43,17 @@ share/cooledit/syntax/php.syntax
share/cooledit/syntax/prolog.syntax
share/cooledit/syntax/python.syntax
share/cooledit/syntax/sh.syntax
+share/cooledit/syntax/sql.syntax
share/cooledit/syntax/smalltalk.syntax
share/cooledit/syntax/swig.syntax
share/cooledit/syntax/texinfo.syntax
share/cooledit/syntax/unknown.syntax
+share/cooledit/syntax/xml.syntax
share/coolicon/browse.xpm
share/coolicon/cdrom_eject.xpm
share/coolicon/cdrom_view.xpm
share/coolicon/cooledit.xpm
+share/coolicon/coolicon.config
share/coolicon/dynamite.xpm
share/coolicon/e.data
share/coolicon/global.py
@@ -84,6 +86,6 @@ share/locale/pt/LC_MESSAGES/cooledit.mo
share/locale/ru/LC_MESSAGES/cooledit.mo
share/locale/sl/LC_MESSAGES/cooledit.mo
share/locale/sv/LC_MESSAGES/cooledit.mo
+@dirrm share/coolicon
@dirrm share/cooledit/syntax
@dirrm share/cooledit
-@dirrm share/coolicon