aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>1999-09-08 14:53:08 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>1999-09-08 14:53:08 +0000
commit117abf6fda46ce3cfcae26ef6f03c7aef512599c (patch)
treeaf5b6019bf50e19a4537e5f29f8ef25866c41d8a /editors
parent3dcd7ea6d573e02bd0df066afce60d13514fd619 (diff)
downloadports-117abf6fda46ce3cfcae26ef6f03c7aef512599c.tar.gz
ports-117abf6fda46ce3cfcae26ef6f03c7aef512599c.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/apel-emacs/Makefile7
-rw-r--r--editors/apel/Makefile7
2 files changed, 14 insertions, 0 deletions
diff --git a/editors/apel-emacs/Makefile b/editors/apel-emacs/Makefile
index ac2a866ddcbd..cfb84bd18f10 100644
--- a/editors/apel-emacs/Makefile
+++ b/editors/apel-emacs/Makefile
@@ -53,6 +53,13 @@ RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}-common
.else
RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}
.endif
+
+# depends on custom: emacs-19.34 or mule-19.34
+.if (${EMACS_VER} == "19.34")
+BUILD_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT}
+RUN_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT}
+.endif
+
SCRIPTS_ENV= EMACS_LIBDIR=${EMACS_LIBDIR} EMACS_VER=${EMACS_VER} \
EMACS_LIBDIR_WITH_VER=${EMACS_LIBDIR_WITH_VER} \
TARGETS="${APEL_SETUPEL}"
diff --git a/editors/apel/Makefile b/editors/apel/Makefile
index ac2a866ddcbd..cfb84bd18f10 100644
--- a/editors/apel/Makefile
+++ b/editors/apel/Makefile
@@ -53,6 +53,13 @@ RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}-common
.else
RUN_DEPENDS= ${EMACS_CMD}:${PORTSDIR}/editors/${EMACS_PORT}
.endif
+
+# depends on custom: emacs-19.34 or mule-19.34
+.if (${EMACS_VER} == "19.34")
+BUILD_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT}
+RUN_DEPENDS+= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp/custom.el:${PORTSDIR}/editors/custom-${EMACS_PORT}
+.endif
+
SCRIPTS_ENV= EMACS_LIBDIR=${EMACS_LIBDIR} EMACS_VER=${EMACS_VER} \
EMACS_LIBDIR_WITH_VER=${EMACS_LIBDIR_WITH_VER} \
TARGETS="${APEL_SETUPEL}"