aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-11-24 12:40:34 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-11-24 12:40:34 +0000
commit40c62da70ecb24d8da33b12f32f96b62871534c1 (patch)
tree54d8a54aa2ef62a2d7d54ef62043b1ac1212793d /editors
parentd04dfd0e1ba946db965231d77b40c6562bc7b22b (diff)
downloadports-40c62da70ecb24d8da33b12f32f96b62871534c1.tar.gz
ports-40c62da70ecb24d8da33b12f32f96b62871534c1.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/xemacs-devel-mule/Makefile1
-rw-r--r--editors/xemacs-devel-mule/files/patch-mule-coding.c23
-rw-r--r--editors/xemacs-devel-mule/files/patch-window.c24
3 files changed, 48 insertions, 0 deletions
diff --git a/editors/xemacs-devel-mule/Makefile b/editors/xemacs-devel-mule/Makefile
index f81d9825ee9b..9c67a75564dc 100644
--- a/editors/xemacs-devel-mule/Makefile
+++ b/editors/xemacs-devel-mule/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xemacs-devel-mule
PORTVERSION= ${XEMACS_VER:S/-/./}
+PORTREVISION= 1
CATEGORIES+= editors
MASTER_SITES= ${MASTER_SITE_XEMACS}
MASTER_SITE_SUBDIR= xemacs-${XEMACS_REL}
diff --git a/editors/xemacs-devel-mule/files/patch-mule-coding.c b/editors/xemacs-devel-mule/files/patch-mule-coding.c
new file mode 100644
index 000000000000..668a870899d9
--- /dev/null
+++ b/editors/xemacs-devel-mule/files/patch-mule-coding.c
@@ -0,0 +1,23 @@
+Index: src/mule-coding.c
+===================================================================
+RCS file: /pack/xemacscvs/XEmacs/xemacs/src/mule-coding.c,v
+retrieving revision 1.35
+retrieving revision 1.36
+diff -u -r1.35 -r1.36
+--- src/mule-coding.c 2005/06/19 21:08:31 1.35
++++ src/mule-coding.c 2005/11/22 07:19:32 1.36
+@@ -2643,10 +2643,10 @@
+ write_c_string (printcharfun, "(force)");
+ }
+
+-#define FROB(prop) \
+- if (!NILP (iso2022_getprop (cs, prop))) \
+- { \
+- write_fmt_string (printcharfun, ", %s", prop); \
++#define FROB(prop) \
++ if (!NILP (iso2022_getprop (cs, prop))) \
++ { \
++ write_fmt_string_lisp (printcharfun, ", %s", 1, prop); \
+ }
+
+ FROB (Qshort);
diff --git a/editors/xemacs-devel-mule/files/patch-window.c b/editors/xemacs-devel-mule/files/patch-window.c
new file mode 100644
index 000000000000..24bfc925a5e6
--- /dev/null
+++ b/editors/xemacs-devel-mule/files/patch-window.c
@@ -0,0 +1,24 @@
+Index: src/window.c
+===================================================================
+RCS file: /pack/xemacscvs/XEmacs/xemacs/src/window.c,v
+retrieving revision 1.88
+retrieving revision 1.89
+diff -u -r1.88 -r1.89
+--- src/window.c 2005/10/25 11:16:30 1.88
++++ src/window.c 2005/11/18 12:23:57 1.89
+@@ -4314,7 +4314,14 @@
+ if (NILP (parent))
+ {
+ if (widthflag)
+- invalid_operation ("No other window to side of this one", Qunbound);
++ {
++ int new_pixsize;
++ sizep = &CURSIZE (w);
++ dim = CURCHARSIZE (w);
++ new_pixsize = inpixels?(*sizep + delta):(dim+delta);
++ set_window_pixsize (window, new_pixsize, 0, 0);
++ return;
++ }
+ break;
+ }
+ if (widthflag