aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-01-08 07:37:41 +0000
committerWen Heping <wen@FreeBSD.org>2010-01-08 07:37:41 +0000
commitd1a6bf8cb55f128978dc2fd207c963cc717e718c (patch)
treee774fdc9fbbbe183a4c9ed6e54d98b4fa148ffa0 /editors
parentd332d16c63f035010525be759e4acbfc4420bb68 (diff)
downloadports-d1a6bf8cb55f128978dc2fd207c963cc717e718c.tar.gz
ports-d1a6bf8cb55f128978dc2fd207c963cc717e718c.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/p5-Padre/Makefile23
-rw-r--r--editors/p5-Padre/distinfo6
-rw-r--r--editors/p5-Padre/pkg-plist32
3 files changed, 51 insertions, 10 deletions
diff --git a/editors/p5-Padre/Makefile b/editors/p5-Padre/Makefile
index 8374aa85f675..f784e1116913 100644
--- a/editors/p5-Padre/Makefile
+++ b/editors/p5-Padre/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Padre
-PORTVERSION= 0.47
+PORTVERSION= 0.50
CATEGORIES= editors perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -27,6 +27,7 @@ BUILD_DEPENDS= ${SITE_PERL}/App/Ack.pm:${PORTSDIR}/textproc/p5-ack \
p5-File-Remove>=1.42:${PORTSDIR}/devel/p5-File-Remove \
${SITE_PERL}/File/ShareDir.pm:${PORTSDIR}/devel/p5-File-ShareDir \
p5-File-Which>=1.08:${PORTSDIR}/sysutils/p5-File-Which \
+ p5-Format-Human-Bytes>=0:${PORTSDIR}/converters/p5-Format-Human-Bytes \
${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
p5-List-MoreUtils>=0.22:${PORTSDIR}/lang/p5-List-MoreUtils \
@@ -40,8 +41,6 @@ BUILD_DEPENDS= ${SITE_PERL}/App/Ack.pm:${PORTSDIR}/textproc/p5-ack \
p5-Parse-ExuberantCTags>=1.00:${PORTSDIR}/devel/p5-Parse-ExuberantCTags \
p5-Pod-Abstract>=0.16:${PORTSDIR}/textproc/p5-Pod-Abstract \
${SITE_PERL}/Pod/POM.pm:${PORTSDIR}/textproc/p5-Pod-POM \
- ${SITE_PERL}/Pod/Simple.pm:${PORTSDIR}/textproc/p5-Pod-Simple \
- ${SITE_PERL}/Pod/Simple/XHTML.pm:${PORTSDIR}/textproc/p5-Pod-Simple \
${SITE_PERL}/Probe/Perl.pm:${PORTSDIR}/sysutils/p5-Probe-Perl \
${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings \
@@ -49,10 +48,8 @@ BUILD_DEPENDS= ${SITE_PERL}/App/Ack.pm:${PORTSDIR}/textproc/p5-ack \
${SITE_PERL}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff \
${SITE_PERL}/Text/FindIndent.pm:${PORTSDIR}/textproc/p5-Text-FindIndent \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/Wx/Perl/ProcessStream.pm:${PORTSDIR}/x11-toolkits/p5-Wx-Perl-ProcessStream \
${SITE_PERL}/YAML/Tiny.pm:${PORTSDIR}/textproc/p5-YAML-Tiny \
p5-Class-XSAccessor>=1.02:${PORTSDIR}/devel/p5-Class-XSAccessor \
- p5-Class-XSAccessor-Array>=1.02:${PORTSDIR}/devel/p5-Class-XSAccessor-Array \
${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
@@ -60,7 +57,8 @@ BUILD_DEPENDS= ${SITE_PERL}/App/Ack.pm:${PORTSDIR}/textproc/p5-ack \
${SITE_PERL}/${PERL_ARCH}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
p5-pip>=0.13:${PORTSDIR}/devel/p5-pip \
p5-PPIx-EditorTools>=0.09:${PORTSDIR}/textproc/p5-PPIx-EditorTools \
- p5-Wx>=0.91:${PORTSDIR}/x11-toolkits/p5-Wx
+ p5-Wx>=0.91:${PORTSDIR}/x11-toolkits/p5-Wx \
+ p5-Wx-Perl-ProcessStream>=0.20:${PORTSDIR}/x11-toolkits/p5-Wx-Perl-ProcessStream
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -84,6 +82,11 @@ IGNORE= needs a threaded Perl, build with WITH_THREADS=yes flag and try again
IGNORE= needs an existing installation of Perl built with WITH_THREADS=yes
.endif
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-Pod-Simple>=3.07:${PORTSDIR}/textproc/p5-Pod-Simple \
+ p5-version>=0:${PORTSDIR}/devel/p5-version
+.endif
+
.if ${PERL_LEVEL} >= 501000 && ${PERL_LEVEL} < 501001
BUILD_DEPENDS+= p5-Encode>=2.26:${PORTSDIR}/converters/p5-Encode \
p5-Thread-Queue>=2.11:${PORTSDIR}/devel/p5-Thread-Queue \
@@ -102,10 +105,14 @@ RUN_DEPENDS+= p5-ExtUtils-Manifest>=1.56:${PORTSDIR}/devel/p5-ExtUtils-Manifest
MAN3= Padre.3 \
Padre::Action.3 \
+ Padre::Action::Perl.3 \
+ Padre::Action::Refactor.3 \
+ Padre::Action::Run.3 \
Padre::Autosave.3 \
Padre::Config.3 \
Padre::Config::Host.3 \
Padre::Config::Human.3 \
+ Padre::Config::Upgrade.3 \
Padre::Constant.3 \
Padre::Current.3 \
Padre::DB.3 \
@@ -147,6 +154,7 @@ MAN3= Padre.3 \
Padre::Service.3 \
Padre::Task.3 \
Padre::Task::HTTPClient.3 \
+ Padre::Task::HTTPClient::LWP.3 \
Padre::Task::LWP.3 \
Padre::Task::OpenResource::SearchTask.3 \
Padre::Task::Outline.3 \
@@ -168,13 +176,16 @@ MAN3= Padre.3 \
Padre::Wx::App.3 \
Padre::Wx::CPAN.3 \
Padre::Wx::Dialog.3 \
+ Padre::Wx::Dialog::FilterTool.3 \
Padre::Wx::Dialog::Find.3 \
Padre::Wx::Dialog::HelpSearch.3 \
Padre::Wx::Dialog::OpenResource.3 \
Padre::Wx::Dialog::OpenURL.3 \
Padre::Wx::Dialog::PluginManager.3 \
Padre::Wx::Dialog::Preferences.3 \
+ Padre::Wx::Dialog::Preferences::File.3 \
Padre::Wx::Dialog::QuickMenuAccess.3 \
+ Padre::Wx::Dialog::RegexEditor.3 \
Padre::Wx::Dialog::Replace.3 \
Padre::Wx::Dialog::SessionManager.3 \
Padre::Wx::Dialog::SessionSave.3 \
diff --git a/editors/p5-Padre/distinfo b/editors/p5-Padre/distinfo
index e75e8700f459..bcc423d53731 100644
--- a/editors/p5-Padre/distinfo
+++ b/editors/p5-Padre/distinfo
@@ -1,3 +1,3 @@
-MD5 (Padre-0.47.tar.gz) = b311ac8ff67e57bc5dfaba1dc7aaa40d
-SHA256 (Padre-0.47.tar.gz) = 39c827a36c81b57f0f847be8c6b215c604e7beef27458fc141e347f387f3f384
-SIZE (Padre-0.47.tar.gz) = 931756
+MD5 (Padre-0.50.tar.gz) = 53e2d9a1ec46b4c3cf2ea3c2897729b3
+SHA256 (Padre-0.50.tar.gz) = 6a978f9b77c82f949b3619523e0db4a95ff743d2c8ec1d99269c72595f146f58
+SIZE (Padre-0.50.tar.gz) = 1067563
diff --git a/editors/p5-Padre/pkg-plist b/editors/p5-Padre/pkg-plist
index 41a108807d84..fae9e034e304 100644
--- a/editors/p5-Padre/pkg-plist
+++ b/editors/p5-Padre/pkg-plist
@@ -2,6 +2,13 @@ bin/padre
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Padre/.packlist
%%SITE_PERL%%/Padre.pm
%%SITE_PERL%%/Padre/Action.pm
+%%SITE_PERL%%/Padre/Action/Help.pm
+%%SITE_PERL%%/Padre/Action/Perl.pm
+%%SITE_PERL%%/Padre/Action/Plugins.pm
+%%SITE_PERL%%/Padre/Action/Refactor.pm
+%%SITE_PERL%%/Padre/Action/Run.pm
+%%SITE_PERL%%/Padre/Action/Search.pm
+%%SITE_PERL%%/Padre/Action/Window.pm
%%SITE_PERL%%/Padre/Autosave.pm
%%SITE_PERL%%/Padre/CPAN.pm
%%SITE_PERL%%/Padre/Config.pm
@@ -11,6 +18,7 @@ bin/padre
%%SITE_PERL%%/Padre/Config/Project.pm
%%SITE_PERL%%/Padre/Config/Setting.pm
%%SITE_PERL%%/Padre/Config/Style.pm
+%%SITE_PERL%%/Padre/Config/Upgrade.pm
%%SITE_PERL%%/Padre/Constant.pm
%%SITE_PERL%%/Padre/Current.pm
%%SITE_PERL%%/Padre/DB.pm
@@ -34,6 +42,7 @@ bin/padre
%%SITE_PERL%%/Padre/Document/Perl/Lexer.pm
%%SITE_PERL%%/Padre/Document/Perl/PPILexer.pm
%%SITE_PERL%%/Padre/File.pm
+%%SITE_PERL%%/Padre/File/FTP.pm
%%SITE_PERL%%/Padre/File/HTTP.pm
%%SITE_PERL%%/Padre/File/Local.pm
%%SITE_PERL%%/Padre/HelpProvider.pm
@@ -70,6 +79,7 @@ bin/padre
%%SITE_PERL%%/Padre/Task/ErrorParser.pm
%%SITE_PERL%%/Padre/Task/Examples/WxEvent.pm
%%SITE_PERL%%/Padre/Task/HTTPClient.pm
+%%SITE_PERL%%/Padre/Task/HTTPClient/LWP.pm
%%SITE_PERL%%/Padre/Task/LWP.pm
%%SITE_PERL%%/Padre/Task/LaunchDefaultBrowser.pm
%%SITE_PERL%%/Padre/Task/OpenResource/SearchTask.pm
@@ -99,6 +109,7 @@ bin/padre
%%SITE_PERL%%/Padre/Wx/Dialog.pm
%%SITE_PERL%%/Padre/Wx/Dialog/Bookmarks.pm
%%SITE_PERL%%/Padre/Wx/Dialog/Encode.pm
+%%SITE_PERL%%/Padre/Wx/Dialog/FilterTool.pm
%%SITE_PERL%%/Padre/Wx/Dialog/Find.pm
%%SITE_PERL%%/Padre/Wx/Dialog/HTML.pm
%%SITE_PERL%%/Padre/Wx/Dialog/HelpSearch.pm
@@ -108,7 +119,10 @@ bin/padre
%%SITE_PERL%%/Padre/Wx/Dialog/PluginManager.pm
%%SITE_PERL%%/Padre/Wx/Dialog/Preferences.pm
%%SITE_PERL%%/Padre/Wx/Dialog/Preferences/Editor.pm
+%%SITE_PERL%%/Padre/Wx/Dialog/Preferences/File.pm
%%SITE_PERL%%/Padre/Wx/Dialog/QuickMenuAccess.pm
+%%SITE_PERL%%/Padre/Wx/Dialog/RefactorSelectFunction.pm
+%%SITE_PERL%%/Padre/Wx/Dialog/RegexEditor.pm
%%SITE_PERL%%/Padre/Wx/Dialog/Replace.pm
%%SITE_PERL%%/Padre/Wx/Dialog/Search.pm
%%SITE_PERL%%/Padre/Wx/Dialog/SessionManager.pm
@@ -137,6 +151,7 @@ bin/padre
%%SITE_PERL%%/Padre/Wx/Menu/Help.pm
%%SITE_PERL%%/Padre/Wx/Menu/Perl.pm
%%SITE_PERL%%/Padre/Wx/Menu/Plugins.pm
+%%SITE_PERL%%/Padre/Wx/Menu/Refactor.pm
%%SITE_PERL%%/Padre/Wx/Menu/Run.pm
%%SITE_PERL%%/Padre/Wx/Menu/Search.pm
%%SITE_PERL%%/Padre/Wx/Menu/View.pm
@@ -160,8 +175,18 @@ bin/padre
%%SITE_PERL%%/Wx/Perl/Dialog/Simple.pm
%%SITE_PERL%%/Wx/Perl/Dialog/SingleChoice.pm
%%SITE_PERL%%/auto/share/dist/Padre/README.txt
-%%SITE_PERL%%/auto/share/dist/Padre/doc/perlopref.pod
+%%SITE_PERL%%/auto/share/dist/Padre/doc/perlopref/Artistic
+%%SITE_PERL%%/auto/share/dist/Padre/doc/perlopref/Copying
+%%SITE_PERL%%/auto/share/dist/Padre/doc/perlopref/README
+%%SITE_PERL%%/auto/share/dist/Padre/doc/perlopref/perlopref.pod
%%SITE_PERL%%/auto/share/dist/Padre/examples/absolute_beginner/01_hello_world.pl
+%%SITE_PERL%%/auto/share/dist/Padre/examples/absolute_beginner/02_time.pl
+%%SITE_PERL%%/auto/share/dist/Padre/examples/absolute_beginner/03_good_morning.pl
+%%SITE_PERL%%/auto/share/dist/Padre/examples/absolute_beginner/04_math.pl
+%%SITE_PERL%%/auto/share/dist/Padre/examples/absolute_beginner/05_do_it_again.pl
+%%SITE_PERL%%/auto/share/dist/Padre/examples/absolute_beginner/06_salat.pl
+%%SITE_PERL%%/auto/share/dist/Padre/examples/absolute_beginner/07_short_salat.pl
+%%SITE_PERL%%/auto/share/dist/Padre/examples/absolute_beginner/README
%%SITE_PERL%%/auto/share/dist/Padre/examples/wx/01_simple_frame.pl
%%SITE_PERL%%/auto/share/dist/Padre/examples/wx/02_label.pl
%%SITE_PERL%%/auto/share/dist/Padre/examples/wx/03_button.pl
@@ -211,6 +236,7 @@ bin/padre
%%SITE_PERL%%/auto/share/dist/Padre/icons/padre/16x16/status/padre-plugin-incompatible.png
%%SITE_PERL%%/auto/share/dist/Padre/icons/padre/16x16/status/padre-plugin.png
%%SITE_PERL%%/auto/share/dist/Padre/icons/padre/16x16/status/padre-syntax-error.png
+%%SITE_PERL%%/auto/share/dist/Padre/icons/padre/16x16/status/padre-syntax-ok.png
%%SITE_PERL%%/auto/share/dist/Padre/icons/padre/16x16/status/padre-syntax-warning.png
%%SITE_PERL%%/auto/share/dist/Padre/icons/padre/16x16/status/padre-tasks-load.png
%%SITE_PERL%%/auto/share/dist/Padre/icons/padre/16x16/status/padre-tasks-running.png
@@ -253,6 +279,7 @@ bin/padre
%%SITE_PERL%%/auto/share/dist/Padre/locale/zh-cn.po
%%SITE_PERL%%/auto/share/dist/Padre/locale/zh-tw.mo
%%SITE_PERL%%/auto/share/dist/Padre/locale/zh-tw.po
+%%SITE_PERL%%/auto/share/dist/Padre/padre-splash-ccnc.bmp
%%SITE_PERL%%/auto/share/dist/Padre/padre-splash.bmp
%%SITE_PERL%%/auto/share/dist/Padre/ppm/README.txt
%%SITE_PERL%%/auto/share/dist/Padre/styles/default.yml
@@ -275,6 +302,7 @@ bin/padre
%%SITE_PERL%%/auto/share/dist/Padre/timeline/migrate-8.pl
%%SITE_PERL%%/auto/share/dist/Padre/timeline/migrate-9.pl
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Padre
+@dirrmtry %%SITE_PERL%%/auto/share/dist/Padre/doc/perlopref
@dirrmtry %%SITE_PERL%%/auto/share/dist/Padre/doc
@dirrmtry %%SITE_PERL%%/auto/share/dist/Padre/examples/absolute_beginner
@dirrmtry %%SITE_PERL%%/auto/share/dist/Padre/examples/wx/img
@@ -304,6 +332,7 @@ bin/padre
@dirrmtry %%SITE_PERL%%/Wx/Perl/Dialog
@dirrmtry %%SITE_PERL%%/Wx/Perl
@dirrmtry %%SITE_PERL%%/Wx
+@dirrmtry %%SITE_PERL%%/Padre/Action
@dirrmtry %%SITE_PERL%%/Padre/Config
@dirrmtry %%SITE_PERL%%/Padre/DB
@dirrmtry %%SITE_PERL%%/Padre/DocBrowser
@@ -319,6 +348,7 @@ bin/padre
@dirrmtry %%SITE_PERL%%/Padre/QuickFixProvider
@dirrmtry %%SITE_PERL%%/Padre/Task/Debug
@dirrmtry %%SITE_PERL%%/Padre/Task/Examples
+@dirrmtry %%SITE_PERL%%/Padre/Task/HTTPClient
@dirrmtry %%SITE_PERL%%/Padre/Task/OpenResource
@dirrmtry %%SITE_PERL%%/Padre/Task/Outline
@dirrmtry %%SITE_PERL%%/Padre/Task/PPI