aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2020-04-01 18:40:18 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2020-04-01 18:40:18 +0000
commit222155c14999efb10e7821125e612e0298fb6278 (patch)
treeed4f7933555254d83e214a707ba687168e4587fb /editors
parent81c2c12d2dbc8bc65c8a0f5db7daf6dc96e1542b (diff)
downloadports-222155c14999efb10e7821125e612e0298fb6278.tar.gz
ports-222155c14999efb10e7821125e612e0298fb6278.zip
vim: Update to patchlevel 491
While here, restrict ctags patching attempts to only the files that will need to be patched. This prevents the creation of dozens of .orig files that are identical to the "patched" versions.
Notes
Notes: svn path=/head/; revision=530232
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile11
-rw-r--r--editors/vim/distinfo6
2 files changed, 10 insertions, 7 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 01e94250eb81..b61bf6c9f96f 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= vim
-PORTVERSION= 8.2.0345
+PORTVERSION= 8.2.0491
DISTVERSIONPREFIX= v
CATEGORIES= editors
@@ -186,13 +186,16 @@ post-install:
# OPTIONS
post-patch-CTAGS_BASE-on:
- ${FIND} ${WRKSRC}/runtime/ -name 'menu*.vim' -print0 | ${XARGS} -0 ${REINPLACE_CMD} -Ee 's!ctags -R ?\.!${FIND} . -type f \\| ${XARGS} ctags!g'
+ ${FIND} ${WRKSRC}/runtime -name 'menu*.vim' | ${XARGS} ${GREP} -l 'ctags -R' | \
+ ${XARGS} ${REINPLACE_CMD} -Ee 's!ctags -R ?\.!${FIND} . -type f \\| ${XARGS} ctags!g'
post-patch-CTAGS_EXUBERANT-on:
- ${FIND} ${WRKSRC}/runtime/ -name 'menu*.vim' -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's|ctags -R|exctags -R|g'
+ ${FIND} ${WRKSRC}/runtime -name 'menu*.vim' | ${XARGS} ${GREP} -l 'ctags -R' | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|ctags -R|exctags -R|g'
post-patch-CTAGS_UNIVERSAL-on:
- ${FIND} ${WRKSRC}/runtime/ -name 'menu*.vim' -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's|ctags -R|uctags -R|g'
+ ${FIND} ${WRKSRC}/runtime -name 'menu*.vim' | ${XARGS} ${GREP} -l 'ctags -R' | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|ctags -R|uctags -R|g'
post-patch-LUA-on:
${REINPLACE_CMD} -e 's|set dummy lua;|set dummy ${LUA_CMD};|g' ${WRKSRC}/src/auto/configure
diff --git a/editors/vim/distinfo b/editors/vim/distinfo
index 6b6d09c977db..9fc0abfdbe98 100644
--- a/editors/vim/distinfo
+++ b/editors/vim/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1583099504
-SHA256 (vim-vim-v8.2.0345_GH0.tar.gz) = 9e57d4f659a3b50a944f635fa4ef1c0e0e588cf936d3037a61316d16f9b22682
-SIZE (vim-vim-v8.2.0345_GH0.tar.gz) = 14839725
+TIMESTAMP = 1585764072
+SHA256 (vim-vim-v8.2.0491_GH0.tar.gz) = 2a241ccf6c70de676a1dcdf8289c2635991d4af96110f7a26c42db5f734f79d5
+SIZE (vim-vim-v8.2.0491_GH0.tar.gz) = 14881178