aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-01-05 05:41:50 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-01-05 05:41:50 +0000
commit506dfcf54237a91292ddc089af043250a9d21dc7 (patch)
tree9beb50bb50c28ee218ac6d09298c88e1d576e18a /editors
parenteee96d8fe8ff133c30720f5032d52a223484f943 (diff)
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/parinfer-rust/Makefile3
-rw-r--r--editors/parinfer-rust/distinfo6
-rw-r--r--editors/parinfer-rust/files/patch-plugin_parinfer.vim6
3 files changed, 7 insertions, 8 deletions
diff --git a/editors/parinfer-rust/Makefile b/editors/parinfer-rust/Makefile
index b2470142f5fe..c27acc2db572 100644
--- a/editors/parinfer-rust/Makefile
+++ b/editors/parinfer-rust/Makefile
@@ -2,8 +2,7 @@
PORTNAME= parinfer-rust
DISTVERSIONPREFIX= v
-DISTVERSION= 0.4.0
-PORTREVISION= 3
+DISTVERSION= 0.4.2
CATEGORIES= editors
MAINTAINER= tobik@FreeBSD.org
diff --git a/editors/parinfer-rust/distinfo b/editors/parinfer-rust/distinfo
index 064d1d9fc848..ff0c9f669fd5 100644
--- a/editors/parinfer-rust/distinfo
+++ b/editors/parinfer-rust/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1569125044
+TIMESTAMP = 1578199850
SHA256 (rust/crates/aho-corasick-0.7.3.tar.gz) = e6f484ae0c99fec2e858eb6134949117399f222608d84cadb3f58c1f97c2364c
SIZE (rust/crates/aho-corasick-0.7.3.tar.gz) = 55093
SHA256 (rust/crates/ansi_term-0.11.0.tar.gz) = ee49baf6cb617b853aa8d93bf420db2383fab46d314482ca2803b40d5fde979b
@@ -177,5 +177,5 @@ SHA256 (rust/crates/winapi-x86_64-pc-windows-gnu-0.4.0.tar.gz) = 712e227841d057c
SIZE (rust/crates/winapi-x86_64-pc-windows-gnu-0.4.0.tar.gz) = 2947998
SHA256 (rust/crates/wincolor-1.0.1.tar.gz) = 561ed901ae465d6185fa7864d63fbd5720d0ef718366c9a4dc83cf6170d7e9ba
SIZE (rust/crates/wincolor-1.0.1.tar.gz) = 4737
-SHA256 (eraserhd-parinfer-rust-v0.4.0_GH0.tar.gz) = 5d2ba306c9814fc6a8e5c7f0e101ccb88b1a8e15b7c09a98796f32515bbd851d
-SIZE (eraserhd-parinfer-rust-v0.4.0_GH0.tar.gz) = 285104
+SHA256 (eraserhd-parinfer-rust-v0.4.2_GH0.tar.gz) = 5eba5ea5c6536fdbdab74187a6b277b31bcc3018b98bea1221b9360b9547134f
+SIZE (eraserhd-parinfer-rust-v0.4.2_GH0.tar.gz) = 288256
diff --git a/editors/parinfer-rust/files/patch-plugin_parinfer.vim b/editors/parinfer-rust/files/patch-plugin_parinfer.vim
index 4bd8e86250d9..751719cf54d5 100644
--- a/editors/parinfer-rust/files/patch-plugin_parinfer.vim
+++ b/editors/parinfer-rust/files/patch-plugin_parinfer.vim
@@ -1,4 +1,4 @@
---- plugin/parinfer.vim.orig 2019-01-26 15:56:17 UTC
+--- plugin/parinfer.vim.orig 2020-01-04 23:58:23 UTC
+++ plugin/parinfer.vim
@@ -9,6 +9,10 @@ if !exists('g:parinfer_force_balance')
endif
@@ -8,6 +8,6 @@
+endif
+
+if !exists('g:parinfer_dylib_path')
+ let s:libdir = expand('<sfile>:p:h:h') . '/target/release'
if has('macunix')
- let g:parinfer_dylib_path = expand('<sfile>:p:h:h'). '/target/release/libparinfer_rust.dylib'
- elseif has('unix')
+ let g:parinfer_dylib_path = s:libdir . '/libparinfer_rust.dylib'