aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-10 16:59:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-10 16:59:28 +0000
commit85e19b22072387b894e396225ab03fa87caef1e9 (patch)
tree451153aece08de662087b87ce13bfc685f41c57c /editors
parenta518b2145edfaea1200f9d4d4d8c15d92e4e2f1e (diff)
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 11f4af8f864f..974689b1013b 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -12,7 +12,7 @@ PORTNAME= vim
# ! PATCHLEVEL to that level.
PATCHLEVEL= 110
PORTVERSION= 7.4.${PATCHLEVEL}
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= editors
MASTER_SITES= VIM
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -44,9 +44,9 @@ OPTIONS_DEFAULT+= CSCOPE EXUBERANT_CTAGS PERL PYTHON RUBY \
CONFLICTS= vim6* vim*-gnome
.if defined(LITE)
-CONFLICTS+= vim*
+CONFLICTS_INSTALL+= vim*
.else
-CONFLICTS+= vim*-lite
+CONFLICTS_INSTALL+= vim*-lite
.endif
USES= pkgconfig
@@ -96,7 +96,7 @@ MAKE_ARGS+= CONF_OPT_TCL="--enable-tclinterp --with-tclsh="${TCLSH:S/${LOCALBASE
.endif
.if ${PORT_OPTIONS:MLUA}
-USE_LUA= yes
+USES+= lua
MAKE_ARGS+= CONF_OPT_LUA="--enable-luainterp=dynamic"
MAKE_ARGS+= CONF_OPT_LUA_PREFIX="--with-lua-prefix=${LOCALBASE}"
.endif
@@ -180,7 +180,7 @@ pre-configure:
s|\$$gtk_config_prefix/bin/gtk-config|\$${GTK_CONFIG}|g; \
s|\$$gtk_config_exec_prefix/bin/gtk-config|\$${GTK_CONFIG}|g; \
s|/usr/local|${LOCALBASE}|g; \
- s|set dummy lua;|set dummy lua-${LUA_VER};|g' \
+ s|set dummy lua;|set dummy ${LUA_CMD};|g' \
${WRKSRC}/auto/configure
.if ${PORT_OPTIONS:MXTERM_SAVE}
@${REINPLACE_CMD} -e ' \