aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-04-07 08:51:00 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-04-07 08:51:00 +0000
commit9357932c8aed401696d945c5812e1d51159205dd (patch)
treee921ce33cc2428ccdcf8757982250b5da642d92d /editors
parentc6a275c4ae11f2f5cff22db5c9546f0248a00aa8 (diff)
downloadports-9357932c8aed401696d945c5812e1d51159205dd.tar.gz
ports-9357932c8aed401696d945c5812e1d51159205dd.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/codelite/Makefile7
-rw-r--r--editors/codelite/distinfo6
-rw-r--r--editors/codelite/files/patch-Runtime_codelite_xterm10
3 files changed, 11 insertions, 12 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index f9a75b5a391a..f02ec28f060d 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= codelite
-DISTVERSION= 2.3.0.${SVN_REVISION}
-PORTREVISION= 2
+DISTVERSION= 2.5.2.${SVN_REVISION}
CATEGORIES= editors
-MASTER_SITES= SF/${PORTNAME}/Releases/${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/Releases/${PORTNAME}-${PORTVERSION:R:R}
MAINTAINER= gahr@FreeBSD.org
COMMENT= An Open Source IDE for C/C++
@@ -26,7 +25,7 @@ HAS_CONFIGURE= yes
.include <bsd.port.pre.mk>
-SVN_REVISION= 3833
+SVN_REVISION= 4031
.if defined(WITH_CSCOPE)
RUN_DEPENDS+= cscope:${PORTSDIR}/devel/cscope
diff --git a/editors/codelite/distinfo b/editors/codelite/distinfo
index 5fecb3c04c7e..2e1c3699888f 100644
--- a/editors/codelite/distinfo
+++ b/editors/codelite/distinfo
@@ -1,3 +1,3 @@
-MD5 (codelite-2.3.0.3833.tar.gz) = 0cbcb35fdd05e19e05988dd121ac1a84
-SHA256 (codelite-2.3.0.3833.tar.gz) = ffdfc8197eb5de42be96926b2da5a06d262fb7142d7366b4e87c949cf323ea28
-SIZE (codelite-2.3.0.3833.tar.gz) = 5974200
+MD5 (codelite-2.5.2.4031.tar.gz) = 5e7ea3868dc395563f003673e6db37c4
+SHA256 (codelite-2.5.2.4031.tar.gz) = 09f202d0ba9f6853a1b61ba6d3c04455b1a42cb9057946df6465f4a1afb63999
+SIZE (codelite-2.5.2.4031.tar.gz) = 6015588
diff --git a/editors/codelite/files/patch-Runtime_codelite_xterm b/editors/codelite/files/patch-Runtime_codelite_xterm
index 271e66ed3779..6913aa486f6e 100644
--- a/editors/codelite/files/patch-Runtime_codelite_xterm
+++ b/editors/codelite/files/patch-Runtime_codelite_xterm
@@ -1,5 +1,5 @@
---- Runtime/codelite_xterm.orig 2010-03-25 21:08:14.000000000 +0100
-+++ Runtime/codelite_xterm 2010-03-25 21:09:11.000000000 +0100
+--- Runtime/codelite_xterm.orig 2010-04-06 08:38:16.000000000 +0000
++++ Runtime/codelite_xterm 2010-04-06 08:38:44.000000000 +0000
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
@@ -8,9 +8,9 @@
## which allows codelite to export LD_LIBRARY_PATH into the exterm
@@ -14,6 +14,6 @@
## Run xterm without the bash wrapper
- xterm -T $program_title -e $2 2> /dev/null
+ xterm -T "$program_title" -e $2 2> /dev/null
else
-- xterm -T $program_title -e /bin/bash -c 'export LD_LIBRARY_PATH=$0;shift;$@' $LD_LIBRARY_PATH $@ 2> /dev/null
-+ xterm -T $program_title -e /bin/sh -c 'export LD_LIBRARY_PATH=$0;shift;$@' $LD_LIBRARY_PATH $@ 2> /dev/null
+- xterm -T "$program_title" -e /bin/bash -c 'export LD_LIBRARY_PATH=$0;shift;$@' $LD_LIBRARY_PATH $@ 2> /dev/null
++ xterm -T "$program_title" -e /bin/sh -c 'export LD_LIBRARY_PATH=$0;shift;$@' $LD_LIBRARY_PATH $@ 2> /dev/null
fi