aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-15 23:30:05 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-15 23:30:05 +0000
commitbdeb8561511e9869fe7b4735106e13b68b529eb8 (patch)
treee962c6543fdab0f842a6d242127e735d0347e99c /editors
parent44eaadcb751194bcef34890a161d4bf9a873a2a4 (diff)
downloadports-bdeb8561511e9869fe7b4735106e13b68b529eb8.tar.gz
ports-bdeb8561511e9869fe7b4735106e13b68b529eb8.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/beav/Makefile2
-rw-r--r--editors/xcoral/Makefile2
-rw-r--r--editors/yasnippet/Makefile2
-rw-r--r--editors/yui/Makefile2
4 files changed, 8 insertions, 0 deletions
diff --git a/editors/beav/Makefile b/editors/beav/Makefile
index 8b6937a5a923..c5dceca31f1a 100644
--- a/editors/beav/Makefile
+++ b/editors/beav/Makefile
@@ -20,6 +20,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R:S/.//}
ALL_TARGET= beav
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DUNIX -DBSD -DNOPROTO"
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|(OFILES):|$$(OFILES):|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/beav.1
diff --git a/editors/xcoral/Makefile b/editors/xcoral/Makefile
index b1a3bd306a98..e8c8f3fe654a 100644
--- a/editors/xcoral/Makefile
+++ b/editors/xcoral/Makefile
@@ -17,6 +17,8 @@ MAKE_JOBS_UNSAFE= yes
PLIST_SUB= VERSION="${PORTVERSION}"
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's| regex\.c | |g ; \
s| -g | |g' ${WRKSRC}/Makefile.in
diff --git a/editors/yasnippet/Makefile b/editors/yasnippet/Makefile
index f8629a753e5c..d4473fb2467c 100644
--- a/editors/yasnippet/Makefile
+++ b/editors/yasnippet/Makefile
@@ -16,6 +16,8 @@ USE_EMACS= yes
NO_BUILD= yes
SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${FIND} ${WRKSRC}/snippets -type d -empty | ${XARGS} ${RMDIR}
diff --git a/editors/yui/Makefile b/editors/yui/Makefile
index ea4eec44dab3..09778dfc472b 100644
--- a/editors/yui/Makefile
+++ b/editors/yui/Makefile
@@ -18,6 +18,8 @@ MAKE_ENV+= LIBPATH=${PREFIX}/lib
BROKEN_sparc64= Does not compile on sparc64
+OPTIONS_DEFINE= DOCS
+
post-install:
${LN} -sf help_eng.html ${STAGEDIR}${PREFIX}/lib/yui/yhelp.html
@${MKDIR} ${STAGEDIR}${DOCSDIR}