aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-01-23 08:07:33 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-01-23 08:07:33 +0000
commitfba196b2dbc6244c71cfa2279c8d4af0f68bbc9b (patch)
tree990b8a5c1cac496022a4911c1c70697cb4fee7d7 /editors
parentf274f6f192d3637a0ee0e9f51927da5652925cb7 (diff)
downloadports-fba196b2dbc6244c71cfa2279c8d4af0f68bbc9b.tar.gz
ports-fba196b2dbc6244c71cfa2279c8d4af0f68bbc9b.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/nvi-perl/Makefile19
-rw-r--r--editors/nvi-perl/files/patch-ac51
-rw-r--r--editors/nvi-perl/pkg-plist13
3 files changed, 69 insertions, 14 deletions
diff --git a/editors/nvi-perl/Makefile b/editors/nvi-perl/Makefile
index a9eaf78b7687..3284434610bb 100644
--- a/editors/nvi-perl/Makefile
+++ b/editors/nvi-perl/Makefile
@@ -5,23 +5,30 @@
# $FreeBSD$
#
-PORTNAME= nvi-perl
+PORTNAME= nvi
PORTVERSION= 1.79
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ftp://sleepy.vwh.net/pub/ \
ftp://ftp.foretune.co.jp/pub/tools/nvi-m17n/
-DISTNAME= nvi-${PORTVERSION}
+PKGNAMESUFFIX= -perl
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
-WRKSRC= ${WRKDIR}/${DISTNAME}/build
-GNU_CONFIGURE= yes
-USE_PERL5= yes
# can't say PATCH_DIST_STRIP=-p1 because contains files outside ${WRKSRC}
PATCH_DIST_ARGS=-d ${WRKSRC}/.. --forward --quiet -E -p0
PATCH_ARGS= -d ${WRKSRC}/.. --forward --quiet -E -p0
+WRKSRC= ${WRKDIR}/${DISTNAME}/build
+USE_PERL5= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= OPTFLAG='-D_PATH_SYSEXRC=\"${PREFIX}/etc/vi.exrc\"'
CONFIGURE_ARGS= --enable-perlinterp --program-prefix=pn
+MAN1= pnvi.1
+MLINKS= pnvi.1 pnex.1 pnvi.1 pnview.1
+
+post-patch:
+ ${LN} -s /usr/include/sys/queue.h ${WRKSRC}/../include/sys/queue_dist.h
+
.include <bsd.port.mk>
diff --git a/editors/nvi-perl/files/patch-ac b/editors/nvi-perl/files/patch-ac
new file mode 100644
index 000000000000..34cabfd43d1f
--- /dev/null
+++ b/editors/nvi-perl/files/patch-ac
@@ -0,0 +1,51 @@
+--- include/sys/queue.h.old Wed Jan 10 07:16:01 2001
++++ include/sys/queue.h Wed Jan 10 07:17:02 2001
+@@ -33,8 +33,10 @@
+ * @(#)queue.h 8.5 (Berkeley) 8/20/94
+ */
+
+-#ifndef _SYS_QUEUE_H_
+-#define _SYS_QUEUE_H_
++#ifndef _SYS_QUEUE_HACK_H_
++#define _SYS_QUEUE_HACK_H_
++
++#include <sys/queue_dist.h>
+
+ /*
+ * This file defines three types of data structures: lists, tail queues,
+@@ -65,6 +67,7 @@
+ * For details on the use of these macros, see the queue(3) manual page.
+ */
+
++#ifndef LIST_HEAD
+ /*
+ * List definitions.
+ */
+@@ -114,7 +117,9 @@
+ (elm)->field.le_prev; \
+ *(elm)->field.le_prev = (elm)->field.le_next; \
+ }
++#endif /* LIST_HEAD */
+
++#ifndef TAILQ_HEAD
+ /*
+ * Tail queue definitions.
+ */
+@@ -180,7 +185,9 @@
+ (head)->tqh_last = (elm)->field.tqe_prev; \
+ *(elm)->field.tqe_prev = (elm)->field.tqe_next; \
+ }
++#endif /* TAILQ_HEAD */
+
++#ifndef CIRCLEQ_HEAD
+ /*
+ * Circular queue definitions.
+ */
+@@ -256,4 +263,6 @@
+ (elm)->field.cqe_prev->field.cqe_next = \
+ (elm)->field.cqe_next; \
+ }
+-#endif /* !_SYS_QUEUE_H_ */
++#endif /* CIRCLEQ_HEAD */
++
++#endif /* !_SYS_QUEUE_HACK_H_ */
diff --git a/editors/nvi-perl/pkg-plist b/editors/nvi-perl/pkg-plist
index cca9011c9655..68fcae85c70b 100644
--- a/editors/nvi-perl/pkg-plist
+++ b/editors/nvi-perl/pkg-plist
@@ -1,10 +1,6 @@
-bin/pnvi
bin/pnex
+bin/pnvi
bin/pnview
-man/man1/pnvi.1
-man/man1/pnex.1
-man/man1/pnview.1
-share/vi/recover
share/vi/catalog/dutch
share/vi/catalog/english
share/vi/catalog/french
@@ -12,16 +8,17 @@ share/vi/catalog/german
share/vi/catalog/ru_SU.KOI8-R
share/vi/catalog/spanish
share/vi/catalog/swedish
+share/vi/perl/VI.pm
share/vi/perl/forall.pl
share/vi/perl/make.pl
share/vi/perl/tk.pl
share/vi/perl/wc.pl
-share/vi/perl/VI.pm
+share/vi/recover
share/vi/tcl/errors.tcl
share/vi/tcl/gnats.tcl
share/vi/tcl/mailprocs.tcl
share/vi/tcl/wc.tcl
-@dirrm share/vi/catalog
-@dirrm share/vi/perl
@dirrm share/vi/tcl
+@dirrm share/vi/perl
+@dirrm share/vi/catalog
@dirrm share/vi