aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-16 08:05:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-16 08:05:11 +0000
commit06af334ab9027f9aaad087ad2a4f1e684dc5cec7 (patch)
tree8565138a516db94da31b12ab4e904d78eae496cc /editors
parent51a8fd3777120b02785a4df2630c2b70a3dbdf13 (diff)
downloadports-06af334ab9027f9aaad087ad2a4f1e684dc5cec7.tar.gz
ports-06af334ab9027f9aaad087ad2a4f1e684dc5cec7.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs23/Makefile18
-rw-r--r--editors/gobby/Makefile2
-rw-r--r--editors/lazarus/Makefile2
3 files changed, 11 insertions, 11 deletions
diff --git a/editors/emacs23/Makefile b/editors/emacs23/Makefile
index 8f6b0420b0e7..b3155667eaba 100644
--- a/editors/emacs23/Makefile
+++ b/editors/emacs23/Makefile
@@ -86,7 +86,7 @@ SVG_CONFIGURE_WITH= rsvg
GTK2_USE= GNOME=gtk20
GTK2_CONFIGURE_ON= --with-x-toolkit=gtk
-XAW3D_LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
+XAW3D_LIB_DEPENDS= libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
XAW3D_CONFIGURE_ON= --with-x-toolkit=athena
XAW_USE= XORG=xaw
@@ -99,29 +99,29 @@ SCROLLBARS_CONFIGURE_WITH= toolkit-scroll-bars
SYNC_INPUT_CONFIGURE_WITH= sync-input
-JPEG_LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
+JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
JPEG_CONFIGURE_WITH= jpeg
-TIFF_LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff
+TIFF_LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
TIFF_CONFIGURE_WITH= tiff
-GIF_LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib
+GIF_LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib
GIF_CONFIGURE_WITH= gif
-PNG_LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+PNG_LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
PNG_CONFIGURE_WITH= png
XPM_USE= XORG=xpm
XPM_CONFIGURE_WITH= xpm
XFT_USE= XORG=xft
-XFT_LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
+XFT_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
XFT_CONFIGURE_WITH= xft
-M17N_LIB_DEPENDS= m17n:${PORTSDIR}/devel/m17n-lib
+M17N_LIB_DEPENDS= libm17n.so:${PORTSDIR}/devel/m17n-lib
M17N_CONFIGURE_WITH= m17n-flt
-OTF_LIB_DEPENDS= otf:${PORTSDIR}/print/libotf
+OTF_LIB_DEPENDS= libotf.so:${PORTSDIR}/print/libotf
OTF_CONFIGURE_WITH= libotf
GCONF_USE= gnome=gconf2
@@ -134,7 +134,7 @@ CANNA_CONFIGURE_ON= --with-canna \
--with-canna-libraries=${LOCALBASE}/lib
CANNA_PATCHFILES= emacs23.3canna-20110316.diff.gz
CANNA_PATCH_SITES= http://distfiles.pirateparty.in/%SUBDIR%/ ${MASTER_SITE_LOCAL}
-CANNA_LIB_DEPENDS= canna:${PORTSDIR}/japanese/canna-lib
+CANNA_LIB_DEPENDS= libcanna.so:${PORTSDIR}/japanese/canna-lib
X11_CONFIGURE_WITH= x
X11_USE= XORG=x11
diff --git a/editors/gobby/Makefile b/editors/gobby/Makefile
index e85445f4320c..92727713285b 100644
--- a/editors/gobby/Makefile
+++ b/editors/gobby/Makefile
@@ -27,7 +27,7 @@ INSTALLS_ICONS= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTKSPELL}
-LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
+LIB_DEPENDS+= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
CONFIGURE_ARGS+=--with-gtkspell
.else
CONFIGURE_ARGS+=--without-gtkspell
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index d08d4e6bc29e..8a3e99fb6524 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -88,7 +88,7 @@ RUN_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editor
.endif
.if ${PORT_OPTIONS:MQT4}
-LIB_DEPENDS+= Qt4Pas.5:${PORTSDIR}/x11-toolkits/qt4pas
+LIB_DEPENDS+= libQt4Pas.so:${PORTSDIR}/x11-toolkits/qt4pas
LCL_PLATFORM= qt
BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-qt
RUN_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-qt