aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-16 19:09:33 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-16 19:09:33 +0000
commit161a45b603790d8433d51a601676967375e580dd (patch)
tree78dd33153ecc02e460f852ee3752bb37a246b3f9 /editors
parent216215fea146c44f197eeb0ca203e1e632aa02c8 (diff)
downloadports-161a45b603790d8433d51a601676967375e580dd.tar.gz
ports-161a45b603790d8433d51a601676967375e580dd.zip
MFH: r542378
editors/encryptpad: fix runtime on powerpc64 configure.py sets ppc32 as target architecture: INFO: Canonicalized CPU target powerpc to ppc32 INFO: Autodetected platform information: OS="FreeBSD" machine="powerpc" proc="powerpc64" Approved by: portmgr (runtime fix blanket)
Notes
Notes: svn path=/branches/2020Q3/; revision=542379
Diffstat (limited to 'editors')
-rw-r--r--editors/encryptpad/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/editors/encryptpad/Makefile b/editors/encryptpad/Makefile
index 04753372b1bf..b51e251bc680 100644
--- a/editors/encryptpad/Makefile
+++ b/editors/encryptpad/Makefile
@@ -4,6 +4,7 @@
PORTNAME= encryptpad
DISTVERSIONPREFIX= v
DISTVERSION= 0.5.0.0
+PORTVERSION= 1
CATEGORIES= editors security
MAINTAINER= dmgk@FreeBSD.org
@@ -29,6 +30,12 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64
+CONFIGURE_ARGS= --cpu="${ARCH}"
+.endif
+
.include <bsd.port.pre.mk>
post-patch:
@@ -38,7 +45,7 @@ post-patch:
.endif
do-configure:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./configure.py
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./configure.py ${CONFIGURE_ARGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/release/* ${STAGEDIR}${PREFIX}/bin