aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2011-04-18 22:25:41 +0000
committerRene Ladan <rene@FreeBSD.org>2011-04-18 22:25:41 +0000
commit48f1d8c469aeb67c4c7838bd2bdf17f28eacbc79 (patch)
tree5509f9ae2d797f02944d429c11a7b43a3c3d2cf3 /editors
parent1042e1bbe987939d4dce45f572cba84222b10aa9 (diff)
downloadports-48f1d8c469aeb67c4c7838bd2bdf17f28eacbc79.tar.gz
ports-48f1d8c469aeb67c4c7838bd2bdf17f28eacbc79.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/zed/Makefile31
-rw-r--r--editors/zed/distinfo2
-rw-r--r--editors/zed/files/patch-aa123
-rw-r--r--editors/zed/files/patch-ab14
-rw-r--r--editors/zed/files/patch-main.cc61
-rw-r--r--editors/zed/files/patch-zed.h13
-rw-r--r--editors/zed/pkg-descr4
-rw-r--r--editors/zed/pkg-plist6
9 files changed, 0 insertions, 255 deletions
diff --git a/editors/Makefile b/editors/Makefile
index f4b3fb3f9016..c37d25fa58d1 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -270,7 +270,6 @@
SUBDIR += yudit
SUBDIR += yui
SUBDIR += yzis
- SUBDIR += zed
SUBDIR += zile
SUBDIR += zim
SUBDIR += zoinks
diff --git a/editors/zed/Makefile b/editors/zed/Makefile
deleted file mode 100644
index 2247c10a321f..000000000000
--- a/editors/zed/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-# New ports collection makefile for: zed
-# Date created: 4 June 2002
-# Whom: Sten Poldma
-#
-# $FreeBSD$
-#
-
-PORTNAME= zed
-PORTVERSION= 1.0.5
-PORTREVISION= 1
-CATEGORIES= editors
-MASTER_SITES= http://zed.c3po.it/
-
-MAINTAINER= exile@chamber.ee
-COMMENT= Simple, small, fast, highly configurable text editor
-
-BROKEN= Does not compile with GCC 4.2
-DEPRECATED= does not compile on FreeBSD 7.x or newer
-EXPIRATION_DATE=2011-04-17
-
-DOCS= CHANGES zed.doc
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/zed ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/cfg/zedrc ${PREFIX}/etc/zedrc.sample
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>
diff --git a/editors/zed/distinfo b/editors/zed/distinfo
deleted file mode 100644
index 0b7ca197efea..000000000000
--- a/editors/zed/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (zed-1.0.5.tar.gz) = 3cff7f4a557e62a84350205b701eda94246707d39863780843eefe09771e1be2
-SIZE (zed-1.0.5.tar.gz) = 166599
diff --git a/editors/zed/files/patch-aa b/editors/zed/files/patch-aa
deleted file mode 100644
index 5c6d2093df39..000000000000
--- a/editors/zed/files/patch-aa
+++ /dev/null
@@ -1,123 +0,0 @@
---- Makefile.orig Wed Apr 5 19:49:16 2000
-+++ Makefile Sun Nov 17 22:41:13 2002
-@@ -5,7 +5,7 @@
- PREFIX=/usr/local
-
- # Pentium Linux
--CFLAGS=-pipe -Wall -malign-jumps=2 -malign-functions=2 -fomit-frame-pointer -m486 -O2
-+#CFLAGS=-pipe -Wall -malign-jumps=2 -malign-functions=2 -fomit-frame-pointer -m486 -O2
-
- # i486 Linux
- #CFLAGS=-pipe -Wall -fomit-frame-pointer -m486 -O2
-@@ -16,18 +16,18 @@
- #CFLAGS=-pipe -Wall -mpa-risc-1-1 -O2
-
- # RS6000 AIX
--#CFLAGS=-pipe -Wall -O2
-+CFLAGS=-pipe -Wall -O2
-
- # Sun
- #ILIBS=-lm
- #IXLIBS=-lm
- #CFLAGS=-pipe -Wall -O2 -msupersparc
-
--COMPILER=gcc
-+COMPILER=${CXX}
- # someone needs this:
- #COMPILER=g++
-
--LINKER=gcc
-+LINKER=${CXX}
-
- ###############################################
-
-@@ -45,7 +45,7 @@
-
- ###############################################
-
--OBJS=config.o editor.o lowl.o main.o varie.o edvis.o # hpux.o
-+OBJS=config.o editor.o lowl.o main.o varie.o edvis.o
- LIBS=$(ILIBS)
- OPTIONS=$(IOPTIONS)
-
-@@ -53,7 +53,7 @@
- XLIBS=-L/usr/X11R6/lib -lX11 $(XPMLIB) $(IXLIBS)
- XOPTIONS=$(XPMOPT) $(IXOPTIONS)
-
--all: zed zedx
-+all: zed
-
- default:
- @echo
-@@ -65,53 +65,35 @@
- @echo
-
- zed : $(OBJS)
-- $(LINKER) -o zed $(AFLAGS) $(OBJS) $(LIBS)
-+ $(LINKER) -o zed $(OBJS) $(LIBS)
-
- zedx : $(XOBJS)
-- $(LINKER) -o zedx $(AFLAGS) $(XOBJS) $(XLIBS)
-+ $(LINKER) -o zedx $(XOBJS) $(XLIBS)
-
- clean:
- rm -rf core *.o *.xo *~
-
--install: zed zedx
-+install: zed
- install -m 755 -d $(PREFIX)/bin
- install -m 755 -d $(PREFIX)/etc
-- install -m 755 -d $(PREFIX)/lib/zed
-+ install -m 755 -d $(PREFIX)/share/doc/zed
- install -s -m 755 zed $(PREFIX)/bin/zed
-- install -s -m 755 zedx $(PREFIX)/bin/zedx
-- install -m 644 cfg/zedxrc $(PREFIX)/etc/zedxrc
-- install -m 644 cfg/zedrc $(PREFIX)/etc/zedrc
-- install -m 644 cfg/zedrc.xterm $(PREFIX)/etc/zedrc.xterm
-- install -m 644 zed.doc $(PREFIX)/lib/zed/zed.doc
-- install -m 644 zedico.xpm $(PREFIX)/lib/zed/zedico.xpm
-- install -m 644 README $(PREFIX)/lib/zed/README
-- install -m 644 zed.png $(PREFIX)/lib/zed/zed.png
-- install -m 644 zedlogo.png $(PREFIX)/lib/zed/zedlogo.png
-+ install -c -m 644 cfg/zedrc.xterm $(PREFIX)/etc/zedrc
-+ install -c -m 644 zed.doc $(PREFIX)/share/doc/zed/zed.doc
- @echo
- @echo "Zed is now installed in your system."
- @echo
-- @echo "Please READ at least the README file. It contain important information."
-- @echo
--
--.SUFFIXES:
--
--%.xo : %.cc
-- $(COMPILER) $(CFLAGS) $(AFLAGS) -DX11 $(XOPTIONS) -o $@ -c $<
--
--%.o : %.cc
-- $(COMPILER) $(CFLAGS) $(AFLAGS) $(OPTIONS) -o $@ -c $<
-
--### Dependencies:
--config.o: config.cc zed.h
--editor.o: editor.cc zed.h
--edvis.o: edvis.cc zed.h
--lowl.o: lowl.cc zed.h
--main.o: main.cc zed.h
--varie.o: varie.cc zed.h
--config.xo: config.cc zed.h
--editor.xo: editor.cc zed.h
--lowl.xo: lowl.cc zed.h
--main.xo: main.cc zed.h
--varie.xo: varie.cc zed.h
--x11part.xo: x11part.cc zedico.xpm zed.h
-+config.o: config.cc
-+ $(COMPILER) $(CFLAGS) $(OPTIONS) -c config.cc
-+editor.o: editor.cc
-+ $(COMPILER) $(CFLAGS) $(OPTIONS) -c editor.cc
-+lowl.o: lowl.cc
-+ $(COMPILER) $(CFLAGS) $(OPTIONS) -c lowl.cc
-+main.o: main.cc
-+ $(COMPILER) $(CFLAGS) $(OPTIONS) -c main.cc
-+varie.o: varie.cc
-+ $(COMPILER) $(CFLAGS) $(OPTIONS) -c varie.cc
-+edvis.o: edvis.cc
-+ $(COMPILER) $(CFLAGS) $(OPTIONS) -c edvis.cc
-
diff --git a/editors/zed/files/patch-ab b/editors/zed/files/patch-ab
deleted file mode 100644
index 3915830c6e39..000000000000
--- a/editors/zed/files/patch-ab
+++ /dev/null
@@ -1,14 +0,0 @@
---- cfg/zedrc.xterm Thu Mar 13 15:13:19 1997
-+++ cfg/zedrc.xterm Tue Jun 4 15:04:48 2002
-@@ -73,9 +73,9 @@
- ;* ***** Editing *****
- ;*
-
--key \u7F e_canc ;* Canc - delete character under the cursor
-+key \u08 e_canc ;* Canc - delete character under the cursor
- key \u1B[3\u7E e_canc ; canc keypad
--key \u08 e_bkspc ;* BackSpace - delete character at the left of the cursor
-+key \u7F e_bkspc ;* BackSpace - delete character at the left of the cursor
- key \u0d e_enter ; Enter
- key \u19 e_delline ;* ^Y - delete row
- key \u1B[2\u7E l_instog ;* Ins - toggle insert/overwrite mode
diff --git a/editors/zed/files/patch-main.cc b/editors/zed/files/patch-main.cc
deleted file mode 100644
index 7b18f79b56ee..000000000000
--- a/editors/zed/files/patch-main.cc
+++ /dev/null
@@ -1,61 +0,0 @@
---- main.cc.orig Fri Nov 28 16:17:58 2003
-+++ main.cc Fri Nov 28 14:44:27 2003
-@@ -25,6 +25,7 @@
- #include <unistd.h>
- #include <signal.h>
- #include <regex.h>
-+#include <errno.h>
- #ifdef X11
- #include <X11/Xlib.h>
- #endif
-@@ -91,6 +92,8 @@
-
- /***************************************************************************/
-
-+int fork2();
-+
- void resetcfg(int flag,char *str)
- {
- if (config.keys==(unsigned int *)0xffffffff) config.keys=0;
-@@ -554,7 +557,7 @@
-
- if (piped) pipe(pp); else deinit(); // ripristino i settaggi del terminale
-
-- if ((pid=fork())==0)
-+ if ((pid=fork2())==0)
- { // figlio
- char *argv[100];
- int argc=0;
-@@ -1352,6 +1355,32 @@
- deinit();
-
- return(0);
-+}
-+
-+int fork2() {
-+ pid_t pid;
-+ int status;
-+
-+ if (!(pid = fork())) {
-+ switch (fork()) {
-+ case 0: return 0;
-+ case -1: _exit(errno); /* assumes all errnos are <256 */
-+ default: _exit(0);
-+ }
-+ }
-+
-+ if (pid < 0 || waitpid(pid,&status,0) < 0)
-+ return -1;
-+
-+ if (WIFEXITED(status))
-+ if (WEXITSTATUS(status) == 0)
-+ return 1;
-+ else
-+ errno = WEXITSTATUS(status);
-+ else
-+ errno = EINTR; /* well, sort of :-) */
-+
-+ return -1;
- }
-
- /***************************************************************************/
diff --git a/editors/zed/files/patch-zed.h b/editors/zed/files/patch-zed.h
deleted file mode 100644
index cd9547537eb5..000000000000
--- a/editors/zed/files/patch-zed.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- zed.h.orig Sun Nov 17 22:35:46 2002
-+++ zed.h Sun Nov 17 22:35:09 2002
-@@ -123,8 +123,8 @@
- int lung;
- char dati[0]; // puntatore ai dati
-
-- friend editor; // solo pero' all'interno di ZED.H
-- friend list;
-+ friend class editor; // solo pero' all'interno di ZED.H
-+ friend class list;
- };
-
- protected:
diff --git a/editors/zed/pkg-descr b/editors/zed/pkg-descr
deleted file mode 100644
index be379864c10e..000000000000
--- a/editors/zed/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Zed is a very simple, fast, powerful, small, low cpu consumer, highly
-configurable text editor that was originally written for UNIX.
-Perfect for console environment.
-WWW: http://zed.c3po.it
diff --git a/editors/zed/pkg-plist b/editors/zed/pkg-plist
deleted file mode 100644
index c485e4a6246f..000000000000
--- a/editors/zed/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-@comment $FreeBSD$
-bin/zed
-etc/zedrc.sample
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/zed.doc
-%%PORTDOCS%%@dirrm %%DOCSDIR%%