aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-28 17:59:39 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-28 17:59:39 +0000
commit87a32678ace250f951d38e2729215bd538d41612 (patch)
treede30350286ee03b3b61793e5851346e768032300 /editors
parent359c6f9dd858cc213e6c43d8da8f507def11b184 (diff)
downloadports-87a32678ace250f951d38e2729215bd538d41612.tar.gz
ports-87a32678ace250f951d38e2729215bd538d41612.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/joe-devel/Makefile36
-rw-r--r--editors/joe-devel/distinfo4
-rw-r--r--editors/joe-devel/files/patch-Makefile.in35
-rw-r--r--editors/joe-devel/files/patch-ad63
-rw-r--r--editors/joe-devel/pkg-plist47
5 files changed, 56 insertions, 129 deletions
diff --git a/editors/joe-devel/Makefile b/editors/joe-devel/Makefile
index 0208be905c7c..23e979121f70 100644
--- a/editors/joe-devel/Makefile
+++ b/editors/joe-devel/Makefile
@@ -5,35 +5,51 @@
# $FreeBSD$
#
-PORTNAME= joe-devel
-PORTVERSION= 2.9.8
-PORTREVISION= 1
+PORTNAME= joe
+PORTVERSION= 3.0
PORTEPOCH= 1
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= joe-editor
+PKGNAMESUFFIX= -devel
DISTNAME= joe-${PORTVERSION}
MAINTAINER= petef@FreeBSD.org
COMMENT= Development version of Joe's own editor
-MAN1= joe.1
+CONFLICTS= joe-2.*
+LATEST_LINK= joe-devel
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -liconv"
+
USE_GMAKE= yes
+USE_ICONV= yes
+USE_REINPLACE= yes
ALL_TARGET= joe
+MAN1= joe.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+post-patch:
+ @${REINPLACE_CMD} -e 's/towupper/__toupper/g' ${WRKSRC}/regex.c
+ @${REINPLACE_CMD} -e 's/iswalnum(c)/__istype(c, _CTYPE_A|_CTYPE_D)/' ${WRKSRC}/utils.c
+.endif
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/joe
- ${INSTALL_DATA} ${WRKSRC}/INFO ${WRKSRC}/README ${PREFIX}/share/doc/joe
- ${INSTALL_DATA} ${WRKSRC}/LIST ${PREFIX}/share/doc/joe/CommandList
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/INFO ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/LIST ${DOCSDIR}/CommandList
.endif
.for file in jmacsrc jpicorc jstarrc rjoerc joerc
-.if !exists(${PREFIX}/etc/${file})
- @${CP} ${PREFIX}/etc/${file}.dist ${PREFIX}/etc/${file}
+.if !exists(${PREFIX}/etc/joe/${file})
+ @${CP} ${PREFIX}/etc/joe/${file} ${PREFIX}/etc/joe/${file}.dist
.endif
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/joe-devel/distinfo b/editors/joe-devel/distinfo
index 630e65a23c18..af87ea11b2d7 100644
--- a/editors/joe-devel/distinfo
+++ b/editors/joe-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (joe-2.9.8.tar.gz) = c7c66cc641f53ba820f47a73c5b2377f
-SIZE (joe-2.9.8.tar.gz) = 283596
+MD5 (joe-3.0.tar.gz) = 05395f2f8566351d660c48390cf31dc6
+SIZE (joe-3.0.tar.gz) = 310584
diff --git a/editors/joe-devel/files/patch-Makefile.in b/editors/joe-devel/files/patch-Makefile.in
deleted file mode 100644
index c510fd14e01d..000000000000
--- a/editors/joe-devel/files/patch-Makefile.in
+++ /dev/null
@@ -1,35 +0,0 @@
---- Makefile.in.orig Mon May 5 11:15:32 2003
-+++ Makefile.in Fri Dec 26 11:04:29 2003
-@@ -275,8 +275,8 @@
- if test -f $$p \
- ; then \
- f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
-- echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/$$f"; \
-- $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/$$f || exit 1; \
-+ echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/$$p"; \
-+ $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/$$p || exit 1; \
- else :; fi; \
- done
-
-@@ -391,8 +391,8 @@
- inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
- inst=`echo $$inst | sed -e 's/^.*\///'`; \
- inst=`echo $$inst | sed '$(transform)'`.$$ext; \
-- echo " $(INSTALL_DATA) $$file $(DESTDIR)$(man1dir)/$$inst"; \
-- $(INSTALL_DATA) $$file $(DESTDIR)$(man1dir)/$$inst; \
-+ echo " $(INSTALL_DATA) $$file $(DESTDIR)$(man1dir)/$$file"; \
-+ $(INSTALL_DATA) $$file $(DESTDIR)$(man1dir)/$$file; \
- done
- uninstall-man1:
- @$(NORMAL_UNINSTALL)
-@@ -422,8 +422,8 @@
- @list='$(sysconf_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- f="`echo $$p | sed -e 's|^.*/||'`"; \
-- echo " $(sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f"; \
-- $(sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f; \
-+ echo " $(sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f.dist"; \
-+ $(sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f.dist; \
- done
-
- uninstall-sysconfDATA:
diff --git a/editors/joe-devel/files/patch-ad b/editors/joe-devel/files/patch-ad
deleted file mode 100644
index 39c52b56e693..000000000000
--- a/editors/joe-devel/files/patch-ad
+++ /dev/null
@@ -1,63 +0,0 @@
---- b.c.orig Fri Dec 7 19:13:04 2001
-+++ b.c Fri Dec 7 19:13:10 2001
-@@ -17,6 +17,9 @@
- #include <pwd.h>
- #endif
- #include <errno.h>
-+#include <sys/file.h>
-+#include <sys/types.h>
-+#include <sys/stat.h>
- #include <stdlib.h>
- #include <ctype.h>
- #include <string.h>
-@@ -187,6 +190,7 @@
- else
- b->o = pdefault;
- mset(b->marks, 0, sizeof(b->marks));
-+ b->filehandle = -1; /* initialize filehande &&& ob */
- b->rdonly = 0;
- b->orphan = 0;
- b->oldcur = 0;
-@@ -239,6 +243,10 @@
- void brm(B * b)
- {
- if (b && !--b->count) {
-+ if (b->filehandle != -1) {
-+ /* close filehandle, free lock &&& ob */
-+ close (b->filehandle);
-+ }
- if (b->changed)
- abrerr(b->name);
- if (b == errbuf)
-@@ -1805,7 +1813,8 @@
- B *b;
- long skip, amnt;
- char *n;
-- int nowrite = 0;
-+ struct stat sb;
-+ int nowrite = 0, fh = -1;
-
- if (!s || !s[0]) {
- error = -1;
-@@ -1852,6 +1861,12 @@
- goto opnerr;
- }
-
-+ /* Lock the file &&& ob,petef */
-+ if (fi) {
-+ fh = dup( fileno(fi) );
-+ nowrite = (flock (fh, LOCK_EX | LOCK_NB));
-+ }
-+
- /* Skip data if we need to */
- if (skip && lseek(fileno(fi), skip, 0) < 0) {
- int r;
-@@ -1907,6 +1922,8 @@
- vsrm(n);
-
- b->er = error;
-+ if (fh != -1)
-+ b->filehandle = fh;
- return b;
- }
-
diff --git a/editors/joe-devel/pkg-plist b/editors/joe-devel/pkg-plist
index 139ee86e4739..e9455e9c4249 100644
--- a/editors/joe-devel/pkg-plist
+++ b/editors/joe-devel/pkg-plist
@@ -4,22 +4,31 @@ bin/jpico
bin/jstar
bin/rjoe
bin/termidx
-@unexec if cmp -s %D/etc/jmacsrc.dist %D/etc/jmacsrc; then rm -f %D/etc/jmacsrc; fi
-etc/jmacsrc.dist
-@exec if [ ! -f %D/etc/jmacsrc ]; then cp %D/etc/%f %D/etc/jmacsrc; fi
-@unexec if cmp -s %D/etc/joerc.dist %D/etc/joerc; then rm -f %D/etc/joerc; fi
-etc/joerc.dist
-@exec if [ ! -f %D/etc/joerc ]; then cp %D/etc/%f %D/etc/joerc; fi
-@unexec if cmp -s %D/etc/jpicorc.dist %D/etc/jpicorc; then rm -f %D/etc/jpicorc; fi
-etc/jpicorc.dist
-@exec if [ ! -f %D/etc/jpicorc ]; then cp %D/etc/%f %D/etc/jpicorc; fi
-@unexec if cmp -s %D/etc/jstarrc.dist %D/etc/jstarrc; then rm -f %D/etc/jstarrc; fi
-etc/jstarrc.dist
-@exec if [ ! -f %D/etc/jstarrc ]; then cp %D/etc/%f %D/etc/jstarrc; fi
-@unexec if cmp -s %D/etc/rjoerc.dist %D/etc/rjoerc; then rm -f %D/etc/rjoerc; fi
-etc/rjoerc.dist
-@exec if [ ! -f %D/etc/rjoerc ]; then cp %D/etc/%f %D/etc/rjoerc; fi
-%%PORTDOCS%%share/doc/joe/INFO
-%%PORTDOCS%%share/doc/joe/README
-%%PORTDOCS%%share/doc/joe/CommandList
-%%PORTDOCS%%@dirrm share/doc/joe
+@unexec if cmp -s %D/etc/joe/jmacsrc.dist %D/etc/joe/jmacsrc; then rm -f %D/etc/joe/jmacsrc; fi
+etc/joe/jmacsrc.dist
+@exec if [ ! -f %D/etc/joe/jmacsrc ]; then cp %D/etc/joe/%f %D/etc/joe/jmacsrc; fi
+@unexec if cmp -s %D/etc/joe/joerc.dist %D/etc/joe/joerc; then rm -f %D/etc/joe/joerc; fi
+etc/joe/joerc.dist
+@exec if [ ! -f %D/etc/joe/joerc ]; then cp %D/etc/joe/%f %D/etc/joe/joerc; fi
+@unexec if cmp -s %D/etc/joe/jpicorc.dist %D/etc/joe/jpicorc; then rm -f %D/etc/joe/jpicorc; fi
+etc/joe/jpicorc.dist
+@exec if [ ! -f %D/etc/joe/jpicorc ]; then cp %D/etc/joe/%f %D/etc/joe/jpicorc; fi
+@unexec if cmp -s %D/etc/joe/jstarrc.dist %D/etc/joe/jstarrc; then rm -f %D/etc/joe/jstarrc; fi
+etc/joe/jstarrc.dist
+@exec if [ ! -f %D/etc/joe/jstarrc ]; then cp %D/etc/joe/%f %D/etc/joe/jstarrc; fi
+@unexec if cmp -s %D/etc/joe/rjoerc.dist %D/etc/joe/rjoerc; then rm -f %D/etc/joe/rjoerc; fi
+etc/joe/rjoerc.dist
+@exec if [ ! -f %D/etc/joe/rjoerc ]; then cp %D/etc/joe/%f %D/etc/joe/rjoerc; fi
+etc/joe/syntax/c.jsf
+etc/joe/syntax/conf.jsf
+etc/joe/syntax/perl.jsf
+etc/joe/syntax/php.jsf
+etc/joe/syntax/python.jsf
+etc/joe/syntax/sh.jsf
+etc/joe/syntax/verilog.jsf
+%%PORTDOCS%%%%DOCSDIR%%/CommandList
+%%PORTDOCS%%%%DOCSDIR%%/INFO
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm etc/joe/syntax
+@dirrm etc/joe