aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-28 17:46:27 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-28 17:46:27 +0000
commit439ef397ae8ed5dd824f727eca4e92c460259e3d (patch)
tree58e00fbc1afb344d31dd27a65eba9f3f41944f78 /editors
parent9305904409fae6ce80a349ff90e8ec9efc7b4c06 (diff)
downloadports-439ef397ae8ed5dd824f727eca4e92c460259e3d.tar.gz
ports-439ef397ae8ed5dd824f727eca4e92c460259e3d.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/beaver/Makefile13
-rw-r--r--editors/beaver/distinfo1
-rw-r--r--editors/beaver/files/patch-Makefile.in (renamed from editors/beaver/files/patch-Makefile.am)0
-rw-r--r--editors/beaver/files/patch-src::conf.c74
-rw-r--r--editors/beaver/files/patch-src::search.c (renamed from editors/beaver/files/patch-src-search.c)0
-rw-r--r--editors/beaver/pkg-descr10
-rw-r--r--editors/beaver/pkg-plist4
7 files changed, 86 insertions, 16 deletions
diff --git a/editors/beaver/Makefile b/editors/beaver/Makefile
index 3516e65d180f..33409463eb3a 100644
--- a/editors/beaver/Makefile
+++ b/editors/beaver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= beaver
PORTVERSION= 0.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,17 +15,14 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jylefort@brutele.be
COMMENT= A programmer's text editor for GTK+ 2.0
-USE_GNOME= gtk20
-
USE_X_PREFIX= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER= 13
USE_REINPLACE= yes
-
-LIB_DEPENDS= gtksourceview-1.0.0:${PORTSDIR}/x11-toolkits/gtksourceview
+USE_GNOME= gnomehack gnomeprefix gtk20 gtksourceview lthack
post-patch:
- @${REINPLACE_CMD} -e 's|/applications|/gnome/applications|' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|/pixmaps|/gnome/pixmaps|' ${WRKSRC}/Makefile.in
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-D.*_DISABLE_DEPRECATED||g'
.include <bsd.port.mk>
diff --git a/editors/beaver/distinfo b/editors/beaver/distinfo
index 08100162ece2..874f4479b0b7 100644
--- a/editors/beaver/distinfo
+++ b/editors/beaver/distinfo
@@ -1 +1,2 @@
MD5 (beaver-0.3.1.tar.gz) = b7281a4e9a4a802111aa2854fa5e7541
+SIZE (beaver-0.3.1.tar.gz) = 473502
diff --git a/editors/beaver/files/patch-Makefile.am b/editors/beaver/files/patch-Makefile.in
index 7a1c028d5f51..7a1c028d5f51 100644
--- a/editors/beaver/files/patch-Makefile.am
+++ b/editors/beaver/files/patch-Makefile.in
diff --git a/editors/beaver/files/patch-src::conf.c b/editors/beaver/files/patch-src::conf.c
new file mode 100644
index 000000000000..e1e5e3ed5b97
--- /dev/null
+++ b/editors/beaver/files/patch-src::conf.c
@@ -0,0 +1,74 @@
+--- src/conf.c.orig Tue Mar 15 02:40:04 2004
++++ src/conf.c Tue Mar 15 02:40:07 2004
+@@ -183,6 +183,7 @@
+ t_conf conf;
+ gint ret_val;
+
++ bzero( &conf, sizeof(conf) );
+ if (get_conf(key, &conf))
+ {
+ free_conf(&conf);
+@@ -198,6 +199,7 @@
+ t_conf conf;
+ gint ret_val;
+
++ bzero( &conf, sizeof(conf) );
+ if (get_conf(key, &conf))
+ {
+ free_conf(&conf);
+@@ -213,6 +215,7 @@
+ t_conf conf;
+ gboolean ret_val;
+
++ bzero( &conf, sizeof(conf) );
+ if (get_conf(key, &conf))
+ {
+ free_conf(&conf);
+@@ -231,6 +234,7 @@
+ t_conf conf;
+ gboolean ret_val;
+
++ bzero( &conf, sizeof(conf) );
+ if (get_conf(key, &conf))
+ {
+ free_conf(&conf);
+@@ -249,6 +253,7 @@
+ t_conf conf;
+ gchar *ret_val;
+
++ bzero( &conf, sizeof(conf) );
+ if (get_conf(key, &conf))
+ {
+ free_conf(&conf);
+@@ -266,6 +271,7 @@
+ t_conf conf;
+ gchar *ret_val;
+
++ bzero( &conf, sizeof(conf) );
+ if (get_conf(key, &conf))
+ {
+ free_conf(&conf);
+@@ -386,6 +392,7 @@
+ {
+ t_conf conf;
+
++ bzero( &conf, sizeof(conf) );
+ conf.line = g_strdup_printf("%d", value);
+ if (set_conf(key, &conf))
+ {
+@@ -400,6 +407,7 @@
+ {
+ t_conf conf;
+
++ bzero( &conf, sizeof(conf) );
+ if (value)
+ conf.line = g_strdup("TRUE");
+ else
+@@ -417,6 +425,7 @@
+ {
+ t_conf conf;
+
++ bzero( &conf, sizeof(conf) );
+ conf.line = g_strdup(value);
+ if (set_conf(key, &conf))
+ {
diff --git a/editors/beaver/files/patch-src-search.c b/editors/beaver/files/patch-src::search.c
index 55c613b2e9b6..55c613b2e9b6 100644
--- a/editors/beaver/files/patch-src-search.c
+++ b/editors/beaver/files/patch-src::search.c
diff --git a/editors/beaver/pkg-descr b/editors/beaver/pkg-descr
index f4f8b2dc6aa7..7638c981748b 100644
--- a/editors/beaver/pkg-descr
+++ b/editors/beaver/pkg-descr
@@ -1,13 +1,11 @@
-From the homepage:
-
-"Beaver is an Early AdVanced EditoR, for Linux and other Unix (and
-even Windows); in other words, it's a text editor that is intended to
-be lightweight, but full of useful features for programming, from
+Beaver is an Early AdVanced EditoR, for Linux and other Unix (and even
+Windows); in other words, it's a text editor that is intended to be
+lightweight, but full of useful features for programming, from
websites editing to C coding. It is based upon the GTK+ toolkit,
supports many languages through config files and offers functions such
as automatic indentation, completion and correction, or syntax
highlighting. In fact, it is 100% compatible with the Ultraedit's
-wordfile.txt files, and has its own mini macro language."
+wordfile.txt files, and has its own mini macro language.
WWW: http://www.nongnu.org/beaver/
diff --git a/editors/beaver/pkg-plist b/editors/beaver/pkg-plist
index 3474d50331cc..37790df373d0 100644
--- a/editors/beaver/pkg-plist
+++ b/editors/beaver/pkg-plist
@@ -1,4 +1,4 @@
bin/beaver
-share/gnome/pixmaps/beaver.png
share/gnome/applications/beaver.desktop
-@dirrm share/beaver
+share/gnome/pixmaps/beaver.png
+share/locale/de/LC_MESSAGES/beaver.mo