aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /editors
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile2
-rw-r--r--editors/calligraplan/Makefile2
-rw-r--r--editors/codelite/Makefile2
-rw-r--r--editors/ecrire/Makefile2
-rw-r--r--editors/jucipp/Makefile2
-rw-r--r--editors/kate-kde4/Makefile2
-rw-r--r--editors/kate-plugin-pate-kde4/Makefile2
-rw-r--r--editors/kate/Makefile2
-rw-r--r--editors/kile/Makefile2
-rw-r--r--editors/neovim-qt/Makefile2
-rw-r--r--editors/neovim/Makefile2
-rw-r--r--editors/texworks/Makefile2
12 files changed, 12 insertions, 12 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 8df72ab7c9f0..d690711e882e 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -36,7 +36,7 @@ LIB_DEPENDS= libImath.so:graphics/ilmbase \
BUILD_DEPENDS= pstoedit:graphics/pstoedit
RUN_DEPENDS= pstoedit:graphics/pstoedit
-USES= cmake:outsource cpe compiler:c++11-lib desktop-file-utils eigen:3 \
+USES= cmake cpe compiler:c++11-lib desktop-file-utils eigen:3 \
gettext iconv:translit jpeg kde:5 localbase:ldflags perl5 pkgconfig \
qt:5 shared-mime-info sqlite tar:xz
USE_KDE= activities archive auth bookmarks codecs completion config \
diff --git a/editors/calligraplan/Makefile b/editors/calligraplan/Makefile
index 2a8cc55c40f9..1f701e23c455 100644
--- a/editors/calligraplan/Makefile
+++ b/editors/calligraplan/Makefile
@@ -12,7 +12,7 @@ COMMENT= KDE Calligra project management application
LIB_DEPENDS= libKChart.so:graphics/kdiagram
-USES= cmake:outsource cpe compiler:c++11-lib desktop-file-utils kde:5 \
+USES= cmake cpe compiler:c++11-lib desktop-file-utils kde:5 \
qt:5 tar:xz
USE_KDE= activities akonadi archive auth bookmarks codecs completion config \
configwidgets coreaddons dbusaddons ecm guiaddons holidays i18n \
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index 9273743f38c6..3058cb0085d4 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -19,7 +19,7 @@ BROKEN_armv6= fails to configure: has leading or trailing whitespace. This is
USE_GITHUB= yes
GH_ACCOUNT= eranif
-USES= cmake:outsource,noninja compiler:c++11-lib dos2unix gettext \
+USES= cmake:noninja compiler:c++11-lib dos2unix gettext \
pathfix shebangfix sqlite
USE_GNOME+= cairo gtk20
DOS2UNIX_GLOB= *.cpp *.txt
diff --git a/editors/ecrire/Makefile b/editors/ecrire/Makefile
index 50b3360fa903..63213da75baf 100644
--- a/editors/ecrire/Makefile
+++ b/editors/ecrire/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libefl.so:devel/efl
-USES= cmake:outsource desktop-file-utils pkgconfig
+USES= cmake desktop-file-utils pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= Obsidian-StudiosInc
diff --git a/editors/jucipp/Makefile b/editors/jucipp/Makefile
index e6eed21e332a..6a5fa173db87 100644
--- a/editors/jucipp/Makefile
+++ b/editors/jucipp/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libaspell.so:textproc/aspell \
libgit2.so:devel/libgit2 \
libclang.so.5:devel/llvm50
-USES= cmake:outsource compiler:c++14-lang desktop-file-utils pkgconfig
+USES= cmake compiler:c++14-lang desktop-file-utils pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= cppit
GH_TUPLE= cppit:libclangmm:5a0195e:libclangmm/libclangmm \
diff --git a/editors/kate-kde4/Makefile b/editors/kate-kde4/Makefile
index af23f814ecf7..c877e5bd48c1 100644
--- a/editors/kate-kde4/Makefile
+++ b/editors/kate-kde4/Makefile
@@ -14,7 +14,7 @@ EXPIRATION_DATE= 2018-12-31
LIB_DEPENDS= libqjson.so:devel/qjson@qt4
-USES= cmake:outsource gettext kde:4 perl5 qt:4 tar:xz
+USES= cmake gettext kde:4 perl5 qt:4 tar:xz
USE_KDE= kdelibs automoc4 kactivities
USE_PERL5= build
USE_QT= dbus gui script sql webkit xml \
diff --git a/editors/kate-plugin-pate-kde4/Makefile b/editors/kate-plugin-pate-kde4/Makefile
index 8ce373ac1854..b29cfb4c408b 100644
--- a/editors/kate-plugin-pate-kde4/Makefile
+++ b/editors/kate-plugin-pate-kde4/Makefile
@@ -12,7 +12,7 @@ COMMENT= Support for Python plugins in Kate
DEPRECATED= KDE4 is EOL upstream
EXPIRATION_DATE= 2018-12-31
-USES= cmake:outsource,noninja kde:4 python:2.7 qt:4 tar:xz
+USES= cmake:noninja kde:4 python:2.7 qt:4 tar:xz
USE_KDE= kdelibs automoc4 kate \
pykde4_build pykde4_run
USE_QT= gui webkit \
diff --git a/editors/kate/Makefile b/editors/kate/Makefile
index e66ab8f4d20f..2ba5b8203353 100644
--- a/editors/kate/Makefile
+++ b/editors/kate/Makefile
@@ -11,7 +11,7 @@ BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:textproc/docbook-
docbook-xml>0:textproc/docbook-xml
LIB_DEPENDS= libgit2.so:devel/libgit2
-USES= cmake:outsource compiler:c++11-lang desktop-file-utils gettext \
+USES= cmake compiler:c++11-lang desktop-file-utils gettext \
pkgconfig kde:5 qt:5 tar:xz
USE_KDE= activities attica auth bookmarks codecs completion config \
configwidgets coreaddons crash dbusaddons doctools ecm \
diff --git a/editors/kile/Makefile b/editors/kile/Makefile
index 578b9fdb517d..f76b1fab37e6 100644
--- a/editors/kile/Makefile
+++ b/editors/kile/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpoppler.so:graphics/poppler \
libpoppler-qt5.so:graphics/poppler-qt5
-USES= cmake:outsource desktop-file-utils kde:5 \
+USES= cmake desktop-file-utils kde:5 \
qt:5 shared-mime-info shebangfix
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons ecm guiaddons i18n iconthemes \
diff --git a/editors/neovim-qt/Makefile b/editors/neovim-qt/Makefile
index f7d51d73d050..598b063b4aae 100644
--- a/editors/neovim-qt/Makefile
+++ b/editors/neovim-qt/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= neovim>=0:editors/neovim
LIB_DEPENDS= libmsgpackc.so:devel/msgpack
RUN_DEPENDS= neovim>=0:editors/neovim
-USES= cmake:outsource desktop-file-utils qt:5
+USES= cmake desktop-file-utils qt:5
USE_GITHUB= yes
GH_ACCOUNT= equalsraf
USE_QT= core gui testlib network widgets buildtools_build qmake_build
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index 92d8d2daee1a..3c65bdab34b5 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libluajit-5.1.so:lang/luajit \
libuv.so:devel/libuv \
libvterm.so:devel/libvterm
-USES= cmake:outsource iconv lua:build pathfix pkgconfig
+USES= cmake iconv lua:build pathfix pkgconfig
USE_GITHUB= yes
GH_TUPLE= libmpack:libmpack:1.0.5:libmpack \
libmpack:libmpack-lua:1.0.7:libmpack_lua
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index 45a0e2b1a015..d119930b93f6 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell \
libpoppler.so:graphics/poppler \
libpoppler-qt5.so:graphics/poppler-qt5
-USES= cmake:outsource desktop-file-utils pkgconfig qt:5
+USES= cmake desktop-file-utils pkgconfig qt:5
USE_GITHUB= yes
GH_ACCOUNT= TeXworks
USE_QT= buildtools_build designer_build qmake_build \