aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
commitbeb1c1fe19992999ef068d0dcb07c0d02f4aea71 (patch)
tree464f76d8fe2b9fd7499e26491ee739bfe0a5444e /editors
parent496124accdd4d4221bb883770cd6fe27184bfc96 (diff)
downloadports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.tar.gz
ports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/fxite/Makefile2
-rw-r--r--editors/mle/Makefile5
-rw-r--r--editors/neovim/Makefile4
-rw-r--r--editors/wordgrinder/Makefile2
4 files changed, 6 insertions, 7 deletions
diff --git a/editors/fxite/Makefile b/editors/fxite/Makefile
index 1d43994b548a..27e85c0c4e80 100644
--- a/editors/fxite/Makefile
+++ b/editors/fxite/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
GH_ACCOUNT= yetanothergeek
-USES= autoreconf desktop-file-utils gettext gmake lua pkgconfig
+USES= autoreconf desktop-file-utils gettext gmake lua:52 pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-system-lua \
--with-lua-pkg=lua-${LUA_VER}
diff --git a/editors/mle/Makefile b/editors/mle/Makefile
index 51724702d848..993fba71cef8 100644
--- a/editors/mle/Makefile
+++ b/editors/mle/Makefile
@@ -13,15 +13,14 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:devel/uthash
-LIB_DEPENDS= liblua-5.3.so:lang/lua53 \
- libpcre.so:devel/pcre \
+LIB_DEPENDS= libpcre.so:devel/pcre \
libtermbox.so:devel/termbox
TEST_DEPENDS= ${LOCALBASE}/bin/gpaste:sysutils/coreutils \
${LOCALBASE}/bin/grep:textproc/gnugrep \
bash:shells/bash \
gfind:misc/findutils
-USES= compiler:c11 gmake localbase:ldflags shebangfix
+USES= compiler:c11 gmake localbase:ldflags shebangfix lua:53
SHEBANG_FILES= tests/func/*.sh tests/run.sh
USE_GITHUB= yes
GH_ACCOUNT= adsr
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index 7ff954543b13..6c83414a34a0 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -12,8 +12,8 @@ COMMENT= Next-generation Vim
LICENSE= APACHE20
BUILD_DEPENDS= gperf:devel/gperf \
- ${LUA_MODLIBDIR}/bit.so:devel/lua-bitop \
- ${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg
+ ${LUA_MODLIBDIR}/bit.so:devel/lua-bitop@${LUA_FLAVOR} \
+ ${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg@${LUA_FLAVOR}
LIB_DEPENDS= libluv.so:devel/luv \
libmsgpackc.so:devel/msgpack \
libtermkey.so:devel/libtermkey \
diff --git a/editors/wordgrinder/Makefile b/editors/wordgrinder/Makefile
index 254f599dc92c..bf77fee7e0ff 100644
--- a/editors/wordgrinder/Makefile
+++ b/editors/wordgrinder/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= editors
MAINTAINER= vmagerya@gmail.com
COMMENT= Simple Unicode-aware console and X11-based word processor
-RUN_DEPENDS= ${LUA_MODLIBDIR}/lfs.so:devel/luafilesystem
+RUN_DEPENDS= ${LUA_REFMODLIBDIR}/lfs.so:devel/luafilesystem@${LUA_FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= davidgiven