aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2007-06-22 18:43:45 +0000
committerAndrey Slusar <anray@FreeBSD.org>2007-06-22 18:43:45 +0000
commit0a30e861780e084b5ad0cae3a620d23bb6582293 (patch)
treeb944b18d20caf3a007267e96ce6e1a8417bcde06 /editors
parent265d63bee96399248c323502af97e99eadcf9ea1 (diff)
downloadports-0a30e861780e084b5ad0cae3a620d23bb6582293.tar.gz
ports-0a30e861780e084b5ad0cae3a620d23bb6582293.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/tamago-emacs21/Makefile1
-rw-r--r--editors/tamago-emacs21/files/patch-wnnrpc.el21
-rw-r--r--editors/tamago/Makefile1
-rw-r--r--editors/tamago/files/patch-wnnrpc.el21
4 files changed, 44 insertions, 0 deletions
diff --git a/editors/tamago-emacs21/Makefile b/editors/tamago-emacs21/Makefile
index f914a69aa08a..289e7afb0660 100644
--- a/editors/tamago-emacs21/Makefile
+++ b/editors/tamago-emacs21/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tamago
PORTVERSION= ${EGG_DEBIAN_VER}
+PORTREVISION= 1
CATEGORIES= editors elisp
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/e/egg
diff --git a/editors/tamago-emacs21/files/patch-wnnrpc.el b/editors/tamago-emacs21/files/patch-wnnrpc.el
new file mode 100644
index 000000000000..1df5c148999f
--- /dev/null
+++ b/editors/tamago-emacs21/files/patch-wnnrpc.el
@@ -0,0 +1,21 @@
+--- egg/wnnrpc.el Sat Jun 16 23:30:29 2007
++++ egg/wnnrpc.el Sat Jun 16 23:29:00 2007
+@@ -714,8 +714,14 @@
+ ,send-expr ,@rcv-exprs))
+
+ (defmacro wnnrpc-get-result (&rest body)
+- `(let (result)
+- (comm-unpack (u) result)
++ `(let (result resulth)
++ (comm-unpack (w w) resulth result)
++ (cond ((and (= result 65535) (= resulth 65535))
++ (setq result -1))
++ ((= resulth (lsh (lsh resulth 16) -16))
++ (setq result (+ (lsh resulth 16) result)))
++ (t
++ (error "overflow")))
+ (if (< result 0)
+ (progn
+ (comm-unpack (u) result)
+
+
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index f914a69aa08a..289e7afb0660 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tamago
PORTVERSION= ${EGG_DEBIAN_VER}
+PORTREVISION= 1
CATEGORIES= editors elisp
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/e/egg
diff --git a/editors/tamago/files/patch-wnnrpc.el b/editors/tamago/files/patch-wnnrpc.el
new file mode 100644
index 000000000000..1df5c148999f
--- /dev/null
+++ b/editors/tamago/files/patch-wnnrpc.el
@@ -0,0 +1,21 @@
+--- egg/wnnrpc.el Sat Jun 16 23:30:29 2007
++++ egg/wnnrpc.el Sat Jun 16 23:29:00 2007
+@@ -714,8 +714,14 @@
+ ,send-expr ,@rcv-exprs))
+
+ (defmacro wnnrpc-get-result (&rest body)
+- `(let (result)
+- (comm-unpack (u) result)
++ `(let (result resulth)
++ (comm-unpack (w w) resulth result)
++ (cond ((and (= result 65535) (= resulth 65535))
++ (setq result -1))
++ ((= resulth (lsh (lsh resulth 16) -16))
++ (setq result (+ (lsh resulth 16) result)))
++ (t
++ (error "overflow")))
+ (if (< result 0)
+ (progn
+ (comm-unpack (u) result)
+
+