aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-11-05 10:16:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-11-05 10:16:11 +0000
commit2bd5751ba3450319d9821cbaedaabc48bb5729e4 (patch)
tree72d194ea81e43d72718ebaa58a9b2cb91b647e3b /editors
parent429da67c124902ea1c6850d0e4702c6f287d47d2 (diff)
downloadports-2bd5751ba3450319d9821cbaedaabc48bb5729e4.tar.gz
ports-2bd5751ba3450319d9821cbaedaabc48bb5729e4.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/dedit/Makefile10
-rw-r--r--editors/dedit/files/patch-src-dedit.h10
-rw-r--r--editors/dedit/files/patch-src-file.c46
-rw-r--r--editors/dedit/files/patch-src-jcode.c46
-rw-r--r--editors/dedit/files/patch-src-print.c11
-rw-r--r--editors/lfhex/Makefile6
-rw-r--r--editors/lfhex/files/patch-src-mappings.h29
7 files changed, 147 insertions, 11 deletions
diff --git a/editors/dedit/Makefile b/editors/dedit/Makefile
index f459e8b012d8..2ed3765aede7 100644
--- a/editors/dedit/Makefile
+++ b/editors/dedit/Makefile
@@ -27,17 +27,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= dedit.1
MANLANG= "" ja
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
-pre-patch:
+post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|dedit.ja.1||'
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/dedit.ja.1 ${MANPREFIX}/man/ja/man1/dedit.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/dedit/files/patch-src-dedit.h b/editors/dedit/files/patch-src-dedit.h
new file mode 100644
index 000000000000..2d9dd757ef38
--- /dev/null
+++ b/editors/dedit/files/patch-src-dedit.h
@@ -0,0 +1,10 @@
+--- src/dedit.h.orig 2007-11-04 00:35:59.000000000 +0100
++++ src/dedit.h 2007-11-04 00:36:08.000000000 +0100
+@@ -30,7 +30,6 @@
+ extern GnomeMDI *DEmdi;
+
+ extern gchar *print_cmd;
+-extern gboolean restarted;
+ extern const struct poptOption options[];
+ extern gint fs_code;
+ extern GtkWidget *file_sel;
diff --git a/editors/dedit/files/patch-src-file.c b/editors/dedit/files/patch-src-file.c
new file mode 100644
index 000000000000..b2bf2a1e8e42
--- /dev/null
+++ b/editors/dedit/files/patch-src-file.c
@@ -0,0 +1,46 @@
+--- src/file.c.orig 2000-10-13 08:45:02.000000000 +0200
++++ src/file.c 2007-11-04 00:56:29.000000000 +0100
+@@ -46,7 +46,7 @@
+ static void cancel_cb(GtkWidget *widget, gpointer *data);
+
+ gint fs_code;
+-static GtkWidget *file_sel;
++GtkWidget *file_sel;
+
+ /*
+ *
+@@ -80,7 +80,7 @@
+ gtk_widget_destroy(GTK_WIDGET(file_sel));
+ file_sel = NULL;
+
+- if(file_name) {
++ if(file_name[0]) {
+ dedit_new_document(NULL, file_name);
+ }
+
+@@ -318,7 +318,7 @@
+ gtk_widget_destroy(GTK_WIDGET(file_sel));
+ file_sel = NULL;
+
+- if(tmp){
++ if(tmp[0]){
+ save_file(doc, tmp);
+ }
+
+@@ -330,7 +330,6 @@
+ {
+ gchar *tmp;
+ gint i;
+- struct stat status;
+ gzFile *gzfp = NULL;
+ gboolean gzMode = FALSE;
+ FILE *fp = NULL;
+@@ -340,7 +339,7 @@
+ gchar backup[PATH_MAX];
+ gboolean bkFlag = FALSE;
+
+- struct stat st0, st1;
++ struct stat st0;
+
+ #ifdef TRACE_FUNC
+ printf("save_file()\n");
diff --git a/editors/dedit/files/patch-src-jcode.c b/editors/dedit/files/patch-src-jcode.c
new file mode 100644
index 000000000000..5099cf326c38
--- /dev/null
+++ b/editors/dedit/files/patch-src-jcode.c
@@ -0,0 +1,46 @@
+--- src/jcode.c.orig 2000-10-13 08:45:02.000000000 +0200
++++ src/jcode.c 2007-11-04 00:49:09.000000000 +0100
+@@ -251,7 +251,7 @@
+ char *
+ kanji_conv_auto(char *str, const char *dstset)
+ {
+- unsigned char *buf, *ret;
++ char *buf, *ret;
+ iconv_t cd;
+ size_t insize = 0;
+ size_t outsize = 0;
+@@ -278,7 +278,7 @@
+ break;
+ }
+
+- buf = (unsigned char *)malloc(strlen(str)* 4 + 1);
++ buf = malloc(strlen(str)* 4 + 1);
+ if(!buf)
+ return NULL;
+
+@@ -315,7 +315,6 @@
+ {
+ static char *jpcode = NULL;
+ static char *locale_euc[] = { JCODE_LOCALE_EUC, NULL };
+- static char *locale_jis[] = { JCODE_LOCALE_JIS, NULL };
+ static char *locale_sjis[] = { JCODE_LOCALE_SJIS, NULL };
+
+ static struct LOCALE_TABLE {
+@@ -352,7 +351,7 @@
+ char *
+ kanji_conv(char *str, const char *dstset, const char *srcset)
+ {
+- unsigned char *buf, *ret;
++ char *buf, *ret;
+ iconv_t cd;
+ size_t insize = 0;
+ size_t outsize = 0;
+@@ -363,7 +362,7 @@
+ if(!str)
+ return NULL;
+
+- buf = (unsigned char *)malloc(strlen(str) * 4 + 1);
++ buf = malloc(strlen(str) * 4 + 1);
+ if(!buf)
+ return NULL;
+
diff --git a/editors/dedit/files/patch-src-print.c b/editors/dedit/files/patch-src-print.c
new file mode 100644
index 000000000000..2cc7fcac04f9
--- /dev/null
+++ b/editors/dedit/files/patch-src-print.c
@@ -0,0 +1,11 @@
+--- src/print.c.orig 2007-11-04 00:37:11.000000000 +0100
++++ src/print.c 2007-11-04 00:38:50.000000000 +0100
+@@ -46,7 +46,7 @@
+ static GtkWidget *print_dialog = NULL;
+ static GtkWidget *print_cmd_entry = NULL;
+
+-static GtkWidget *file_sel;
++GtkWidget *file_sel;
+ gchar *print_cmd;
+
+ /* °õºþ
diff --git a/editors/lfhex/Makefile b/editors/lfhex/Makefile
index ba07b73fe76f..e1df23121ecf 100644
--- a/editors/lfhex/Makefile
+++ b/editors/lfhex/Makefile
@@ -34,10 +34,10 @@ PLIST_FILES= bin/lfhex
.include <bsd.port.pre.mk>
+post-patch:
.if ${OSVERSION} >= 700042
-.if ${ARCH} == "i386"
-BROKEN= Does not compile with GCC 4.2
-.endif
+ ${REINPLACE_CMD} -e 's|abs|llabs|g' \
+ ${WRKSRC}/src/reader.cpp
.endif
.include <bsd.port.post.mk>
diff --git a/editors/lfhex/files/patch-src-mappings.h b/editors/lfhex/files/patch-src-mappings.h
new file mode 100644
index 000000000000..f78cf1ee2f10
--- /dev/null
+++ b/editors/lfhex/files/patch-src-mappings.h
@@ -0,0 +1,29 @@
+--- src/mappings.h.orig 2005-09-24 22:44:32.000000000 +0200
++++ src/mappings.h 2007-11-04 20:34:59.000000000 +0100
+@@ -12,7 +12,7 @@
+ /* automatically generated mappings from gen*To*Map.pl scripts */
+
+ namespace TranslationTables {
+- char * byteToBinaryMap[256] = {
++ const char * byteToBinaryMap[256] = {
+ "00000000", "00000001", "00000010", "00000011", "00000100", "00000101",
+ "00000110", "00000111", "00001000", "00001001", "00001010", "00001011",
+ "00001100", "00001101", "00001110", "00001111", "00010000", "00010001",
+@@ -85,7 +85,7 @@
+ '.','.','.','.','.','.','.','.','.','.',
+ '.','.','.','.','.','.',
+ };
+- char * byteToHexMap[256] = {
++ const char * byteToHexMap[256] = {
+ "00", "01", "02", "03", "04", "05", "06", "07", "08", "09",
+ "0a", "0b", "0c", "0d", "0e", "0f", "10", "11", "12", "13",
+ "14", "15", "16", "17", "18", "19", "1a", "1b", "1c", "1d",
+@@ -113,7 +113,7 @@
+ "f0", "f1", "f2", "f3", "f4", "f5", "f6", "f7", "f8", "f9",
+ "fa", "fb", "fc", "fd", "fe", "ff",
+ };
+- char * byteToOctalMap[256] = {
++ const char * byteToOctalMap[256] = {
+ "000", "001", "002", "003", "004", "005", "006", "007", "010", "011",
+ "012", "013", "014", "015", "016", "017", "020", "021", "022", "023",
+ "024", "025", "026", "027", "030", "031", "032", "033", "034", "035",