aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2012-08-14 21:33:05 +0000
committerMaho Nakata <maho@FreeBSD.org>2012-08-14 21:33:05 +0000
commit313192e015c973b4501222388628edae883c5807 (patch)
treef810204e6e04e9b789664b45c91a5fd24af33fec /editors
parent8402c86ad4269f1298158f0cb850e8e11d2b5fe9 (diff)
downloadports-313192e015c973b4501222388628edae883c5807.tar.gz
ports-313192e015c973b4501222388628edae883c5807.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3-devel/Makefile35
-rw-r--r--editors/openoffice-3-devel/distinfo8
-rw-r--r--editors/openoffice-3-devel/files/extra-patch-libexttextcat-lingucomponent13
3 files changed, 42 insertions, 14 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 3c68347abed3..3722b8e625ac 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -73,15 +73,17 @@ FREEBSD_ENV_SET= FreeBSDX86Env.Set.sh
OOOSRC= ApacheOpenOffice.r${SVNREVISION}${EXTRACT_SUFX}
EXTSRC= ApacheOpenOffice.ext_sources.r${SVNREVISION}${EXTRACT_SUFX}
OOODIR= openoffice.org3
-SVNREVISION= 1356713
+SVNREVISION= 1371027
INSTALLATION_BASEDIR?= openoffice-r${SVNREVISION}
EXECBASE?= openoffice-r${SVNREVISION}
DIST_SUBDIR= openoffice
SIMPLEOSVER= ${OSREL:C/\.//g}
+
+PACKAGE_PREFIX= Apache_OpenOffice_incubating
.if ${ARCH} == amd64
-PACKAGE_BASENAME= ApacheOpenOffice_${OPSYS}_${PORTREVISION}_x86-64
+PACKAGE_MIDDLE= ${PORTVERSION}_${OPSYS}_x86-64
.else
-PACKAGE_BASENAME= ApacheOpenOffice_${OPSYS}_${PORTREVISION}_x86
+PACKAGE_MIDDLE= ${PORTVERSION}_${OPSYS}_x86
.endif
LOCALIZED_LANG?= en-US
@@ -94,13 +96,9 @@ PKGNAMESUFFIX= -${LANG_SUFFIX}
RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
${JAVALIBDIR}/commons-httpclient.jar:${PORTSDIR}/java/jakarta-commons-httpclient \
- ${JAVALIBDIR}/commons-lang.jar:${PORTSDIR}/java/jakarta-commons-lang \
${JAVALIBDIR}/bsh.jar:${PORTSDIR}/lang/bsh \
${JAVALIBDIR}/saxon9.jar:${PORTSDIR}/textproc/saxon-devel \
- ${LOCALBASE}/lib/X11/fonts/ChromeOS/Arimo-Bold.ttf.ttf:${PORTSDIR}/x11-fonts/croscorefonts-fonts-ttf \
- ${LOCALBASE}/lib/X11/fonts/LinLibertineG/LinLibertine_DR_G.ttf:${PORTSDIR}/x11-fonts/linuxlibertine-g \
- ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu \
- ${LOCALBASE}/lib/X11/fonts/gentium-basic/GenBasI.ttf:${PORTSDIR}/x11-fonts/gentium-basic
+ ${LOCALBASE}/lib/X11/fonts/ChromeOS/Arimo-Bold.ttf:${PORTSDIR}/x11-fonts/croscorefonts-fonts-ttf
.if defined(WITH_CCACHE)
BUILD_DEPENDS+= ccache:${PORTSDIR}/devel/ccache
@@ -126,7 +124,19 @@ LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
freetype.9:${PORTSDIR}/print/freetype2 \
apr-1.4:${PORTSDIR}/devel/apr1 \
CoinMP.7:${PORTSDIR}/math/coinmp \
- serf-1.0:${PORTSDIR}/www/serf
+ serf-1.0:${PORTSDIR}/www/serf \
+ freetype.9:${PORTSDIR}/print/freetype2
+
+.if exists(${LOCALBASE}/include/libexttextcat/textcat.h)
+.if exists(${LOCALBASE}/include/textcat.h)
+LIB_DEPENDS+= exttextcat-1.0.0:${PORTSDIR}/textproc/libexttextcat
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libexttextcat-lingucomponent
+.else
+IGNORE= textproc/libexttextcat needs COMPAT_TEXTCAT enabled
+.endif
+.else
+LIB_DEPENDS+= textcat.0:${PORTSDIR}/textproc/libtextcat
+.endif
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
@@ -179,6 +189,8 @@ CONFIGURE_ARGS+= --enable-verbose \
--with-system-curl \
--with-system-poppler \
--with-system-redland \
+ --with-system-libtextcat \
+ --with-system-libtextcat-data=${LOCALBASE}/share/libtextcat \
--with-system-vigra \
--with-system-stdlibs \
--with-system-apr \
@@ -235,6 +247,9 @@ pre-everything::
post-extract:
@${CP} ${DISTDIR}/${DIST_SUBDIR}/unowinreg.dll ${WRKSRC}/external/unowinreg/
+# @${MKDIR} ${WRKSRC}/../ext_sources
+# @${MV} ${WRKDIR}/ooo/ext_sources/* ${WRKSRC}/../ext_sources/
+# @${RM} -rf ${WRKSRC}/l10n
post-patch:
.if defined (USE_GCC)
@@ -253,7 +268,7 @@ do-build:
@cd ${WRKDIR}/ooo ; ${PRINTF} "main=active\n" >> source_config
@cd ${WRKDIR}/ooo ; ${PRINTF} "extras=active\n" >> source_config
@cd ${WRKSRC} ; ./bootstrap
- @cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" ${BASH} -c "source ${FREEBSD_ENV_SET} ; cd instsetoo_native ; build.pl --checkmodules ; build.pl --all -P${MAKE_JOBS_NUMBER} -- -P${MAKE_JOBS_NUMBER}"
+ @cd ${WRKSRC} ; ${SETENV} "LANG=C" "LC_ALL=C" ${BASH} -c "source ${FREEBSD_ENV_SET} ; cd instsetoo_native/util ; build.pl --all -P${MAKE_JOBS_NUMBER} -- -P${MAKE_JOBS_NUMBER}"
do-install:
@cd ${WRKSRC}/instsetoo_native/unxfbsd?.pro/OpenOffice/archive/install/${LOCALIZED_LANG}/ ; ${LS} *.tar.?z > ${WRKDIR}/INSTALLFILES
diff --git a/editors/openoffice-3-devel/distinfo b/editors/openoffice-3-devel/distinfo
index 172173dcb311..48367b3022b8 100644
--- a/editors/openoffice-3-devel/distinfo
+++ b/editors/openoffice-3-devel/distinfo
@@ -1,6 +1,6 @@
-SHA256 (openoffice/ApacheOpenOffice.r1356713.tar.bz2) = 5828fd511bd45b31d7119f707f530fe9fce306ca3cc6a1dd7d294af922619c28
-SIZE (openoffice/ApacheOpenOffice.r1356713.tar.bz2) = 251891339
-SHA256 (openoffice/ApacheOpenOffice.ext_sources.r1356713.tar.bz2) = 64ba0dbca6e1f855bb10d6283daa8f2064197dda516e5ed5dbcdb63e126051bb
-SIZE (openoffice/ApacheOpenOffice.ext_sources.r1356713.tar.bz2) = 223485318
+SHA256 (openoffice/ApacheOpenOffice.r1371027.tar.bz2) = 487df9bce4a17f38980a0c47197e8d10cab6b3a227b58d1b27461eb28c9a4521
+SIZE (openoffice/ApacheOpenOffice.r1371027.tar.bz2) = 259094331
+SHA256 (openoffice/ApacheOpenOffice.ext_sources.r1371027.tar.bz2) = a10fccbce918efe88e2d97dc7afbabedfc23deb5fda8871ff4fa19f3154c93af
+SIZE (openoffice/ApacheOpenOffice.ext_sources.r1371027.tar.bz2) = 236250110
SHA256 (openoffice/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
SIZE (openoffice/unowinreg.dll) = 6144
diff --git a/editors/openoffice-3-devel/files/extra-patch-libexttextcat-lingucomponent b/editors/openoffice-3-devel/files/extra-patch-libexttextcat-lingucomponent
new file mode 100644
index 000000000000..0aec5c2f9b6b
--- /dev/null
+++ b/editors/openoffice-3-devel/files/extra-patch-libexttextcat-lingucomponent
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- lingucomponent/source/languageguessing/simpleguesser.cxx.orig 2012-01-10 19:42:30.000000000 +0900
++++ lingucomponent/source/languageguessing/simpleguesser.cxx 2012-08-07 11:14:45.000000000 +0900
+@@ -114,7 +114,7 @@
+ if(!h){return guesses;}
+
+ //calculate le number of unicode charcters (symbols)
+- int len = utfstrlen(text);
++ int len = strlen(text);
+
+ if( len > MAX_STRING_LENGTH_TO_ANALYSE ){len = MAX_STRING_LENGTH_TO_ANALYSE ;}
+