aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-02 19:10:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-02 19:10:41 +0000
commitb0b0e402f25bf294369036bb62057a7d7e9332c9 (patch)
tree0b1743c8a08f14b57e4cb2381ab4808403c6a9f3 /editors
parent9a0d0575be112a06e86c667ac754258a70d16b96 (diff)
downloadports-b0b0e402f25bf294369036bb62057a7d7e9332c9.tar.gz
ports-b0b0e402f25bf294369036bb62057a7d7e9332c9.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/xenon/Makefile20
-rw-r--r--editors/xenon/files/patch-Makefile.common2
-rw-r--r--editors/xenon/pkg-descr3
-rw-r--r--editors/xenon/pkg-plist4
4 files changed, 16 insertions, 13 deletions
diff --git a/editors/xenon/Makefile b/editors/xenon/Makefile
index 4e4f1db79a38..423ae681fc01 100644
--- a/editors/xenon/Makefile
+++ b/editors/xenon/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: xenon
+# New ports collection makefile for: Xenon
# Date created: 22 October 1999
# Whom: Chris D. Faulhaber <jedgar@fxp.org>
#
@@ -16,10 +16,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Simple X-based text editor
USE_GMAKE= yes
-USE_GCC= 3.4+
-USE_X_PREFIX= yes
USE_XPM= yes
MAKEFILE= ${WRKSRC}/makefiles/Makefile.Linux
+NOPRECIOUSSOFTMAKEVARS= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/ex
MAN1= xe.1
@@ -27,8 +27,6 @@ FIX_FILES= Xe.h XeApp.C XeApp.h XeFontTable.C XeKeyTable.C \
XeKeyTable.h XeObject.C XeObject.h XeObjectTable.h XeText.C \
XeText.h
-.include <bsd.port.pre.mk>
-
do-configure:
.for file in ${FIX_FILES}
@${REINPLACE_CMD} -e 's|#include <ext/|#include <|' \
@@ -38,13 +36,17 @@ do-configure:
-e 's|#include <hash_map>|#include <ext/hash_map>|' \
-e 's|std::hash_map|__gnu_cxx::hash_map|g' \
-e 's|std::hash|__gnu_cxx::hash|g' \
- ${WRKSRC}/${file}
+ ${WRKSRC}/${file}
.endfor
+ @${REINPLACE_CMD} '/friend int compare/d' ${WRKSRC}/KrAtom.h
+ @${REINPLACE_CMD} 's|<Undo\*>|<class Undo*>|' ${WRKSRC}/XeText.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xe ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xe.1 ${PREFIX}/man/man1
- @${MKDIR} ${PREFIX}/share/examples/xe
- ${INSTALL_DATA} ${WRKSRC}/xerc ${PREFIX}/share/examples/xe/sample.xerc
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xerc ${EXAMPLESDIR}/sample.xerc
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/xenon/files/patch-Makefile.common b/editors/xenon/files/patch-Makefile.common
index a07d8d2dd381..188a4d0a2882 100644
--- a/editors/xenon/files/patch-Makefile.common
+++ b/editors/xenon/files/patch-Makefile.common
@@ -14,7 +14,7 @@
$(TARGET): $(TARGETLIB) $(AUXTARGET).o
- $(CC) $(ARCH) $(LDFLAGS) $(AUXTARGET).o $(_LDFLAGS) -o $(TARGET)
-+ $(CC) $(LDFLAGS) $(AUXTARGET).o $(_LDFLAGS) -o $(TARGET)
++ $(CXX) $(LDFLAGS) $(AUXTARGET).o $(_LDFLAGS) -o $(TARGET)
#$(SHTARGET): $(TARGETSO) $(TARGET).o
# $(CC) -o $(TARGET) -g $(TARGET).o $(SHLDFLAGS)
diff --git a/editors/xenon/pkg-descr b/editors/xenon/pkg-descr
index 28fc4fbcb933..cfd715c76f85 100644
--- a/editors/xenon/pkg-descr
+++ b/editors/xenon/pkg-descr
@@ -3,11 +3,12 @@ editing source code, system configuration files, scripts and whatever else
is an ASCII text file.
Features include:
+
* Speed, simplicity and low memory use.
* Search, substring or regular expression
* Unlimited undo/redo.
* Display of line numbers, jump to line number
- * Some X resource configuration: mostly command keys, some colours
+ * Some X resource configuration: mostly command keys, some colors
* Man page!
* Some error dialogs.
* Multiple files in separate windows.
diff --git a/editors/xenon/pkg-plist b/editors/xenon/pkg-plist
index 753552605f31..d226aeed44fd 100644
--- a/editors/xenon/pkg-plist
+++ b/editors/xenon/pkg-plist
@@ -1,3 +1,3 @@
bin/xe
-share/examples/xe/sample.xerc
-@dirrm share/examples/xe
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.xerc
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%