aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-08 19:47:35 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-08 19:47:35 +0000
commitb23dbd361dddceb2253049f04abf6aea78e2592a (patch)
treec690a1e99d2fafebc2d8a38443e7453d48944e13 /editors
parentf41538257e1c8e5a6c09f6970588cb6ec0f1a595 (diff)
downloadports-b23dbd361dddceb2253049f04abf6aea78e2592a.tar.gz
ports-b23dbd361dddceb2253049f04abf6aea78e2592a.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/scite/Makefile5
-rw-r--r--editors/scite/distinfo4
-rw-r--r--editors/scite/files/patch-makefile33
-rw-r--r--editors/scite/files/patch-src__FilePath.h10
4 files changed, 21 insertions, 31 deletions
diff --git a/editors/scite/Makefile b/editors/scite/Makefile
index 081144c785b8..973420c17321 100644
--- a/editors/scite/Makefile
+++ b/editors/scite/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= scite
-PORTVERSION= 3.4.1
+PORTVERSION= 3.4.4
CATEGORIES= editors gnome
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
@@ -27,8 +27,7 @@ PORTDOCS= *
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|[(]CC[)]|(CXX)|g ; s|[(]CCOMP[)]|(CC)|g ; \
- s| -Os||g' ${WRKSRC}/makefile
+ @${REINPLACE_CMD} -e 's| -Os||g' ${WRKSRC}/makefile
.if ${PORT_OPTIONS:MFULL_BUFFER_MENU}
@${REINPLACE_CMD} -e 's|30, "/Buffers|props.GetInt("buffers") > 30 ? props.GetInt("buffers") - 10 : 30, "/Buffers|g' ${WRKSRC}/SciTEGTK.cxx
.endif
diff --git a/editors/scite/distinfo b/editors/scite/distinfo
index 1c0edc2a254a..7ab540d3f6b8 100644
--- a/editors/scite/distinfo
+++ b/editors/scite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scite341.tgz) = ab2940ba6ad3f1c7c33aea233dd5b44efc75319062fe0b3625db04c747bf3341
-SIZE (scite341.tgz) = 2237159
+SHA256 (scite344.tgz) = 89602ea4c245928caac07bc5192d57f98b968e578efaf0748e3dd832a724c499
+SIZE (scite344.tgz) = 2245870
diff --git a/editors/scite/files/patch-makefile b/editors/scite/files/patch-makefile
index 6406833ddcae..457f46b4801a 100644
--- a/editors/scite/files/patch-makefile
+++ b/editors/scite/files/patch-makefile
@@ -1,20 +1,21 @@
---- makefile.orig 2013-10-13 23:38:06.000000000 +0200
-+++ makefile 2014-01-27 15:50:05.858185668 +0100
-@@ -5,13 +5,6 @@
+--- ./makefile.orig 2014-07-25 07:00:13.000000000 -0400
++++ ./makefile 2014-08-07 21:57:08.000000000 -0400
+@@ -5,14 +5,6 @@
# GNU make does not like \r\n line endings so should be saved to CVS in binary form.
.SUFFIXES: .cxx .o .h .a .c
-ifdef CLANG
--CC = clang -fsanitize=address --std=c++0x
--CCOMP = clang -fsanitize=address -Wno-empty-body
--else
--CC = g++
--CCOMP = gcc
+-# Can choose aspect to sanitize: address and undefined can simply change SANITIZE but for
+-# thread also need to create Position Independent Executable -> search online documentation
+-SANITIZE = address
+-#SANITIZE = undefined
+-CXX = clang++ -fsanitize=$(SANITIZE) --std=c++0x
+-CC = clang -fsanitize=$(SANITIZE) -Wno-empty-body
-endif
- AR = ar
ifdef GTK3
-@@ -24,7 +17,7 @@
+ GTKVERSION=gtk+-3.0
+@@ -24,7 +16,7 @@
CONFIGFLAGS:=$(shell pkg-config --cflags $(GTKVERSION))
CONFIGLIB:=$(shell pkg-config --libs $(GTKVERSION) gthread-2.0 gmodule-no-export-2.0)
CONFIGTHREADS:=
@@ -23,15 +24,15 @@
ifndef prefix
ifdef gnomeprefix
prefix=$(gnomeprefix)
-@@ -116,8 +109,9 @@
- $(PROG): SciTEGTK.o GUIGTK.o Widget.o \
- FilePath.o SciTEBase.o FileWorker.o Cookie.o Credits.o SciTEBuffers.o SciTEIO.o StringList.o Exporters.o StringHelpers.o \
+@@ -113,8 +105,9 @@
+ FilePath.o SciTEBase.o FileWorker.o Cookie.o Credits.o SciTEBuffers.o SciTEIO.o StringList.o \
+ Exporters.o MatchMarker.o StringHelpers.o \
PropSetFile.o MultiplexExtension.o DirectorExtension.o SciTEProps.o StyleDefinition.o StyleWriter.o Utf8_16.o \
- JobQueue.o GTKMutex.o IFaceTable.o $(COMPLIB) $(LUA_OBJS)
-- $(CC) `$(CONFIGTHREADS)` -rdynamic -Wl,--as-needed -Wl,--version-script lua.vers -DGTK $^ -o $@ $(CONFIGLIB) $(LIBDL) -lm -lstdc++
+- $(CXX) `$(CONFIGTHREADS)` -rdynamic -Wl,--as-needed -Wl,--version-script lua.vers -DGTK $^ -o $@ $(CONFIGLIB) $(LIBDL) -lm -lstdc++
+ JobQueue.o GTKMutex.o IFaceTable.o $(LUA_OBJS)
-+ $(CC) -DGTK $(CXXFLAGS) -rdynamic -Wl,--version-script lua.vers $(LDFLAGS) \
-+ -o $@ $^ -lscintilla -lscintilla_lexers -Wl,--as-needed $(CONFIGLIB)
++ $(CXX) -rdynamic -Wl,--version-script lua.vers -DGTK $(CXXFLAGS) $^ -o $@ \
++ $(LDFLAGS) -lscintilla -lscintilla_lexers -Wl,--as-needed $(CONFIGLIB)
# Automatically generate header dependencies with "make deps"
include deps.mak
diff --git a/editors/scite/files/patch-src__FilePath.h b/editors/scite/files/patch-src__FilePath.h
deleted file mode 100644
index c0217ff90e43..000000000000
--- a/editors/scite/files/patch-src__FilePath.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ../src/FilePath.h.orig 2011-07-31 22:49:30.000000000 -0400
-+++ ../src/FilePath.h 2011-09-06 21:43:03.000000000 -0400
-@@ -13,6 +13,7 @@
- extern const GUI::gui_char fileWrite[];
-
- #if defined(__unix__)
-+#include <cstdio>
- #include <limits.h>
- #ifdef PATH_MAX
- #define MAX_PATH PATH_MAX