aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 12:57:27 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 12:57:27 +0000
commitb335652f5aff7fcbd3cc2dac19bfbeeff4827068 (patch)
tree4db7c1361ddfdb47c9a24e90b9df782305cea4af /editors
parentc726e8e6f34a5a230d144029accbc96869835542 (diff)
downloadports-b335652f5aff7fcbd3cc2dac19bfbeeff4827068.tar.gz
ports-b335652f5aff7fcbd3cc2dac19bfbeeff4827068.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/vimpart/Makefile41
-rw-r--r--editors/vimpart/distinfo2
-rw-r--r--editors/vimpart/pkg-descr3
-rw-r--r--editors/vimpart/pkg-plist19
5 files changed, 66 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 3983254f0bc9..a26c94ff116c 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -187,6 +187,7 @@
SUBDIR += vim-lite
SUBDIR += vim5
SUBDIR += vim6+ruby
+ SUBDIR += vimpart
SUBDIR += wily
SUBDIR += xcoral
SUBDIR += xed
diff --git a/editors/vimpart/Makefile b/editors/vimpart/Makefile
new file mode 100644
index 000000000000..2c6e588fe92b
--- /dev/null
+++ b/editors/vimpart/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: vimpart
+# Date created: 11 Febrary 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${VIMPART_PORTNAME}
+PORTVERSION= ${VIMPART_PORTVERSION}
+PORTREVISION= ${VIMPART_PORTREVISION}
+CATEGORIES= editors kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE wrapper for gvim
+
+IGNORE= This port is part of KDE 3.2.1 and is not yet ready
+
+KDE_SPLIT= ${VIMPART_PORTNAME:S/${KDE_SPLIT_DIST}-//}
+KDE_DOC_SPLIT= # none
+USE_KDELIBS_VER=3
+
+USE_BZIP2= yes
+PREFIX= ${KDE_PREFIX}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS+= %%PREFIX%%/lib/kde3
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include "${.CURDIR}/../../misc/kdeaddons3/Makefile.split"
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/gvim)
+RUN_DEPENDS+= gvim:${PORTSDIR}/editors/vim
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/editors/vimpart/distinfo b/editors/vimpart/distinfo
new file mode 100644
index 000000000000..95aca618ce40
--- /dev/null
+++ b/editors/vimpart/distinfo
@@ -0,0 +1,2 @@
+MD5 (KDE/kdeaddons-3.2.1.tar.bz2) = c73c1777d3f5c25f46cd782fcca9fc35
+SIZE (KDE/kdeaddons-3.2.1.tar.bz2) = 1371322
diff --git a/editors/vimpart/pkg-descr b/editors/vimpart/pkg-descr
new file mode 100644
index 000000000000..b3df3068c9c0
--- /dev/null
+++ b/editors/vimpart/pkg-descr
@@ -0,0 +1,3 @@
+Editor for Atlantik.
+
+WWW: http://www.kde.org
diff --git a/editors/vimpart/pkg-plist b/editors/vimpart/pkg-plist
new file mode 100644
index 000000000000..2508957a1454
--- /dev/null
+++ b/editors/vimpart/pkg-plist
@@ -0,0 +1,19 @@
+lib/kde3/kcm_vim.la
+lib/kde3/kcm_vim.so
+lib/kde3/libvimpart.la
+lib/kde3/libvimpart.so
+lib/kde3/libvimpart.so.0
+lib/libxvim.la
+lib/libxvim.so
+lib/libxvim.so.0
+share/applications/kde/kcmvim.desktop
+share/applications/kdeaddons-vimpart-3.2.1
+share/apps/kcontrol/pics/kvim.png
+share/apps/vimpart/kvim.vim
+share/apps/vimpart/vimpartui.rc
+share/apps/vimpart/vimpartuibrowser.rc
+share/apps/vimpart/vimpartuireadonly.rc
+share/services/vimpart.desktop
+@dirrm share/apps/vimpart
+@dirrm share/apps/kcontrol/pics
+@dirrm share/apps/kcontrol