aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-10-21 12:51:40 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-10-21 12:51:40 +0000
commiteabbfd75e30148b8f686899a638b93547ca83485 (patch)
tree5b70e6802d6d9dfe8b4564fc4f09f2d0a5156343 /editors
parentf51fe6e12cc1833af15f8086b22a92af9f8aa4b0 (diff)
downloadports-eabbfd75e30148b8f686899a638b93547ca83485.tar.gz
ports-eabbfd75e30148b8f686899a638b93547ca83485.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/2bsd-vi/Makefile2
-rw-r--r--editors/emacs-devel/Makefile2
-rw-r--r--editors/flim/Makefile2
-rw-r--r--editors/lazarus/Makefile6
-rw-r--r--editors/lazarus/Makefile.common2
-rw-r--r--editors/libreoffice4/Makefile2
-rw-r--r--editors/linux-sublime/Makefile2
-rw-r--r--editors/mined/Makefile6
-rw-r--r--editors/openoffice-4/Makefile16
-rw-r--r--editors/openoffice-devel/Makefile16
-rw-r--r--editors/rox-edit/Makefile2
-rw-r--r--editors/semi/Makefile2
12 files changed, 30 insertions, 30 deletions
diff --git a/editors/2bsd-vi/Makefile b/editors/2bsd-vi/Makefile
index 49839fc388c7..55f87ee23d7b 100644
--- a/editors/2bsd-vi/Makefile
+++ b/editors/2bsd-vi/Makefile
@@ -21,7 +21,7 @@ PRESERVEDIR= /var/preserve/${PKGBASE}
PLIST_SUB= PRESERVEDIR="${PRESERVEDIR}"
post-extract: .SILENT
- ${RM} -fr ${WRKSRC}/libuxre ${WRKSRC}/regexp.h
+ ${RM} -r ${WRKSRC}/libuxre ${WRKSRC}/regexp.h
post-patch:
.for f in Makefile ex.1 expreserve.c exrecover.c vi.1
diff --git a/editors/emacs-devel/Makefile b/editors/emacs-devel/Makefile
index 728e80193387..fc551bc2cdc1 100644
--- a/editors/emacs-devel/Makefile
+++ b/editors/emacs-devel/Makefile
@@ -241,7 +241,7 @@ LDFLAGS+=-ltinfo
.endif
post-patch:
- @${RM} -f ${WRKSRC}/info/*
+ @${RM} ${WRKSRC}/info/*
## stage-qa will give a warning, but don't pull in desktop-file-utils
## portlint -AC will give a warning about INSTALL_ICONS, but don't pull in those
diff --git a/editors/flim/Makefile b/editors/flim/Makefile
index d4b767575167..f9c4233b7459 100644
--- a/editors/flim/Makefile
+++ b/editors/flim/Makefile
@@ -202,7 +202,7 @@ info-package-install:
done)
manifest-install:
- @${RM} -f ${WRKDIR}/${MANIFEST}
+ @${RM} ${WRKDIR}/${MANIFEST}
@${CAT} ${PLIST} | ${GREP} -e "^%%EMACS_PACKAGESDIR%%" | \
${SED} -e "s;^%%EMACS_PACKAGESDIR%%/;;" > ${WRKDIR}/${MANIFEST}
@${INSTALL_DATA} ${WRKDIR}/${MANIFEST} \
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 98caba8d3d1e..c9df3849d71f 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -110,7 +110,7 @@ do-build:
post-build:
@cd ${WRKSRC} && \
- ${RM} -Rf COPYING* README* debian localize.bat test *.orig *.bak startlazarus.app \
+ ${RM} -R COPYING* README* debian localize.bat test *.orig *.bak startlazarus.app \
ide/Makefile*.orig ide/Makefile*.bak lcl/units components/ideintf/units \
components/synedit/units components/lazcontrols/lib
@@ -119,8 +119,8 @@ pre-install:
@${ECHO} "cd ${DATADIR} || exit 1 " >> ${WRKDIR}/lazarus-wrapper
@${ECHO} "exec ./startlazarus" >> ${WRKDIR}/lazarus-wrapper
- @${RM} -f ${PLIST}
- @${RM} -f ${WRKSRC}/lcl/units
+ @${RM} ${PLIST}
+ @${RM} ${WRKSRC}/lcl/units
@${RM} -r ${WRKSRC}/components/chmhelp/lhelp/lhelp.app/Contents/MacOS \
${WRKSRC}/lazarus.app/Contents/MacOS \
${WRKSRC}/lazarus.app/Contents/Resources/startlazarus.app/Contents/MacOS
diff --git a/editors/lazarus/Makefile.common b/editors/lazarus/Makefile.common
index 59731ba60b32..df135661f810 100644
--- a/editors/lazarus/Makefile.common
+++ b/editors/lazarus/Makefile.common
@@ -61,7 +61,7 @@ do-build:
${SETENV} ${MAKE_ENV} ${MAKE_CMD} LCL_PLATFORM=${LCL_INTERFACE}
pre-install:
- @${RM} -f ${PLIST}
+ @${RM} ${PLIST}
@cd ${WRKSRC}/units/${BUILDNAME}/${LCL_INTERFACE} && \
${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/lcl/units/%%BUILDNAME%%/${LCL_INTERFACE}/|' -e 's|//|/|' >> ${PLIST}
diff --git a/editors/libreoffice4/Makefile b/editors/libreoffice4/Makefile
index 2311262f90f2..f4a50afa2b2e 100644
--- a/editors/libreoffice4/Makefile
+++ b/editors/libreoffice4/Makefile
@@ -359,7 +359,7 @@ post-configure:
do-install:
@cd ${WRKSRC} && ${MAKE_CMD} ${MAKE_ARGS} distro-pack-install
- @${RM} -f ${PLISTD} ${PLISTF}
+ @${RM} ${PLISTD} ${PLISTF}
@cd ${STAGEDIR}${PREFIX} && ${FIND} -d lib/libreoffice -type d \
-empty -exec ${ECHO_CMD} "@dir {}" \; >> ${PLISTD}
@cd ${STAGEDIR}${PREFIX} && ${FIND} -H -s bin etc lib man \
diff --git a/editors/linux-sublime/Makefile b/editors/linux-sublime/Makefile
index c66fc665264d..5f7f957228fd 100644
--- a/editors/linux-sublime/Makefile
+++ b/editors/linux-sublime/Makefile
@@ -35,7 +35,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/Icon/48x48/sublime_text.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/48x48/apps/
@${INSTALL_DATA} ${WRKSRC}/Icon/128x128/sublime_text.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/128x128/apps/
@${INSTALL_DATA} ${WRKSRC}/Icon/256x256/sublime_text.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/256x256/apps/
- @${RM} -rf ${WRKSRC}/Icon/
+ @${RM} -r ${WRKSRC}/Icon/
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
@${CHMOD} +x ${STAGEDIR}${DATADIR}/sublime_text
@${INSTALL_SCRIPT} ${WRKDIR}/sublime ${STAGEDIR}${PREFIX}/bin/sublime
diff --git a/editors/mined/Makefile b/editors/mined/Makefile
index ac9cd85b8aec..b559858db923 100644
--- a/editors/mined/Makefile
+++ b/editors/mined/Makefile
@@ -45,8 +45,8 @@ post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && ${INSTALL_DATA} * ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/usrshare/package_doc && ${INSTALL_DATA} * ${STAGEDIR}${DOCSDIR}
- ${RM} -rf ${STAGEDIR}${DATADIR}/setup_install/cyg
- @${RM} -rf ${STAGEDIR}${DOCSDIR}/CHANGES ${STAGEDIR}${DOCSDIR}/LICENCE.GPL
- @${RM} -rf ${STAGEDIR}${DATADIR}/doc_user ${STAGEDIR}${DATADIR}/package_doc
+ ${RM} -r ${STAGEDIR}${DATADIR}/setup_install/cyg
+ @${RM} -r ${STAGEDIR}${DOCSDIR}/CHANGES ${STAGEDIR}${DOCSDIR}/LICENCE.GPL
+ @${RM} -r ${STAGEDIR}${DATADIR}/doc_user ${STAGEDIR}${DATADIR}/package_doc
.include <bsd.port.mk>
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 81c8abb99a05..3a2514a057ff 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -282,13 +282,13 @@ pre-everything::
# really tweak, extremely useful when you build all localized language versions
# needed after when you build with ALL_LOCALIZED_LANGS.
.if defined(TWEAK_L10N)
- ${RM} -f ${WRKDIR}/.PLIST*
- ${RM} -f ${WRKDIR}/.install_done.*
- ${RM} -f ${WRKDIR}/.package_done.*
- ${RM} -f ${WRKDIR}/.extract_done.*
- ${RM} -f ${WRKDIR}/.patch_done.*
- ${RM} -f ${WRKDIR}/.configure_done.*
- ${RM} -f ${WRKDIR}/.build_done.*
+ ${RM} ${WRKDIR}/.PLIST*
+ ${RM} ${WRKDIR}/.install_done.*
+ ${RM} ${WRKDIR}/.package_done.*
+ ${RM} ${WRKDIR}/.extract_done.*
+ ${RM} ${WRKDIR}/.patch_done.*
+ ${RM} ${WRKDIR}/.configure_done.*
+ ${RM} ${WRKDIR}/.build_done.*
${MKDIR} ${WRKDIR}
${TOUCH} ${EXTRACT_COOKIE}
${TOUCH} ${PATCH_COOKIE}
@@ -301,7 +301,7 @@ post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/unowinreg.dll ${WRKSRC}/external/unowinreg/
${CP} ${FILESDIR}/freebsd-aoo-intro.png ${WRKSRC}/default_images/introabout/intro.png
${CP} ${FILESDIR}/freebsd-aoo-about.png ${WRKSRC}/default_images/introabout/about.png
- ${RM} -rf ${WRKSRC}/l10n
+ ${RM} -r ${WRKSRC}/l10n
${LN} -sf ${UNZIP_CMD} ${WRKSRC}/solenv/bin/unzip
${SED} -e '\|^For main/vcl/unx/generic/fontmanager/parseAFM|,/^__/p' \
-e '\|^For PostScript(R) AFM|,/^__/p' \
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 319a50e5fb6d..a82428629af7 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -292,13 +292,13 @@ pre-everything::
# really tweak, extremely useful when you build all localized language versions
# needed after when you build with ALL_LOCALIZED_LANGS.
.if defined(TWEAK_L10N)
- ${RM} -f ${WRKDIR}/.PLIST*
- ${RM} -f ${WRKDIR}/.install_done.*
- ${RM} -f ${WRKDIR}/.package_done.*
- ${RM} -f ${WRKDIR}/.extract_done.*
- ${RM} -f ${WRKDIR}/.patch_done.*
- ${RM} -f ${WRKDIR}/.configure_done.*
- ${RM} -f ${WRKDIR}/.build_done.*
+ ${RM} ${WRKDIR}/.PLIST*
+ ${RM} ${WRKDIR}/.install_done.*
+ ${RM} ${WRKDIR}/.package_done.*
+ ${RM} ${WRKDIR}/.extract_done.*
+ ${RM} ${WRKDIR}/.patch_done.*
+ ${RM} ${WRKDIR}/.configure_done.*
+ ${RM} ${WRKDIR}/.build_done.*
${MKDIR} ${WRKDIR}
${TOUCH} ${EXTRACT_COOKIE}
${TOUCH} ${PATCH_COOKIE}
@@ -311,7 +311,7 @@ post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/unowinreg.dll ${WRKSRC}/external/unowinreg/
${CP} ${FILESDIR}/freebsd-aoo-intro-developer.png ${WRKSRC}/default_images/introabout/intro.png
${CP} ${FILESDIR}/freebsd-aoo-about-developer.png ${WRKSRC}/default_images/introabout/about.png
- ${RM} -rf ${WRKSRC}/l10n
+ ${RM} -r ${WRKSRC}/l10n
${LN} -sf ${UNZIP_CMD} ${WRKSRC}/solenv/bin/unzip
${SED} -e '\|^For main/vcl/unx/generic/fontmanager/parseAFM|,/^__/p' \
-e '\|^For PostScript(R) AFM|,/^__/p' \
diff --git a/editors/rox-edit/Makefile b/editors/rox-edit/Makefile
index 7c706651364c..912796102130 100644
--- a/editors/rox-edit/Makefile
+++ b/editors/rox-edit/Makefile
@@ -17,7 +17,7 @@ USES= python tar:bzip2
post-extract:
@${FIND} ${WRKSRC} -name .cvsignore | ${XARGS} ${RM}
- @${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -rf
+ @${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -r
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}
diff --git a/editors/semi/Makefile b/editors/semi/Makefile
index 02b67a2bdbb9..39887ba902ec 100644
--- a/editors/semi/Makefile
+++ b/editors/semi/Makefile
@@ -176,7 +176,7 @@ info-package-install:
done)
manifest-install:
- @${RM} -f ${WRKDIR}/${MANIFEST}
+ @${RM} ${WRKDIR}/${MANIFEST}
@${CAT} ${PLIST} | ${GREP} -e "^%%EMACS_PACKAGESDIR%%" | \
${SED} -e "s;^%%EMACS_PACKAGESDIR%%/;;" > ${WRKDIR}/${MANIFEST}
@${INSTALL_DATA} ${WRKDIR}/${MANIFEST} \