aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2010-03-02 03:09:48 +0000
committerHiroki Sato <hrs@FreeBSD.org>2010-03-02 03:09:48 +0000
commit012ef1250221d58c46416b9499b8dc0d26fcdb73 (patch)
tree09341f9dbe88e702ec4d2e4b7442db68c7efe41c /editors
parent9df13cbc23ccbdba352e2b559b5472802df82467 (diff)
downloadports-012ef1250221d58c46416b9499b8dc0d26fcdb73.tar.gz
ports-012ef1250221d58c46416b9499b8dc0d26fcdb73.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/tamago/Makefile5
-rw-r--r--editors/tamago/distinfo6
-rw-r--r--editors/tamago/files/patch-wnnrpc.el21
-rw-r--r--editors/tamago/files/post-patch-egg-com.el96
-rw-r--r--editors/tamago/files/post-patch-egg-wnn.el30
-rw-r--r--editors/tamago/files/post-patch-egg-wnnrpc.el19
6 files changed, 39 insertions, 138 deletions
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index c6ab467caf6f..f59de1f14fe2 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tamago
-PORTVERSION= 4.0.6.0.20041122.11
-PORTREVISION= 8
+PORTVERSION= 4.0.6.0.20041122.18
CATEGORIES= editors elisp
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/e/egg
@@ -16,7 +15,7 @@ DISTNAME= egg_4.0.6+0.20041122cvs.orig
PATCH_SITES= ${MASTER_SITE_DEBIAN:S,%SUBDIR%,pool/main/e/egg,} \
${MASTER_SITE_LOCAL:S,%SUBDIR%,nork,}
-PATCHFILES= egg_4.0.6+0.20041122cvs-11.diff.gz
+PATCHFILES= egg_4.0.6+0.20041122cvs-18.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= hrs@FreeBSD.org
diff --git a/editors/tamago/distinfo b/editors/tamago/distinfo
index 3cccc5f31e9e..e7ce616e38ec 100644
--- a/editors/tamago/distinfo
+++ b/editors/tamago/distinfo
@@ -1,6 +1,6 @@
MD5 (egg_4.0.6+0.20041122cvs.orig.tar.gz) = 64ec1af61f6e265c05447dd4e2a83aae
SHA256 (egg_4.0.6+0.20041122cvs.orig.tar.gz) = 722413515f2d60418d98250c8aed2b811e6b5363cdb69899193d454afe425115
SIZE (egg_4.0.6+0.20041122cvs.orig.tar.gz) = 287308
-MD5 (egg_4.0.6+0.20041122cvs-11.diff.gz) = 5c45cde2aed743cfc9c9e194c6b411c7
-SHA256 (egg_4.0.6+0.20041122cvs-11.diff.gz) = 31c9d1e161cbebb13412a90374d538792f257047de0b3569d5c3632c2a0860b4
-SIZE (egg_4.0.6+0.20041122cvs-11.diff.gz) = 28295
+MD5 (egg_4.0.6+0.20041122cvs-18.diff.gz) = e0b0a61d9a142f57cb514ff2aa24a7c8
+SHA256 (egg_4.0.6+0.20041122cvs-18.diff.gz) = e6ff6e7e1b52b38ba87cadc0733add1651827366af766bd78719b9ab6fd57e8b
+SIZE (egg_4.0.6+0.20041122cvs-18.diff.gz) = 28267
diff --git a/editors/tamago/files/patch-wnnrpc.el b/editors/tamago/files/patch-wnnrpc.el
deleted file mode 100644
index 1df5c148999f..000000000000
--- a/editors/tamago/files/patch-wnnrpc.el
+++ /dev/null
@@ -1,21 +0,0 @@
---- egg/wnnrpc.el Sat Jun 16 23:30:29 2007
-+++ egg/wnnrpc.el Sat Jun 16 23:29:00 2007
-@@ -714,8 +714,14 @@
- ,send-expr ,@rcv-exprs))
-
- (defmacro wnnrpc-get-result (&rest body)
-- `(let (result)
-- (comm-unpack (u) result)
-+ `(let (result resulth)
-+ (comm-unpack (w w) resulth result)
-+ (cond ((and (= result 65535) (= resulth 65535))
-+ (setq result -1))
-+ ((= resulth (lsh (lsh resulth 16) -16))
-+ (setq result (+ (lsh resulth 16) result)))
-+ (t
-+ (error "overflow")))
- (if (< result 0)
- (progn
- (comm-unpack (u) result)
-
-
diff --git a/editors/tamago/files/post-patch-egg-com.el b/editors/tamago/files/post-patch-egg-com.el
deleted file mode 100644
index bf83d1d06c61..000000000000
--- a/editors/tamago/files/post-patch-egg-com.el
+++ /dev/null
@@ -1,96 +0,0 @@
---- egg-com.el.2 2010-03-02 05:19:01.000000000 +0900
-+++ egg-com.el 2010-03-02 05:19:04.000000000 +0900
-@@ -44,8 +44,65 @@
-
- ;; Japanese
-
-+(defun fixed-euc-jp-pre-write-conversion (from to)
-+ (let ((work-buf (generate-new-buffer " *temp*"))
-+ ch)
-+ (if (stringp from)
-+ (encode-coding-string from 'euc-japan nil work-buf)
-+ (encode-coding-region from to 'euc-japan work-buf))
-+ (set-buffer work-buf)
-+ (set-buffer-multibyte nil)
-+ (goto-char (point-min))
-+ (while (not (eobp))
-+ (setq ch (following-char))
-+ (cond ((= ch #x8E) ; SS2 for JISX0201-kana
-+ (delete-char 1) ; SS2 BYTE -> 0 BYTE&0x7F
-+ (insert 0)
-+ (forward-char 1))
-+ ((= ch #x8F) ; SS3 for JISX0212
-+ (delete-char 1) ; SS3 BYTE1 BYTE2 -> BYTE1 BYTE2&0x7F
-+ (forward-char 1)
-+ (setq ch (following-char))
-+ (delete-char 1)
-+ (insert (logand ch #x7F)))
-+ ((>= ch #xA0) ; JISX0208
-+ (forward-char 2))
-+ (t ; ASCII
-+ (insert 0) ; BYTE -> 0 BYTE
-+ (forward-char 1))))))
-+
-+(defun fixed-euc-jp-post-read-conversion (len)
-+ (let ((str (string-as-unibyte (buffer-substring (point) (+ (point) len))))
-+ (pos (point))
-+ i ch1 ch2)
-+ (delete-region (point) (+ (point) len))
-+ (setq i 0)
-+ (while (< i len)
-+ (setq ch1 (aref str i))
-+ (setq ch2 (aref str (1+ i)))
-+ (cond ((>= ch1 #x80)
-+ (if (>= ch2 #x80)
-+ (setq ch1 ; JISX0208
-+ (decode-char 'japanese-jisx0208
-+ (logior (lsh (logand ch1 #x7F) 8)
-+ (logand ch2 #x7F))))
-+ (setq ch1 ; JISX0212
-+ (decode-char 'japanese-jisx0212
-+ (logior (lsh (logand ch1 #x7F) 8) ch2)))))
-+ (t
-+ (if (>= ch2 #x80)
-+ (setq ch1 ; JISX0201-kana
-+ (decode-char 'katakana-jisx0201 (logand ch2 #x7F)))
-+ (setq ch1 ch2))))
-+ (insert ch1)
-+ (setq i (+ i 2)))
-+ (prog1 (- (point) pos)
-+ (goto-char pos))))
-+
- (eval-and-compile
--(define-ccl-program ccl-decode-fixed-euc-jp
-+ (if (string< mule-version "6.0")
-+ (progn
-+ (define-ccl-program ccl-decode-fixed-euc-jp
- `(2
- ((r2 = ,(charset-id 'japanese-jisx0208))
- (r3 = ,(charset-id 'japanese-jisx0212))
-@@ -96,11 +153,24 @@
- (write-read-repeat r0)))
- (read r0)
- (repeat)))))
--)
-
- (make-coding-system 'fixed-euc-jp 4 ?W "Coding System for fixed EUC Japanese"
- (cons ccl-decode-fixed-euc-jp ccl-encode-fixed-euc-jp))
--
-+)
-+ (define-charset 'fixed-euc-jp
-+ "Fixed EUC Japanese"
-+ :dimension 2
-+ :superset '(ascii
-+ (katakana-jisx0201 . #x80)
-+ (japanese-jisx0208 . #x8080)
-+ (japanese-jisx0212 . #x8000)))
-+ (define-coding-system 'fixed-euc-jp
-+ "Coding System for fixed EUC Japanese"
-+ :mnemonic ?W
-+ :coding-type 'charset
-+ :charset-list '(fixed-euc-jp))
-+ )
-+)
- ;; Korean
-
- (eval-and-compile
diff --git a/editors/tamago/files/post-patch-egg-wnn.el b/editors/tamago/files/post-patch-egg-wnn.el
index 75ae49483989..11c6de2c5799 100644
--- a/editors/tamago/files/post-patch-egg-wnn.el
+++ b/editors/tamago/files/post-patch-egg-wnn.el
@@ -1,5 +1,5 @@
---- egg/wnn.el.orig 2008-11-08 14:09:35.000000000 +0900
-+++ egg/wnn.el 2008-11-08 14:23:22.000000000 +0900
+--- egg/wnn.el.2 2010-03-02 10:35:45.000000000 +0900
++++ egg/wnn.el 2010-03-02 11:54:30.000000000 +0900
@@ -82,6 +82,10 @@
(const wnn-uniq)
(const wnn-uniq-kanji)))
@@ -93,7 +93,7 @@
- (setq port-off (string-to-int (substring hostname (match-end 0)))
- hostname (substring hostname 0 (match-beginning 0))))
- (and (equal hostname "") (setq hostname "localhost"))
-+ hostname-list (cdr hostname-list))
++ hostname-list (cdr hostname-list))
+ (if (or (and (getenv serverenv)
+ (string-match "^unix$" (getenv serverenv)))
+ (and (null (getenv serverenv))
@@ -103,7 +103,7 @@
+ (setq hostname "unix"
+ family 'local
+ port udpath))
-+ (progn
++ (progn
+ (setq hostname (or (getenv serverenv) hostname "localhost"))
+ (if (null (string-match ":" hostname))
+ (setq port-off 0)
@@ -123,17 +123,17 @@
- (+ port port-off)))
- ((error quit))))
- (when proc
-+ (if (fboundp 'make-network-process)
-+ (condition-case nil
-+ (setq proc (make-network-process :name proc-name :buffer buf :host host :service port :family family))
-+ ((error quit)))
-+ (if (string-match "^unix$" hostname)
-+ (let ((process-connection-type nil))
-+ (setq proc (start-process proc-name buf egg-wnn-helper-path port)))
-+ (condition-case nil
-+ (setq proc (open-network-stream proc-name buf hostname port))
-+ (error quit)))))
-+ (when (processp proc)
++ (if (fboundp 'make-network-process)
++ (condition-case nil
++ (setq proc (make-network-process :name proc-name :buffer buf :host host :service port :family family))
++ ((error quit)))
++ (if (string-match "^unix$" hostname)
++ (let ((process-connection-type nil))
++ (setq proc (start-process proc-name buf egg-wnn-helper-path port)))
++ (condition-case nil
++ (setq proc (open-network-stream proc-name buf hostname port))
++ (error quit)))))
++ (when (processp proc)
(process-kill-without-query proc)
(set-process-coding-system proc 'binary 'binary)
(set-process-sentinel proc 'wnn-comm-sentinel)
diff --git a/editors/tamago/files/post-patch-egg-wnnrpc.el b/editors/tamago/files/post-patch-egg-wnnrpc.el
new file mode 100644
index 000000000000..e6730da755b1
--- /dev/null
+++ b/editors/tamago/files/post-patch-egg-wnnrpc.el
@@ -0,0 +1,19 @@
+--- egg/wnnrpc.el.2 2010-03-02 10:34:18.000000000 +0900
++++ egg/wnnrpc.el 2010-03-02 10:34:42.000000000 +0900
+@@ -714,8 +714,14 @@
+ ,send-expr ,@rcv-exprs))
+
+ (defmacro wnnrpc-get-result (&rest body)
+- `(let (result)
+- (comm-unpack (i) result)
++ `(let (result resulth)
++ (comm-unpack (w w) resulth result)
++ (cond ((and (= result 65535) (= resulth 65535))
++ (setq result -1))
++ ((= resulth (lsh (lsh resulth 16) -16))
++ (setq result (+ (lsh resulth 16) result)))
++ (t
++ (error "overflow")))
+ (if (< result 0)
+ (progn
+ (comm-unpack (i) result)