aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2004-07-23 19:10:32 +0000
committerEric Anholt <anholt@FreeBSD.org>2004-07-23 19:10:32 +0000
commit4eb209da7d941e66e0cb065aead6bda76c9e97f3 (patch)
treec9cf2fdcee3885499960b9c706dacac0a0080f8e /editors
parentb188150955302fdc3c1402eb0688a84d1f2cf451 (diff)
downloadports-4eb209da7d941e66e0cb065aead6bda76c9e97f3.tar.gz
ports-4eb209da7d941e66e0cb065aead6bda76c9e97f3.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/elvis/Makefile2
-rw-r--r--editors/openoffice-1.0/Makefile2
-rw-r--r--editors/openoffice-1.1-devel/Makefile2
-rw-r--r--editors/openoffice-1.1/Makefile2
-rw-r--r--editors/openoffice-2.0-devel/Makefile5
-rw-r--r--editors/openoffice-3-devel/Makefile5
-rw-r--r--editors/openoffice-3/Makefile5
-rw-r--r--editors/openoffice.org-1.0/Makefile2
-rw-r--r--editors/openoffice.org-1.1-devel/Makefile2
-rw-r--r--editors/openoffice.org-1.1/Makefile2
-rw-r--r--editors/openoffice.org-2-RC/Makefile5
-rw-r--r--editors/openoffice.org-2-devel/Makefile5
-rw-r--r--editors/openoffice.org-2.0-devel/Makefile5
-rw-r--r--editors/openoffice.org-2.0/Makefile5
-rw-r--r--editors/openoffice.org-2/Makefile5
-rw-r--r--editors/openoffice.org-3-RC/Makefile5
-rw-r--r--editors/openoffice.org-3-devel/Makefile5
-rw-r--r--editors/openoffice.org-3/Makefile5
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile5
19 files changed, 31 insertions, 43 deletions
diff --git a/editors/elvis/Makefile b/editors/elvis/Makefile
index 4ebb8df4560d..db514fefb065 100644
--- a/editors/elvis/Makefile
+++ b/editors/elvis/Makefile
@@ -34,7 +34,7 @@ PKGNAMESUFFIX= -nox11
CONFIGURE_ARGS+= --without-x
.else
USE_XPM= yes
-.if ${XFREE86_VERSION} < 4 || defined(WITHOUT_XFT)
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3 || defined(WITHOUT_XFT)
CONFIGURE_ARGS+= --without-xft
.else
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
diff --git a/editors/openoffice-1.0/Makefile b/editors/openoffice-1.0/Makefile
index 1b1ff8dbca88..521c373075e4 100644
--- a/editors/openoffice-1.0/Makefile
+++ b/editors/openoffice-1.0/Makefile
@@ -120,7 +120,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice-1.1-devel/Makefile b/editors/openoffice-1.1-devel/Makefile
index 4df3e3252c88..cbce9ad6d0a7 100644
--- a/editors/openoffice-1.1-devel/Makefile
+++ b/editors/openoffice-1.1-devel/Makefile
@@ -113,7 +113,7 @@ BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14 \
${ANT}:${PORTSDIR}/devel/apache-ant \
${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice-1.1/Makefile b/editors/openoffice-1.1/Makefile
index 197196eebc85..f2c3a61cc3a5 100644
--- a/editors/openoffice-1.1/Makefile
+++ b/editors/openoffice-1.1/Makefile
@@ -116,7 +116,7 @@ BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14 \
${ANT}:${PORTSDIR}/devel/apache-ant \
${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice-2.0-devel/Makefile b/editors/openoffice-2.0-devel/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice-2.0-devel/Makefile
+++ b/editors/openoffice-2.0-devel/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index 1b1ff8dbca88..521c373075e4 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -120,7 +120,7 @@ BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-1.1-devel/Makefile b/editors/openoffice.org-1.1-devel/Makefile
index 4df3e3252c88..cbce9ad6d0a7 100644
--- a/editors/openoffice.org-1.1-devel/Makefile
+++ b/editors/openoffice.org-1.1-devel/Makefile
@@ -113,7 +113,7 @@ BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14 \
${ANT}:${PORTSDIR}/devel/apache-ant \
${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-1.1/Makefile b/editors/openoffice.org-1.1/Makefile
index 197196eebc85..f2c3a61cc3a5 100644
--- a/editors/openoffice.org-1.1/Makefile
+++ b/editors/openoffice.org-1.1/Makefile
@@ -116,7 +116,7 @@ BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14 \
${ANT}:${PORTSDIR}/devel/apache-ant \
${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-2.0-devel/Makefile b/editors/openoffice.org-2.0-devel/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice.org-2.0-devel/Makefile
+++ b/editors/openoffice.org-2.0-devel/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-2.0/Makefile b/editors/openoffice.org-2.0/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice.org-2.0/Makefile
+++ b/editors/openoffice.org-2.0/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index 49fb1a50d061..bf16cff1e5ec 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -28,6 +28,7 @@ USE_BZIP2= yes
USE_BISON= yes
USE_GMAKE= yes
USE_CCACHE= yes
+USE_XLIB= yes
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
@@ -67,18 +68,16 @@ CC= gcc32
CXX= g++32
.endif
-
BUILD_DEPENDS+= ${JAVAVM}:${PORTSDIR}/java/jdk14
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= ${ANT}:${PORTSDIR}/devel/apache-ant
-BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
BUILD_DEPENDS+= ${X11BASE}/lib/libXft.so:${PORTSDIR}/x11-fonts/libXft
BUILD_DEPENDS+= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip
BUILD_DEPENDS+= gcp:${PORTSDIR}/sysutils/coreutils
.if !defined(DISPLAY)
-BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
+BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT}
.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \