aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-10-08 01:40:26 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-10-08 01:40:26 +0000
commit58ca723ef5821d19912bf5415bc5ea16b90ba857 (patch)
treefaaee7b623fc117ad54351bd1bee66d2f49f5b58 /editors
parentc8e61c7d9380113627d7bc0ba4e56afa13872526 (diff)
downloadports-58ca723ef5821d19912bf5415bc5ea16b90ba857.tar.gz
ports-58ca723ef5821d19912bf5415bc5ea16b90ba857.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/vim6/Makefile116
-rw-r--r--editors/vim6/distinfo12
-rw-r--r--editors/vim6/files/patch-0196
-rw-r--r--editors/vim6/files/patch-028
-rw-r--r--editors/vim6/pkg-comment1
-rw-r--r--editors/vim6/pkg-descr24
-rw-r--r--editors/vim6/pkg-plist22
7 files changed, 0 insertions, 279 deletions
diff --git a/editors/vim6/Makefile b/editors/vim6/Makefile
deleted file mode 100644
index 69353ba16485..000000000000
--- a/editors/vim6/Makefile
+++ /dev/null
@@ -1,116 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: vim
-# Date created: Sat June 29, 1996
-# Whom: David O'Brien (obrien@cs.ucdavis.edu)
-#
-# $FreeBSD$
-#
-
-PORTNAME?= vim
-PORTVERSION= 6.0.11
-PORTREVISION?= 0
-CATEGORIES?= editors
-MASTER_SITES= ftp://nuxi.ucdavis.edu/pub/vim/unix/ \
- ftp://ftp.nuxi.com/pub/vim/unix/ \
- ftp://ftp.vim.org/pub/vim/unix/ \
- ftp://ftp.is.co.za/applications/editors/vim/unix/ \
- ftp://ftp.prz.tu-berlin.de/pub/unix/editors/vim/unix/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.vim.org/pub/vim/unix/ \
- ftp://ftp.progsoc.uts.edu.au/pub/vim/unix/
-DISTNAME= vim-${PORTVERSION:C/\.[0-9]*$//}
-
-PATCH_SITES= ${MASTER_SITES:S/unix/patches/}
-.for p in 01 02 03 04 05 06 07 08 09 10 11
-PATCHFILES+= ${PORTVERSION:C/\.[0-9]*$//}.0${p}
-.endfor
-
-MAINTAINER?= obrien@FreeBSD.org
-
-.if defined(PACKAGE_BUILDING) && !defined(LITE)
-BUILD_DEPENDS= tclsh8.0:${PORTSDIR}/lang/tcl80
-LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80
-USE_PERL5= yes
-USE_PYTHON= yes
-.endif
-
-USE_BZIP2= yes
-DIST_SUBDIR= vim
-WRKSRC= ${WRKDIR}/vim${PORTVERSION:C/\.[0-9]*$//:S/.//g}/src
-PATCH_DIST_ARGS= -d ${WRKDIR}/${PORTNAME}${PORTVERSION:C/\.[0-9]*$//:S/.//g} --forward --quiet -E ${PATCH_DIST_STRIP}
-MAKE_ARGS+= CONF_ARGS="--prefix=${PREFIX} --with-tlib=termlib"
-ALL_TARGET= #
-PLIST_SUB= VIM_VER=${DISTNAME:S/-//:S/.//}
-MAN1= evim.1 vim.1 vimdiff.1 vimtutor.1 xxd.1
-MLINKS= vim.1 rvim.1 vim.1 rview.1
-
-.include <bsd.port.pre.mk>
-
-.if !defined(LITE)
-MLINKS+= vim.1 gvim.1 vim.1 gview.1 vim.1 rgvim.1 vim.1 rgview.1 \
- eview.1 gvimdiff.1
-
-MAKE_ARGS+= CONF_OPT_MAX="--enable-max-features"
-I18N= CONF_OPT_MULTIBYTE="--enable-multibyte --enable-fontset --enable-xim"
-
-.if defined(NO_GUI)
-WITHOUT_X11= yes
-.endif
-
-.if !defined(WITHOUT_X11)
-# for now default the GUI to the GTK+ one
-# will be reviewed when the GTK+ 1.{3,4} behemoth is released
-.if !defined(WITH_ATHENA) && !defined(WITH_GTK) && !defined(WITH_MOTIF)
-WITH_GTK= yes
-.endif
-
-.if defined(WITH_ATHENA)
-MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=athena" ${I18N}
-.elif defined(WITH_GTK)
-USE_GTK= yes
-MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=gtk --with-gtk-prefix=${X11BASE}" ${I18N}
-MAKE_ARGS+= X_LIBS="$(X_LIBS) -lXt"
-.elif defined(WITH_MOTIF)
-USE_MOTIF= yes
-MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=motif --with-motif-lib=\"${MOTIFLIB}\"" MOTIFHOME=${X11BASE} ${I18N}
-.endif
-.else # WITHOUT_X11
-MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x ${I18N}"
-.endif # WITHOUT_X11
-
-.if defined(PACKAGE_BUILDING)
-MAKE_ARGS+= CONF_OPT_PERL="--enable-perlinterp --enable-pythoninterp --enable-tclinterp --enable-cscope"
-.endif
-
-.else # LITE
-MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x"
-MAKE_ARGS+= CONF_OPT_PERL="--disable-perlinterp --disable-pythoninterp --disable-tclinterp"
-.endif # LITE
-
-pre-build:
- @(cd ${WRKSRC}; ${MAKE} distclean)
-
-post-install:
- [ -e ${PREFIX}/bin/gvim ] || (cd ${PREFIX}/bin ; ${LN} -sf vim gvim)
- # below needed for `vim-lite' port
- test -e ${PREFIX}/bin/rgvim || (cd ${PREFIX}/bin ; ${LN} -s vim rgvim)
- test -e ${PREFIX}/bin/gview || (cd ${PREFIX}/bin ; ${LN} -s vim gview)
- test -e ${PREFIX}/bin/rgview || (cd ${PREFIX}/bin ; ${LN} -s vim rgview)
- test -e ${PREFIX}/bin/evim || (cd ${PREFIX}/bin ; ${LN} -s vim evim)
- test -e ${PREFIX}/bin/eview || (cd ${PREFIX}/bin ; ${LN} -s vim eview)
- cd ${PREFIX} ;\
- find share/vim/${DISTNAME:S/-//:S/.//}/ -type f -o -type l \
- | sort \
- >${WRKDIR}/PLIST.share-vim
- cd ${PREFIX} ;\
- find share/vim/${DISTNAME:S/-//:S/.//}/ -type d \
- | sort -r | ${SED} -e 's/^/@dirrm /g' \
- >>${WRKDIR}/PLIST.share-vim
- ${ECHO} "r ${TMPPLIST}" > ${WRKDIR}/ex.script
- ${ECHO} "/Insert PLIST.share-vim" >> ${WRKDIR}/ex.script
- ${ECHO} "d" >> ${WRKDIR}/ex.script
- ${ECHO} "r ${WRKDIR}/PLIST.share-vim" >> ${WRKDIR}/ex.script
- ${ECHO} "x!" >> ${WRKDIR}/ex.script
- ${CP} -p ${TMPPLIST} ${TMPPLIST}.pre-share-vim
- cd ${WRKDIR} ; ex < ex.script
-
-.include <bsd.port.post.mk>
diff --git a/editors/vim6/distinfo b/editors/vim6/distinfo
deleted file mode 100644
index 0fe06cd420e7..000000000000
--- a/editors/vim6/distinfo
+++ /dev/null
@@ -1,12 +0,0 @@
-MD5 (vim/vim-6.0.tar.bz2) = 9d9ca84d489af6b3f54639dd97af3774
-MD5 (vim/6.0.001) = f0001f677137de0743950f00720a2422
-MD5 (vim/6.0.002) = f5f8ac207f9666296d6343ba4dd297b4
-MD5 (vim/6.0.003) = 72d0cd2b572ee69c60e50aa977a2e4df
-MD5 (vim/6.0.004) = bb64e4166fa9d80b294a98ef2629610c
-MD5 (vim/6.0.005) = 599aed2108ec8ee11676d8a6c1dd9e14
-MD5 (vim/6.0.006) = b102a80a5cfadb2979ac2829b1ac9398
-MD5 (vim/6.0.007) = 2205e65a4b41669c58fd3f73ce2cb539
-MD5 (vim/6.0.008) = 4b1bc95a9df984d847f58d9dd121ef7e
-MD5 (vim/6.0.009) = 4f4a9dbd1555cda9fc478afb0917edf9
-MD5 (vim/6.0.010) = 321034698f583151ba6f3adfe4c452d9
-MD5 (vim/6.0.011) = 39f65bdfc690f6fc67d21ee93339f450
diff --git a/editors/vim6/files/patch-01 b/editors/vim6/files/patch-01
deleted file mode 100644
index e33fd5a1da70..000000000000
--- a/editors/vim6/files/patch-01
+++ /dev/null
@@ -1,96 +0,0 @@
---- Makefile.orig Sun Jul 22 10:49:39 2001
-+++ Makefile Sat Jul 28 21:52:21 2001
-@@ -280,2 +280,3 @@
- # CONFIGURE - configure arguments {{{1
-+CONF_ARGS = --prefix=$(PREFIX)
- # You can give a lot of options to configure.
-@@ -1679,36 +1680,36 @@
- $(DEST_BIN)/$(EXTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(EXTARGET)
-+ #cd $(DEST_BIN); ln -sf $(VIMTARGET) $(EXTARGET)
-
- $(DEST_BIN)/$(VIEWTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(VIEWTARGET)
-+ #cd $(DEST_BIN); ln -sf $(VIMTARGET) $(VIEWTARGET)
-
- $(DEST_BIN)/$(GVIMTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(GVIMTARGET)
-+ cd $(DEST_BIN); ln -sf $(VIMTARGET) $(GVIMTARGET)
-
- $(DEST_BIN)/$(GVIEWTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(GVIEWTARGET)
-+ cd $(DEST_BIN); ln -sf $(VIMTARGET) $(GVIEWTARGET)
-
- $(DEST_BIN)/$(RVIMTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(RVIMTARGET)
-+ cd $(DEST_BIN); ln -sf $(VIMTARGET) $(RVIMTARGET)
-
- $(DEST_BIN)/$(RVIEWTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(RVIEWTARGET)
-+ cd $(DEST_BIN); ln -sf $(VIMTARGET) $(RVIEWTARGET)
-
- $(DEST_BIN)/$(RGVIMTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(RGVIMTARGET)
-+ cd $(DEST_BIN); ln -sf $(VIMTARGET) $(RGVIMTARGET)
-
- $(DEST_BIN)/$(RGVIEWTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(RGVIEWTARGET)
-+ cd $(DEST_BIN); ln -sf $(VIMTARGET) $(RGVIEWTARGET)
-
- $(DEST_BIN)/$(VIMDIFFTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(VIMDIFFTARGET)
-+ cd $(DEST_BIN); ln -sf $(VIMTARGET) $(VIMDIFFTARGET)
-
- $(DEST_BIN)/$(GVIMDIFFTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(GVIMDIFFTARGET)
-+ cd $(DEST_BIN); ln -sf $(VIMTARGET) $(GVIMDIFFTARGET)
-
- $(DEST_BIN)/$(EVIMTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(EVIMTARGET)
-+ cd $(DEST_BIN); ln -sf $(VIMTARGET) $(EVIMTARGET)
-
- $(DEST_BIN)/$(EVIEWTARGET):
-- cd $(DEST_BIN); ln -s $(VIMTARGET) $(EVIEWTARGET)
-+ cd $(DEST_BIN); ln -sf $(VIMTARGET) $(EVIEWTARGET)
-
-@@ -1730,30 +1731,30 @@
- $(DEST_MAN)/$(EXNAME).1:
-- cd $(DEST_MAN); ln -s $(VIMNAME).1 $(EXNAME).1
-+ cd $(DEST_MAN); ln -sf $(VIMNAME).1 $(EXNAME).1
-
- $(DEST_MAN)/$(VIEWNAME).1:
-- cd $(DEST_MAN); ln -s $(VIMNAME).1 $(VIEWNAME).1
-+ cd $(DEST_MAN); ln -sf $(VIMNAME).1 $(VIEWNAME).1
-
- $(DEST_MAN)/$(GVIMNAME).1:
-- cd $(DEST_MAN); ln -s $(VIMNAME).1 $(GVIMNAME).1
-+ cd $(DEST_MAN); ln -sf $(VIMNAME).1 $(GVIMNAME).1
-
- $(DEST_MAN)/$(GVIEWNAME).1:
-- cd $(DEST_MAN); ln -s $(VIMNAME).1 $(GVIEWNAME).1
-+ cd $(DEST_MAN); ln -sf $(VIMNAME).1 $(GVIEWNAME).1
-
- $(DEST_MAN)/$(RVIMNAME).1:
-- cd $(DEST_MAN); ln -s $(VIMNAME).1 $(RVIMNAME).1
-+ cd $(DEST_MAN); ln -sf $(VIMNAME).1 $(RVIMNAME).1
-
- $(DEST_MAN)/$(RVIEWNAME).1:
-- cd $(DEST_MAN); ln -s $(VIMNAME).1 $(RVIEWNAME).1
-+ cd $(DEST_MAN); ln -sf $(VIMNAME).1 $(RVIEWNAME).1
-
- $(DEST_MAN)/$(RGVIMNAME).1:
-- cd $(DEST_MAN); ln -s $(VIMNAME).1 $(RGVIMNAME).1
-+ cd $(DEST_MAN); ln -sf $(VIMNAME).1 $(RGVIMNAME).1
-
- $(DEST_MAN)/$(RGVIEWNAME).1:
-- cd $(DEST_MAN); ln -s $(VIMNAME).1 $(RGVIEWNAME).1
-+ cd $(DEST_MAN); ln -sf $(VIMNAME).1 $(RGVIEWNAME).1
-
- $(DEST_MAN)/$(GVIMDIFFNAME).1:
-- cd $(DEST_MAN); ln -s $(VIMDIFFNAME).1 $(GVIMDIFFNAME).1
-+ cd $(DEST_MAN); ln -sf $(VIMDIFFNAME).1 $(GVIMDIFFNAME).1
-
- $(DEST_MAN)/$(EVIEWNAME).1:
-- cd $(DEST_MAN); ln -s $(EVIMNAME).1 $(EVIEWNAME).1
-+ cd $(DEST_MAN); ln -sf $(EVIMNAME).1 $(EVIEWNAME).1
-
diff --git a/editors/vim6/files/patch-02 b/editors/vim6/files/patch-02
deleted file mode 100644
index db221f9e69ba..000000000000
--- a/editors/vim6/files/patch-02
+++ /dev/null
@@ -1,8 +0,0 @@
---- auto/configure.orig Tue Oct 31 13:03:47 2000
-+++ auto/configure Mon Nov 6 11:26:36 2000
-@@ -3171 +3171 @@
-- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
-+ GTK_CONFIG=${GTK_CONFIG}
-@@ -3175 +3175 @@
-- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
-+ GTK_CONFIG=${GTK_CONFIG}
diff --git a/editors/vim6/pkg-comment b/editors/vim6/pkg-comment
deleted file mode 100644
index 06543ff852c3..000000000000
--- a/editors/vim6/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Vi "workalike", with many additional features
diff --git a/editors/vim6/pkg-descr b/editors/vim6/pkg-descr
deleted file mode 100644
index 67770104fbe3..000000000000
--- a/editors/vim6/pkg-descr
+++ /dev/null
@@ -1,24 +0,0 @@
-Vim is a virtually compatible, extreamly enhanced, version of the UNIX
-text editor vi.
-
-There are a lot of enhancements above Vi: multi level undo, multi-windows
-and buffers, syntax highlighting, command line editing, filename completion,
-on-line help, visual selection, etc..
-
-Many features above standard vi's have been added:
- multiple windows and buffers, multi level undo, command line history,
- filename completion, selection highlighting, block operations (including
- column/rectangular blocks), syntax highlighting, on-line help, etc.
- Embeded Perl, Tcl, and Python support.
- See ":help vi_diff" for a summary of the differences between Vim and Vi.
-
- An X-windows aware or a full X-windows GUI version can also be built
- that allows full use of the mouse and pull-down menus
-
-See http://www.vim.org/why.html for a full explanation of Vim's features.
-
-Portability to all UNIX platforms, AmigaOS, Archimedes, Atari MiNT, BeOS,
-M$-DOS, MacOS, OS/2, VMS, WinNT+Win95.
-
--- David (obrien@cs.ucdavis.edu)
-WWW: http://www.vim.org/
diff --git a/editors/vim6/pkg-plist b/editors/vim6/pkg-plist
deleted file mode 100644
index e0047f3f4545..000000000000
--- a/editors/vim6/pkg-plist
+++ /dev/null
@@ -1,22 +0,0 @@
-@comment $FreeBSD$
-bin/vim
-bin/vimtutor
-bin/xxd
-@comment bin/ex
-@comment bin/gex
-bin/eview
-bin/evim
-bin/gview
-bin/gvim
-bin/rgview
-bin/rgvim
-bin/rview
-bin/rvim
-bin/vimdiff
-bin/gvimdiff
-@comment bin/view
-@exec mkdir -p %D/share/vim/%%VIM_VER%%/lang
-@comment Insert PLIST.share-vim here
-@comment -=[ begin PLIST.share-vim ]=-
-@comment -=[ end PLIST.share-vim ]=-
-@dirrm share/vim