aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2021-03-27 19:00:08 +0000
committerJuraj Lutter <otis@FreeBSD.org>2021-03-27 19:00:08 +0000
commit8311ffad211cc0e3fd96127a55ff980761928a79 (patch)
tree1805e2bcf8f482ba4a6fd4826b17c63667aff227 /editors
parent42a3961a9c6a67a7618803f154bf5c6054fb5126 (diff)
downloadports-8311ffad211cc0e3fd96127a55ff980761928a79.tar.gz
ports-8311ffad211cc0e3fd96127a55ff980761928a79.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/poke/Makefile36
-rw-r--r--editors/poke/distinfo3
-rw-r--r--editors/poke/pkg-descr6
-rw-r--r--editors/poke/pkg-plist44
5 files changed, 90 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index cbed61a2f1e0..80d4daac4456 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -218,6 +218,7 @@
SUBDIR += picpas
SUBDIR += pluma
SUBDIR += poedit
+ SUBDIR += poke
SUBDIR += psgml
SUBDIR += puff
SUBDIR += py-babi
diff --git a/editors/poke/Makefile b/editors/poke/Makefile
new file mode 100644
index 000000000000..1734e05ff3d4
--- /dev/null
+++ b/editors/poke/Makefile
@@ -0,0 +1,36 @@
+# Created by: Olga Smirnova <mistresssilvara@hotmail.com>
+# $FreeBSD$
+
+PORTNAME= poke
+PORTVERSION= 1.0
+CATEGORIES= editors
+MASTER_SITES= GNU
+
+MAINTAINER= mistresssilvara@hotmail.com
+COMMENT= Scriptable interactive binary editor
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= help2man:misc/help2man
+LIB_DEPENDS= libgc.so:devel/boehm-gc \
+ libjson-c.so:devel/json-c \
+ libtextstyle.so:devel/libtextstyle
+
+USES= gmake libtool pkgconfig readline
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --disable-gui
+INSTALL_TARGET= install-strip
+
+INFO= ${PORTNAME}
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
+
+.include <bsd.port.mk>
diff --git a/editors/poke/distinfo b/editors/poke/distinfo
new file mode 100644
index 000000000000..72ca81175954
--- /dev/null
+++ b/editors/poke/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614569691
+SHA256 (poke-1.0.tar.gz) = de930b8700c0772b3c2cd0d0ca35f50fd3d77bdf82c6251eb516b49e8ca25b0a
+SIZE (poke-1.0.tar.gz) = 6698818
diff --git a/editors/poke/pkg-descr b/editors/poke/pkg-descr
new file mode 100644
index 000000000000..f0300956faf3
--- /dev/null
+++ b/editors/poke/pkg-descr
@@ -0,0 +1,6 @@
+GNU poke is an interactive, extensible editor for binary data. Not
+limited to editing basic entities such as bits and bytes, it provides
+a full-fledged procedural, interactive programming language designed
+to describe data structures and to operate on them.
+
+WWW: http://www.jemarch.net/poke
diff --git a/editors/poke/pkg-plist b/editors/poke/pkg-plist
new file mode 100644
index 000000000000..e5b409c4625e
--- /dev/null
+++ b/editors/poke/pkg-plist
@@ -0,0 +1,44 @@
+%%EXAMPLES%%bin/pk-elfextractor
+bin/poke
+include/libpoke.h
+lib/libpoke.a
+lib/libpoke.so
+lib/libpoke.so.0
+lib/libpoke.so.0.0.0
+man/man1/poke.1.gz
+%%DATADIR%%/maps/dwarf.map
+%%DATADIR%%/maps/elf.map
+%%DATADIR%%/maps/mp3.map
+%%DATADIR%%/nodelist
+%%DATADIR%%/pickles/argp.pk
+%%DATADIR%%/pickles/bmp.pk
+%%DATADIR%%/pickles/bpf.pk
+%%DATADIR%%/pickles/btf-dump.pk
+%%DATADIR%%/pickles/btf.pk
+%%DATADIR%%/pickles/color.pk
+%%DATADIR%%/pickles/ctf.pk
+%%DATADIR%%/pickles/dwarf-common.pk
+%%DATADIR%%/pickles/dwarf-frame.pk
+%%DATADIR%%/pickles/dwarf-pubnames.pk
+%%DATADIR%%/pickles/dwarf-types.pk
+%%DATADIR%%/pickles/dwarf.pk
+%%DATADIR%%/pickles/elf.pk
+%%DATADIR%%/pickles/id3v1.pk
+%%DATADIR%%/pickles/leb128.pk
+%%DATADIR%%/pickles/mbr.pk
+%%DATADIR%%/pickles/pktest.pk
+%%DATADIR%%/pickles/rgb24.pk
+%%DATADIR%%/pickles/time.pk
+%%DATADIR%%/pickles/ustar.pk
+%%DATADIR%%/pk-cmd.pk
+%%DATADIR%%/pk-copy.pk
+%%DATADIR%%/pk-dump.pk
+%%DATADIR%%/pk-extract.pk
+%%DATADIR%%/pk-hserver.pk
+%%DATADIR%%/pk-save.pk
+%%DATADIR%%/pk-scrabble.pk
+%%DATADIR%%/pkl-rt.pk
+%%DATADIR%%/poke-default.css
+%%DATADIR%%/poke.pk
+%%DATADIR%%/poke.text
+%%DATADIR%%/std.pk