aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2021-12-02 16:41:57 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2021-12-02 16:41:57 +0000
commita2f29f52f70007ef491672e59a2d110ae2fc5218 (patch)
treefac343385d100d076a615919e72508467b9b62af /editors
parent19348aec64790eb19ff26d56b1d2aceb4098874d (diff)
downloadports-a2f29f52f70007ef491672e59a2d110ae2fc5218.tar.gz
ports-a2f29f52f70007ef491672e59a2d110ae2fc5218.zip
editors/neovim: Partially revert 9b869a4c17db42729cdfaca02c5c9c5ab2d22976
luajit-openresty causes lua errors with many nvim plugins. I don't know why, and until I have time to diagnose it, revert the switch to hardcoded luajit-openresty. In the short term I'll likely switch to hardcoding luajit and removing the PUC Lua option.
Diffstat (limited to 'editors')
-rw-r--r--editors/neovim/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index ab04cd1b5627..1888e9cfa09f 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -3,6 +3,7 @@
PORTNAME= neovim
DISTVERSIONPREFIX= v
DISTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES= editors
MAINTAINER= adamw@FreeBSD.org
@@ -13,8 +14,7 @@ LICENSE= APACHE20
BUILD_DEPENDS= gperf:devel/gperf \
${LUA_MODLIBDIR}/bit.so:devel/lua-bitop@${LUA_FLAVOR} \
${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg@${LUA_FLAVOR}
-LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty \
- libluv.so:devel/luv \
+LIB_DEPENDS= libluv.so:devel/luv \
libmsgpackc.so:devel/msgpack \
libtermkey.so:devel/libtermkey \
libtree-sitter.so:devel/tree-sitter \
@@ -26,7 +26,7 @@ TEST_DEPENDS= autoconf>=0:devel/autoconf \
gmake:devel/gmake \
libtool:devel/libtool
-USES= cmake cpe iconv lua:build pathfix pkgconfig
+USES= cmake cpe iconv pathfix pkgconfig
USE_GITHUB= yes
GH_TUPLE= libmpack:libmpack:1.0.5:libmpack \
libmpack:libmpack-lua:1.0.7:libmpack_lua
@@ -39,11 +39,21 @@ CMAKE_ARGS= -DLUA_PRG:FILEPATH="${LUA_CMD}" \
DATADIR= ${PREFIX}/share/nvim
PORTDATA= runtime
-OPTIONS_DEFINE= NLS PYNVIM
+OPTIONS_DEFINE= LUAJIT NLS PYNVIM
+OPTIONS_DEFAULT=LUAJIT
+OPTIONS_EXCLUDE_aarch64= LUAJIT
+OPTIONS_EXCLUDE_mips64= LUAJIT
+OPTIONS_EXCLUDE_riscv64= LUAJIT
+OPTIONS_EXCLUDE_sparc64= LUAJIT
OPTIONS_SUB= yes
+LUAJIT_DESC= Use LuaJIT for faster Lua code (recommended)
PYNVIM_DESC= Enable support for plugins written in python
+LUAJIT_CMAKE_OFF= -DPREFER_LUA:BOOL="ON"
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
+LUAJIT_USES= lua:build
+LUAJIT_USES_OFF= lua:52
NLS_CMAKE_BOOL= ENABLE_LIBINTL
NLS_USES= gettext
PYNVIM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pynvim>=0.3.0:editors/py-pynvim@${PY_FLAVOR}
@@ -52,6 +62,7 @@ PYNVIM_USES= python:run
.include <bsd.port.options.mk>
.if ${ARCH:Mpowerpc64*}
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
USES+= compiler:gcc-c++11-lib
.endif