aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-28 14:03:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-28 14:03:09 +0000
commiteeb1f47e0fbbed42a9fe4faf6cbef828d8624315 (patch)
tree3e1ee80c5e578740654a8a182e1e02bcae529954 /editors
parent6740408e456e073ecfefbe176004bc2531a805d0 (diff)
downloadports-eeb1f47e0fbbed42a9fe4faf6cbef828d8624315.tar.gz
ports-eeb1f47e0fbbed42a9fe4faf6cbef828d8624315.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/mlview/Makefile4
-rw-r--r--editors/mlview/distinfo4
-rw-r--r--editors/mlview/files/patch-ltmain.sh41
-rw-r--r--editors/mlview/files/patch-src-mlview-tree-view.c15
-rw-r--r--editors/mlview/pkg-plist27
5 files changed, 36 insertions, 55 deletions
diff --git a/editors/mlview/Makefile b/editors/mlview/Makefile
index aad7a9b541cc..3c66843210b9 100644
--- a/editors/mlview/Makefile
+++ b/editors/mlview/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mlview
-PORTVERSION= 0.6.2
+PORTVERSION= 0.6.3
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
@@ -20,7 +20,7 @@ USE_X_PREFIX= yes
USE_AUTOCONF_VER= 253
USE_GNOME= gnomeprefix gnomehack eel2
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
diff --git a/editors/mlview/distinfo b/editors/mlview/distinfo
index ef22282aa279..b4dfb224dc2f 100644
--- a/editors/mlview/distinfo
+++ b/editors/mlview/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/mlview-0.6.2.tar.bz2) = 0cbdd1b55f8ad7aa1769ddac38ffea9d
-SIZE (gnome2/mlview-0.6.2.tar.bz2) = 451900
+MD5 (gnome2/mlview-0.6.3.tar.bz2) = 6975d10f92deddfee4b02153aafc6bcd
+SIZE (gnome2/mlview-0.6.3.tar.bz2) = 483344
diff --git a/editors/mlview/files/patch-ltmain.sh b/editors/mlview/files/patch-ltmain.sh
deleted file mode 100644
index ea534afd592a..000000000000
--- a/editors/mlview/files/patch-ltmain.sh
+++ /dev/null
@@ -1,41 +0,0 @@
---- ltmain.sh.orig Fri Nov 21 21:36:55 2003
-+++ ltmain.sh Sat Dec 6 20:58:32 2003
-@@ -1086,7 +1086,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1096,8 +1096,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -4351,10 +4359,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/editors/mlview/files/patch-src-mlview-tree-view.c b/editors/mlview/files/patch-src-mlview-tree-view.c
new file mode 100644
index 000000000000..814ae7239c4a
--- /dev/null
+++ b/editors/mlview/files/patch-src-mlview-tree-view.c
@@ -0,0 +1,15 @@
+--- src/mlview-tree-view.c.orig Sat May 1 23:36:40 2004
++++ src/mlview-tree-view.c Wed Jul 28 15:25:16 2004
+@@ -746,11 +746,11 @@
+ mlview_tree_view_build_contextual_menu (MlViewTreeView *a_this)
+ {
+ struct TreeEditorContextualMenuHandle *menu_handle = NULL ;
++ GtkWidget *menu = NULL, *menuitem = NULL, *submenu = NULL;
+
+ g_return_val_if_fail (a_this
+ && MLVIEW_IS_TREE_VIEW (a_this),
+ MLVIEW_BAD_PARAM_ERROR) ;
+- GtkWidget *menu = NULL, *menuitem = NULL, *submenu = NULL;
+
+ menu_handle = g_try_malloc
+ (sizeof (struct TreeEditorContextualMenuHandle)) ;
diff --git a/editors/mlview/pkg-plist b/editors/mlview/pkg-plist
index 664e30f146e1..917c796c8dc5 100644
--- a/editors/mlview/pkg-plist
+++ b/editors/mlview/pkg-plist
@@ -4,31 +4,38 @@ etc/gconf/schemas/mlview.schemas
@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/mlview.schemas > /dev/null || /usr/bin/true
lib/libmlview.a
lib/libmlview.so
-lib/libmlview.so.4
+lib/libmlview.so.5
share/gnome/applications/mlview.desktop
+share/gnome/mlview/mlview-css-picker.glade
share/gnome/mlview/mlview-dtd-choice.glade
share/gnome/mlview/mlview-dtd-choice-dtd-not-resolved.glade
+share/gnome/mlview/mlview-main-app-win.glade
share/gnome/mlview/mlview-preferences.glade
share/gnome/mlview/tree-view-find-dialog.glade
-share/gnome/pixmaps/mlview-app-icon.png
-share/gnome/pixmaps/mlview-app-icon.xpm
-share/gnome/pixmaps/xml-comment-node.png
-share/gnome/pixmaps/xml-element-node.png
-share/gnome/pixmaps/xml-element-node-open.png
-share/gnome/pixmaps/xml-pi-node.png
-share/gnome/pixmaps/xml-root.png
-share/gnome/pixmaps/xml-root-open.png
-share/gnome/pixmaps/xml-text-node.png
+share/gnome/mlview/mlview-app-icon.png
+share/gnome/mlview/mlview-app-icon.xpm
+share/gnome/mlview/xml-comment-node.png
+share/gnome/mlview/xml-element-node.png
+share/gnome/mlview/xml-element-node-open.png
+share/gnome/mlview/xml-entity-ref-node.png
+share/gnome/mlview/xml-pi-node.png
+share/gnome/mlview/xml-root.png
+share/gnome/mlview/xml-root-open.png
+share/gnome/mlview/xml-text-node.png
share/locale/az/LC_MESSAGES/mlview.mo
share/locale/ca/LC_MESSAGES/mlview.mo
share/locale/cs/LC_MESSAGES/mlview.mo
share/locale/de/LC_MESSAGES/mlview.mo
+share/locale/en_CA/LC_MESSAGES/mlview.mo
+share/locale/en_GB/LC_MESSAGES/mlview.mo
share/locale/es/LC_MESSAGES/mlview.mo
share/locale/fr/LC_MESSAGES/mlview.mo
+share/locale/hr/LC_MESSAGES/mlview.mo
share/locale/ja/LC_MESSAGES/mlview.mo
share/locale/ml/LC_MESSAGES/mlview.mo
share/locale/ms/LC_MESSAGES/mlview.mo
share/locale/nl/LC_MESSAGES/mlview.mo
+share/locale/no/LC_MESSAGES/mlview.mo
share/locale/pl/LC_MESSAGES/mlview.mo
share/locale/pt/LC_MESSAGES/mlview.mo
share/locale/pt_BR/LC_MESSAGES/mlview.mo