aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-01-16 17:33:20 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-01-16 17:33:20 +0000
commit2b1a883dc4fd248d3b049059b9543dde2ac98ffd (patch)
tree0b080fcd55271333176593e1b9bc0b48aedbe9fa /editors
parent21829056931f158e125c2d89352e36c1c7196a26 (diff)
downloadports-2b1a883dc4fd248d3b049059b9543dde2ac98ffd.tar.gz
ports-2b1a883dc4fd248d3b049059b9543dde2ac98ffd.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/biew/Makefile6
-rw-r--r--editors/cooledit/Makefile10
-rw-r--r--editors/emacs20-dl/Makefile8
-rw-r--r--editors/jed/Makefile14
-rw-r--r--editors/mule/Makefile26
-rw-r--r--editors/ved/Makefile14
6 files changed, 39 insertions, 39 deletions
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index 582fe680f32e..df4da22f8c83 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -26,9 +26,9 @@ HOST_CFLAGS= ${CFLAGS} -DLIBDIR="\'\"${PREFIX}/share\"\'"
MAKEFILE= makefile
.if ${OSVERSION} < 400010
-LIB_DEPENDS= ncurses.5:${PORTSDIR}/devel/ncurses
-HOST_CFLAGS+= -D__FreeBSD_version=${OSVERSION} -I${LOCALBASE}/include
-HOST_LD+= -L${LOCALBASE}/lib
+LIB_DEPENDS= ncurses.5:${PORTSDIR}/devel/ncurses
+HOST_CFLAGS+= -D__FreeBSD_version=${OSVERSION} -I${LOCALBASE}/include
+HOST_LD+= -L${LOCALBASE}/lib
.endif
MAKE_ARGS+= HOST_CFLAGS="${HOST_CFLAGS}" CC="${CC}" LD="${CC}" \
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index c1f82b816d5d..8e6efad5b46a 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -8,7 +8,7 @@
PORTNAME= cooledit
PORTVERSION= 3.17.2
CATEGORIES= editors
-MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://www.netins.net/showcase/Comput-IT/cooledit/src/
MASTER_SITE_SUBDIR= apps/editors/X/cooledit
@@ -18,16 +18,16 @@ LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-USE_XLIB= yes
-USE_XPM= yes
-USE_GMAKE= yes
+USE_XLIB= yes
+USE_XPM= yes
+USE_GMAKE= yes
CONFIGURE_ARGS= --disable-mail-author --with-libs='-lcrypt -lreadline' \
--without-included-gettext
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-MAN1 = cooledit.1 smalledit.1 coolman.1 coolicon.1
+MAN1= cooledit.1 smalledit.1 coolman.1 coolicon.1
pre-install:
@${ECHO_MSG} "Installing in ${PREFIX}/bin"
diff --git a/editors/emacs20-dl/Makefile b/editors/emacs20-dl/Makefile
index 34260000f78e..c1261116d9a1 100644
--- a/editors/emacs20-dl/Makefile
+++ b/editors/emacs20-dl/Makefile
@@ -15,7 +15,7 @@ DISTNAME= emacs-${PORTVERSION}
PATCH_SITES= ftp://ftp.m17n.org/pub/mule/dynamic-loading/ \
http://www.etl.go.jp/~tomo/comp/emacsen/
PATCHFILES= emacs-20.4-dl3.diff.gz
-PATCH_DIST_STRIP= -p1
+PATCH_DIST_STRIP= -p1
MAINTAINER= shige@FreeBSD.org
@@ -29,10 +29,10 @@ MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
EMACS_VER= 20.7
CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
.if !defined(WITHOUT_X11)
-CONFIGURE_ARGS= --with-x-toolkit --with-pop
-USE_XLIB= yes
+CONFIGURE_ARGS= --with-x-toolkit --with-pop
+USE_XLIB= yes
.else
-CONFIGURE_ARGS= --with-x=no --with-pop
+CONFIGURE_ARGS= --with-x=no --with-pop
.endif
DOC_FILE= DOC-DL-${EMACS_VER}.1
diff --git a/editors/jed/Makefile b/editors/jed/Makefile
index 0193b584e9f7..bcda37b815bb 100644
--- a/editors/jed/Makefile
+++ b/editors/jed/Makefile
@@ -11,11 +11,11 @@ CATEGORIES= editors
MASTER_SITES= ftp://space.mit.edu/pub/davis/jed/v0.98/
DISTNAME= ${PORTNAME}0.98-7
-PATCH_SITES= ftp://space.mit.edu/pub/davis/jed/v0.98/
-PATCHFILES= BUGS
+PATCH_SITES= ftp://space.mit.edu/pub/davis/jed/v0.98/
+PATCHFILES= BUGS
PATCH_DIST_STRIP= -p1
-MAINTAINER= eric@cybernut.com
+MAINTAINER= eric@cybernut.com
LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
@@ -26,12 +26,12 @@ XJED= xjed
.endif
DIST_SUBDIR= jed
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
PATCH_DIST_ARGS= -d ${WRKSRC}/src --quiet -E ${PATCH_DIST_STRIP}
CONFIGURE_ENV= JED_ROOT=${PREFIX}/lib/jed
-ALL_TARGET= all getmail ${XJED}
-INSTALL_TARGET= install
-WRKSRC= ${WRKDIR}/jed
+ALL_TARGET= all getmail ${XJED}
+INSTALL_TARGET= install
+WRKSRC= ${WRKDIR}/jed
MAN1= jed.1 rgrep.1
pre-install:
diff --git a/editors/mule/Makefile b/editors/mule/Makefile
index ea19218b00d0..525f9d0d25c4 100644
--- a/editors/mule/Makefile
+++ b/editors/mule/Makefile
@@ -17,7 +17,7 @@ DISTFILES= emacs-${EMACS_VERSION}b${EXTRACT_SUFX} \
PATCH_SITES= ftp://etlport.etl.go.jp/pub/mule/
PATCHFILES= mule-${MULE_VERSION:S/.//}-${EMACS_VERSION:S/.//}-alpha01.diff.gz
-PATCH_DIST_STRIP= -p1
+PATCH_DIST_STRIP= -p1
MAINTAINER?= taoka@FreeBSD.org
@@ -42,7 +42,7 @@ INSTALL_COOKIE= ${WRKDIR}/.install_done-${PKGNAME}
PACKAGE_COOKIE= ${WRKDIR}/.package_done-${PKGNAME}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-MAKE_ENV= LIBDIR="${LIBDIR}"
+MAKE_ENV= LIBDIR="${LIBDIR}"
# /usr/bin/sed should be used because configure script includes 'Ctrl-L'
CONFIGURE_ENV= PATH=/usr/bin:$$PATH
EMACS_PREFIX= mule
@@ -59,28 +59,28 @@ INSTALL_TARGET= install-arch-dep
.if defined(CANNA)
LIB_INPUT_METHOD+= canna.1:${PORTSDIR}/japanese/Canna
WITH_INPUT_METHOD+= --with-canna --with-canna-libraries=${PREFIX}/lib \
- --with-canna-includes=${PREFIX}/include
+ --with-canna-includes=${PREFIX}/include
.endif
.if defined(SJ3)
-BUILD_INPUT_METHOD+=sj3serv:${PORTSDIR}/japanese/sj3
-WITH_INPUT_METHOD+= --with-sj3
+BUILD_INPUT_METHOD+= sj3serv:${PORTSDIR}/japanese/sj3
+WITH_INPUT_METHOD+= --with-sj3
.endif
.if defined(FREEWNN)
-LIB_INPUT_METHOD+=wnn.0:${PORTSDIR}/japanese/FreeWnn-lib
+LIB_INPUT_METHOD+= wnn.0:${PORTSDIR}/japanese/FreeWnn-lib
WITH_INPUT_METHOD+= --with-wnn4 --with-wnn-libraries=${LOCALBASE}/lib \
- --with-wnn-includes=${LOCALBASE}/include/wnn
+ --with-wnn-includes=${LOCALBASE}/include/wnn
.elif defined(CFREEWNN)
-LIB_INPUT_METHOD+=cwnn.0:${PORTSDIR}/chinese/FreeWnn-lib
+LIB_INPUT_METHOD+= cwnn.0:${PORTSDIR}/chinese/FreeWnn-lib
WITH_INPUT_METHOD+= --with-wnn4 --with-cwnn4 --with-wnn-libraries=${LOCALBASE}/lib \
- --with-wnn-includes=${LOCALBASE}/include/cwnn
+ --with-wnn-includes=${LOCALBASE}/include/cwnn
.elif defined(KFREEWNN)
-LIB_INPUT_METHOD+=kwnn.0:${PORTSDIR}/korean/FreeWnn-lib
+LIB_INPUT_METHOD+= kwnn.0:${PORTSDIR}/korean/FreeWnn-lib
WITH_INPUT_METHOD+= --with-wnn4 --with-kwnn4 --with-wnn-libraries=${LOCALBASE}/lib \
- --with-wnn-includes=${LOCALBASE}/include/kwnn
+ --with-wnn-includes=${LOCALBASE}/include/kwnn
.elif defined(WNN6)
-LIB_INPUT_METHOD+=wnn6.1:${PORTSDIR}/japanese/Wnn6-lib
+LIB_INPUT_METHOD+= wnn6.1:${PORTSDIR}/japanese/Wnn6-lib
WITH_INPUT_METHOD+= --with-wnn6 --with-wnn-libraries=${LOCALBASE}/lib \
- --with-wnn-includes=${LOCALBASE}/include/wnn6/wnn
+ --with-wnn-includes=${LOCALBASE}/include/wnn6/wnn
.endif
COMP_ELC= egg.elc wnn-egg.elc sj3-client.elc sj3-egg.elc canna.elc
ELC_DIR= ../lisp
diff --git a/editors/ved/Makefile b/editors/ved/Makefile
index 4cbb07768d9a..886c97505c3f 100644
--- a/editors/ved/Makefile
+++ b/editors/ved/Makefile
@@ -5,16 +5,16 @@
# $FreeBSD$
#
-PORTNAME= ved
-PORTVERSION= 1.5
-CATEGORIES= editors
-MASTER_SITES= ftp://ftp.fokus.gmd.de/pub/unix/ved/
+PORTNAME= ved
+PORTVERSION= 1.5
+CATEGORIES= editors
+MASTER_SITES= ftp://ftp.fokus.gmd.de/pub/unix/ved/
-MAINTAINER= greid@ukug.uk.freebsd.org
+MAINTAINER= greid@ukug.uk.freebsd.org
-USE_GMAKE= yes
+USE_GMAKE= yes
-MAN1= ved.1
+MAN1= ved.1
post-patch:
.for F in ved.h ved.1