aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2006-09-26 00:00:11 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2006-09-26 00:00:11 +0000
commit2ed8a83a43ecdc36e2aa249921174881949e02d5 (patch)
treea904956fb58975a0bfdb2977131de3c2ff18b6a4 /editors
parentc909d27db25635f05e077c86413f41aa2281241f (diff)
downloadports-2ed8a83a43ecdc36e2aa249921174881949e02d5.tar.gz
ports-2ed8a83a43ecdc36e2aa249921174881949e02d5.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/kile-kde4/Makefile12
-rw-r--r--editors/kile/Makefile12
2 files changed, 20 insertions, 4 deletions
diff --git a/editors/kile-kde4/Makefile b/editors/kile-kde4/Makefile
index 0327b843bc3b..b6c145bdfe3d 100644
--- a/editors/kile-kde4/Makefile
+++ b/editors/kile-kde4/Makefile
@@ -17,15 +17,23 @@ COMMENT= A LaTeX source editor for KDE
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
identify:${PORTSDIR}/graphics/ImageMagick
-CONFLICTS= kile-i18n-*
+CONFLICTS= kile-i18n-[0-9]*
USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
+OPTIONS= KPDF "Use KPDF and KDVI for viewing" on
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's| syntax||g' ${WRKSRC}/src/kile/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_KPDF)
+RUN_DEPENDS+= kpdf:${PORTSDIR}/graphics/kdegraphics3
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/editors/kile/Makefile b/editors/kile/Makefile
index 0327b843bc3b..b6c145bdfe3d 100644
--- a/editors/kile/Makefile
+++ b/editors/kile/Makefile
@@ -17,15 +17,23 @@ COMMENT= A LaTeX source editor for KDE
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
identify:${PORTSDIR}/graphics/ImageMagick
-CONFLICTS= kile-i18n-*
+CONFLICTS= kile-i18n-[0-9]*
USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
+OPTIONS= KPDF "Use KPDF and KDVI for viewing" on
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's| syntax||g' ${WRKSRC}/src/kile/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_KPDF)
+RUN_DEPENDS+= kpdf:${PORTSDIR}/graphics/kdegraphics3
+.endif
+
+.include <bsd.port.post.mk>