aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-09-22 10:48:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-09-22 10:48:28 +0000
commit3fcd0e41ded1b4e3f014c63e00cf2ee71fa39ad5 (patch)
tree5ec4d6c8c02d380cf421717b2ce88beceb851e79 /editors
parent320538c6d599e65e80ad91bd683504f5d7c338f1 (diff)
downloadports-3fcd0e41ded1b4e3f014c63e00cf2ee71fa39ad5.tar.gz
ports-3fcd0e41ded1b4e3f014c63e00cf2ee71fa39ad5.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/codelite/Makefile5
-rw-r--r--editors/texstudio/Makefile2
-rw-r--r--editors/vanubi/Makefile2
3 files changed, 3 insertions, 6 deletions
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
index b7605c8d113e..52219faf64fb 100644
--- a/editors/codelite/Makefile
+++ b/editors/codelite/Makefile
@@ -19,7 +19,7 @@ BROKEN_armv6= fails to configure: has leading or trailing whitespace. This is
USE_GITHUB= yes
GH_ACCOUNT= eranif
-USES= cmake:outsource,noninja compiler:c++11-lib dos2unix execinfo gettext \
+USES= cmake:outsource,noninja compiler:c++11-lib dos2unix gettext \
pathfix shebangfix sqlite
USE_GNOME+= cairo gtk20
DOS2UNIX_GLOB= *.cpp *.txt
@@ -32,9 +32,6 @@ CMAKE_ARGS= -DPREFIX:STRING="${PREFIX}" \
USE_LDCONFIG= ${PREFIX}/lib/codelite
INSTALLS_ICONS= yes
-CXXFLAGS+= ${EXECINFO_CPPFLAGS}
-LDFLAGS+= ${EXECINFO_LDFLAGS}
-
OPTIONS_DEFINE= CSCOPE SFTP
OPTIONS_RADIO= CLANG
OPTIONS_SUB= yes
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index ca30545e2f42..c019911ec9d9 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell \
BROKEN_aarch64= fails to compile: error: no member named mc_eip in __mcontext
BROKEN_armv6= fails to compile: error: no member named mc_eip in __mcontext
-USES= desktop-file-utils dos2unix execinfo ghostscript:run \
+USES= desktop-file-utils dos2unix ghostscript:run \
pkgconfig qmake
DOS2UNIX_FILES= ${PORTNAME}.pro
diff --git a/editors/vanubi/Makefile b/editors/vanubi/Makefile
index f0f9f73488d2..028f0b636f9e 100644
--- a/editors/vanubi/Makefile
+++ b/editors/vanubi/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= valac:lang/vala
GH_TAGNAME= eedac1d
USE_GITHUB= yes
-USES= autoreconf desktop-file-utils execinfo gmake libtool pkgconfig
+USES= autoreconf desktop-file-utils gmake libtool pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk30 gtksourceview3 libwnck3 vte3
USE_LDCONFIG= yes