aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-31 17:31:12 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-31 17:31:12 +0000
commit42cb5546b65f8e9d54394e08557f85167f8912be (patch)
tree0287bcf4b97e74d8c0789baffc7af681daa8ac40 /editors
parent92e970493a5abc27b4bc6f4410c3fdff05b11c74 (diff)
downloadports-42cb5546b65f8e9d54394e08557f85167f8912be.tar.gz
ports-42cb5546b65f8e9d54394e08557f85167f8912be.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/libreoffice/Makefile84
1 files changed, 41 insertions, 43 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index ff0a9eb5f524..317377eacf74 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -8,7 +8,6 @@
PORTNAME= libreoffice
PORTVERSION= 3.4.3
PORTREVISION= 2
-LOVERSION= ${PORTVERSION}.2
CATEGORIES= editors
MASTER_SITES= http://ftp.osuosl.org/pub/tdf/libreoffice/src/${PORTVERSION}/ \
http://ftp.rediris.es/mirror/TDF/libreoffice/src/${PORTVERSION}/ \
@@ -37,8 +36,44 @@ MASTER_SITES= http://ftp.osuosl.org/pub/tdf/libreoffice/src/${PORTVERSION}/ \
MAINTAINER= office@FreeBSD.org
COMMENT= Full integrated office productivity suite
+LICENSE= LGPL3 MPL
+LICENSE_COMB= dual
+
+# dmake can't be used from ports
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ gpatch:${PORTSDIR}/devel/patch \
+ unzip:${PORTSDIR}/archivers/unzip \
+ bash:${PORTSDIR}/shells/bash \
+ oo2po:${PORTSDIR}/textproc/translate-toolkit \
+ dmake:${PORTSDIR}/devel/dmake \
+ ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
+ ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
+ ${LOCALBASE}/lib/libcppunit.so:${PORTSDIR}/devel/cppunit \
+ ${LOCALBASE}/lib/libboost_regex.a:${PORTSDIR}/devel/boost-libs \
+ vigra-config:${PORTSDIR}/graphics/vigra
+# rely on bsdtar ability to extract .gz and .bz2 archives
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xslt.2:${PORTSDIR}/textproc/libxslt \
+ expat.6:${PORTSDIR}/textproc/expat2 \
+ icutu.48:${PORTSDIR}/devel/icu \
+ jpeg.11:${PORTSDIR}/graphics/jpeg \
+ curl.6:${PORTSDIR}/ftp/curl \
+ hunspell-1.3.0:${PORTSDIR}/textproc/hunspell \
+ mythes-1.2.0:${PORTSDIR}/textproc/mythes \
+ hyphen.2:${PORTSDIR}/textproc/hyphen \
+ poppler-glib.8:${PORTSDIR}/graphics/poppler-glib \
+ wpd-0.9.9:${PORTSDIR}/textproc/libwpd \
+ wpg-0.2.2:${PORTSDIR}/graphics/libwpg \
+ wps-0.2.2:${PORTSDIR}/textproc/libwps \
+ rdf.0:${PORTSDIR}/textproc/redland \
+ textcat.0:${PORTSDIR}/textproc/libtextcat \
+ lpsolve55:${PORTSDIR}/math/lp_solve \
+ cups.2:${PORTSDIR}/print/cups-client
+
CONFLICTS_INSTALL= libreoffice-legacy-[0-9]*
+LOVERSION= ${PORTVERSION}.2
LO_COMPONENTS= artwork base calc components extensions \
extras filters help impress libs-core libs-extern \
libs-extern-sys libs-gui postprocess sdk testing \
@@ -46,7 +81,7 @@ LO_COMPONENTS= artwork base calc components extensions \
USE_BZIP2= yes
#l10n
-INSTALL_TARGET= distro-pack-install
+INSTALL_TARGET= distro-pack-install
DIST_SUBDIR= libreoffice
DISTFILES+= ${PORTNAME}-bootstrap-${LOVERSION}${EXTRACT_SUFX}
@@ -58,9 +93,6 @@ LODESTDIR= ${WRKDIR}/loinstall
DISTFILES+= ${PORTNAME}-${components}-${LOVERSION}${EXTRACT_SUFX}
.endfor
-LICENSE= LGPL3 MPL
-LICENSE_COMB= dual
-
# for dynamic plist generation
PLISTD?= ${WRKDIR}/plist_dirs
PLISTF?= ${WRKDIR}/plist_files
@@ -80,41 +112,6 @@ DISTFILES+= fdb27bfe2dbe2e7b57ae194d9bf36bab-SampleICC-1.3.2.tar.gz:GoOOSrc \
35efabc239af896dfb79be7ebdd6e6b9-gentiumbasic-fonts-1.10.zip:GoOOSrc \
881af2b7dca9b8259abbca00bbbc004d-LinLibertineG-20110101.zip:OOoDTP
-# rely on bsdtar ability to extract .gz and .bz2 archives
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
- xml2.5:${PORTSDIR}/textproc/libxml2 \
- xslt.2:${PORTSDIR}/textproc/libxslt \
- expat.6:${PORTSDIR}/textproc/expat2 \
- icutu.48:${PORTSDIR}/devel/icu \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- curl.6:${PORTSDIR}/ftp/curl \
- hunspell-1.3.0:${PORTSDIR}/textproc/hunspell \
- mythes-1.2.0:${PORTSDIR}/textproc/mythes \
- hyphen.2:${PORTSDIR}/textproc/hyphen \
- poppler-glib.8:${PORTSDIR}/graphics/poppler-glib \
- wpd-0.9.9:${PORTSDIR}/textproc/libwpd \
- wpg-0.2.2:${PORTSDIR}/graphics/libwpg \
- wps-0.2.2:${PORTSDIR}/textproc/libwps \
- rdf.0:${PORTSDIR}/textproc/redland \
- textcat.0:${PORTSDIR}/textproc/libtextcat \
- lpsolve55:${PORTSDIR}/math/lp_solve \
- cups.2:${PORTSDIR}/print/cups-client
-
-
-# dmake can't be used from ports
-
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- gpatch:${PORTSDIR}/devel/patch \
- unzip:${PORTSDIR}/archivers/unzip \
- bash:${PORTSDIR}/shells/bash \
- oo2po:${PORTSDIR}/textproc/translate-toolkit \
- dmake:${PORTSDIR}/devel/dmake \
- ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
- ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
- ${LOCALBASE}/lib/libcppunit.so:${PORTSDIR}/devel/cppunit \
- ${LOCALBASE}/lib/libboost_regex.a:${PORTSDIR}/devel/boost-libs \
- vigra-config:${PORTSDIR}/graphics/vigra
-
USE_BDB= yes
USE_PERL5_BUILD= yes
GNU_CONFIGURE= yes
@@ -240,7 +237,7 @@ CONFIGURE_ARGS+= --disable-gstreamer
USE_PYTHON= yes
CONFIGURE_ARGS+= --with-system-python
.else
-CONFIGURE_ARGS+= --disable-python
+CONFIGURE_ARGS+= --disable-python
.endif
.if defined(WITH_GTK) || defined(WITH_GNOME)
@@ -267,7 +264,7 @@ CONFIGURE_ARGS+= --disable-kde4
.endif
.if defined(WITH_GNOME)
-USE_GNOME+= gconf2 gnomevfs2
+USE_GNOME+= gconf2 gnomevfs2
CONFIGURE_ARGS+= --enable-gconf --enable-gnome-vfs
.else
CONFIGURE_ARGS+= --disable-gconf --disable-gnome-vfs
@@ -297,6 +294,7 @@ DISTFILES+= 798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip:GoOOSrc \
# LibreOffice works only with Java 6 -- which may not be the default
# if you specify the JAVA_VENDOR variable
+CATEGORIES+= java
USE_JAVA= yes
JAVA_VERSION= 1.6
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant \
@@ -390,7 +388,7 @@ post-configure:
post-install:
@${RM} -f ${PLISTF} ${PLISTD}
# It seems that the empty directories are necessary for libreoffice keep them for now
- @find ${LODESTDIR}/${PREFIX}/lib -type d -empty -exec ${TOUCH} {}/.keep \;
+ @${FIND} ${LODESTDIR}/${PREFIX}/lib -type d -empty -exec ${TOUCH} {}/.keep \;
@cd ${LODESTDIR}/${PREFIX} && ${FIND} -H -s lib \( -type f -o -type l \) -print >> ${PLISTF}
@cd ${LODESTDIR}/${PREFIX} && ${FIND} -d lib/libreoffice -type d -exec ${ECHO_CMD} "@dirrm {}" \; >> ${PLISTD}