aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-05-08 10:56:17 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-05-08 10:56:17 +0000
commit7a0fcad7f79e5cb4e819fd87eb3540d1a4313111 (patch)
tree79235225becc19d4d73ef4d7ca10ec15bb968f82 /editors
parent2771911b516683bae0c9ae2e7e220ce80c0ffff9 (diff)
downloadports-7a0fcad7f79e5cb4e819fd87eb3540d1a4313111.tar.gz
ports-7a0fcad7f79e5cb4e819fd87eb3540d1a4313111.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/thoteditor/Makefile45
-rw-r--r--editors/thoteditor/pkg-plist2
2 files changed, 26 insertions, 21 deletions
diff --git a/editors/thoteditor/Makefile b/editors/thoteditor/Makefile
index 328c648283e2..23a3acacf658 100644
--- a/editors/thoteditor/Makefile
+++ b/editors/thoteditor/Makefile
@@ -17,32 +17,35 @@ THOT_SUBDIR= Target
USES= gmake motif
WRKSRC= $(WRKDIR)/Thot/$(THOT_SUBDIR)
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-thot --enable-plugin --without-insure --without-amaya --disable-java --disable-intr --disable-jit --disable-math --disable-ilu
+CONFIGURE_ARGS= --with-thot --enable-plugin --without-insure --without-amaya \
+ --disable-java --disable-intr --disable-jit --disable-math \
+ --disable-ilu
ALL_TARGET= all schemas
+SUB_FILES= thoteditor
MAKE_JOBS_UNSAFE= yes
-MAN1= cextract.1
-MAN5= cextrc.5
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+post-extract:
+ @${MKDIR} ${WRKSRC}
+
+post-patch:
+ @${REINPLACE_CMD} 's|-g -O|${CFLAGS}|' \
+ ${WRKDIR}/Thot/configure
+ @${REINPLACE_CMD} 's|%%MOTIFLIB%%|${MOTIFLIB}|' \
+ ${WRKDIR}/Thot/thot/Makefile.in
+ @${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|' \
+ ${WRKDIR}/Thot/thotlib/base/registry.c
+ @${REINPLACE_CMD} 's|/usr/wsrc/|/usr/tmp/|' \
+ ${WRKDIR}/Thot/thotlib/include/sysdep.h
do-configure:
- $(CP) $(WRKSRC)/../thot/Makefile.in $(WRKSRC)/../thot/Makefile.in.patched
- $(SED) -e "s&%%MOTIFLIB%%&$(MOTIFLIB)&" <$(WRKSRC)/../thot/Makefile.in.patched >$(WRKSRC)/../thot/Makefile.in
(cd $(WRKSRC);../configure $(CONFIGURE_ARGS))
-post-configure:
- $(CP) $(WRKSRC)/../thotlib/base/registry.c $(WRKSRC)/../thotlib/base/registry.c.orig
- $(SED) -e "s&%%PREFIX%%&$(PREFIX)&" <$(WRKSRC)/../thotlib/base/registry.c.orig >$(WRKSRC)/../thotlib/base/registry.c
-
-post-extract:
- (cd $(WRKDIR)/Thot;$(MKDIR) $(THOT_SUBDIR))
-
post-install:
- ${MKDIR} ${PREFIX}/share/thot/doc
- $(SED) -e "s&%%PREFIX%%&$(PREFIX)&" < $(FILESDIR)/thoteditor > $(WRKDIR)/thoteditor
- $(INSTALL_SCRIPT) $(WRKDIR)/thoteditor $(PREFIX)/bin
- $(INSTALL_MAN) $(WRKSRC)/../tools/cextract-1.7/cextrc.5 $(PREFIX)/man/man5
- $(INSTALL_MAN) $(WRKSRC)/../tools/cextract-1.7/cextract.man $(PREFIX)/man/man1/cextract.1
-
-.include <bsd.port.post.mk>
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/thot/doc
+ ${INSTALL_SCRIPT} ${WRKDIR}/thoteditor ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKDIR}/Thot/tools/cextract-1.7/cextract.man \
+ ${STAGEDIR}${PREFIX}/man/man1/cextract.1
+ ${INSTALL_MAN} ${WRKDIR}/Thot/tools/cextract-1.7/cextrc.5 \
+ ${STAGEDIR}${PREFIX}/man/man5
+
+.include <bsd.port.mk>
diff --git a/editors/thoteditor/pkg-plist b/editors/thoteditor/pkg-plist
index ada9cbee1fe2..c6a3594ca613 100644
--- a/editors/thoteditor/pkg-plist
+++ b/editors/thoteditor/pkg-plist
@@ -8,6 +8,8 @@ bin/print
bin/prs
bin/thot
bin/thoteditor
+man/man1/cextract.1.gz
+man/man5/cextrc.5.gz
share/thot/batch/APP.GRM
share/thot/batch/PRESEN.GRM
share/thot/batch/STRUCT.GRM