aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-05 15:48:40 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-05 15:48:40 +0000
commitd52303ea80aa622b55c12627a49f1f1e99799338 (patch)
treed034fed1dcf7a30f93cc657393a36b54fdca2c7b /editors
parent5af1c513f7d709dc7d19fad1794bceca52ca780c (diff)
downloadports-d52303ea80aa622b55c12627a49f1f1e99799338.tar.gz
ports-d52303ea80aa622b55c12627a49f1f1e99799338.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile3
-rw-r--r--editors/calligraplan/Makefile2
-rw-r--r--editors/cooledit/Makefile2
-rw-r--r--editors/cudatext/Makefile2
-rw-r--r--editors/featherpad/Makefile2
-rw-r--r--editors/fte/Makefile2
-rw-r--r--editors/gedit/Makefile2
-rw-r--r--editors/jedit/Makefile2
-rw-r--r--editors/lazarus/Makefile2
-rw-r--r--editors/madedit/Makefile2
-rw-r--r--editors/picpas/Makefile2
-rw-r--r--editors/pluma/Makefile4
-rw-r--r--editors/ted/Makefile3
-rw-r--r--editors/texmacs/Makefile2
-rw-r--r--editors/texstudio/Makefile2
-rw-r--r--editors/vigor/Makefile2
-rw-r--r--editors/xcoral/Makefile2
-rw-r--r--editors/xvile/Makefile2
-rw-r--r--editors/yudit/Makefile2
19 files changed, 22 insertions, 20 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 102b3b16cdfe..d2d4105c09c2 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -37,7 +37,8 @@ BUILD_DEPENDS= pstoedit:graphics/pstoedit
RUN_DEPENDS= pstoedit:graphics/pstoedit
USES= cmake cpe compiler:c++11-lib desktop-file-utils eigen:3 \
- gettext iconv:translit jpeg kde:5 localbase:ldflags perl5 pkgconfig \
+ gettext iconv:translit jpeg kde:5 localbase:ldflags perl5 \
+ pkgconfig xorg
qt:5 shared-mime-info sqlite tar:xz
USE_KDE= akonadicontacts activities archive auth bookmarks codecs completion \
config configwidgets contacts coreaddons crash dbusaddons doctools ecm \
diff --git a/editors/calligraplan/Makefile b/editors/calligraplan/Makefile
index 97d5ce71db13..48d55ac0ffc1 100644
--- a/editors/calligraplan/Makefile
+++ b/editors/calligraplan/Makefile
@@ -13,7 +13,7 @@ COMMENT= KDE Calligra project management application
LIB_DEPENDS= libKChart.so:graphics/kdiagram
USES= cmake cpe compiler:c++11-lib desktop-file-utils kde:5 \
- qt:5 tar:xz
+ qt:5 tar:xz xorg
USE_KDE= activities akonadi archive auth bookmarks codecs completion config \
configwidgets coreaddons dbusaddons ecm guiaddons holidays i18n \
iconthemes itemmodels itemviews jobwidgets js khtml kio \
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index 72eaf4f3455f..a9dd6688256f 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -13,7 +13,7 @@ COMMENT= Suite of utilities, including a GUI editor
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gettext gmake libtool python # gettext is linked to despite .mo files having been deleted
+USES= gettext gmake libtool python xorg # gettext is linked to despite .mo files having been deleted
GNU_CONFIGURE= yes
USE_XORG= x11 xt
USE_LDCONFIG= yes
diff --git a/editors/cudatext/Makefile b/editors/cudatext/Makefile
index bfa27868b284..90c68d937394 100644
--- a/editors/cudatext/Makefile
+++ b/editors/cudatext/Makefile
@@ -11,7 +11,7 @@ COMMENT= Cross-platform text editor, written in Lazarus
LICENSE= MPL20
-USES= desktop-file-utils dos2unix fpc lazarus:flavors
+USES= desktop-file-utils dos2unix fpc lazarus:flavors xorg
USE_FPC= chm fcl-base fcl-image fcl-json fcl-stl fcl-xml pasjpeg rtl-objpas x11
USE_XORG= x11
USE_GITHUB= yes
diff --git a/editors/featherpad/Makefile b/editors/featherpad/Makefile
index 7b7162515964..df1f0c01fb45 100644
--- a/editors/featherpad/Makefile
+++ b/editors/featherpad/Makefile
@@ -12,7 +12,7 @@ COMMENT= Lightweight Qt5 plain-text editor
LICENSE= GPLv3
-USES= compiler:c++11-lang desktop-file-utils pkgconfig qmake:outsource qt:5 gl
+USES= compiler:c++11-lang desktop-file-utils pkgconfig qmake:outsource qt:5 gl xorg
USE_GITHUB= yes
GH_ACCOUNT= tsujan
diff --git a/editors/fte/Makefile b/editors/fte/Makefile
index 62082950ebd7..5f12977827d6 100644
--- a/editors/fte/Makefile
+++ b/editors/fte/Makefile
@@ -17,7 +17,7 @@ LICENSE_COMB= dual
WRKSRC= ${WRKDIR}/fte
-USES= perl5 zip
+USES= perl5 zip xorg
USE_PERL5= build
USE_XORG= x11 xpm
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 51f149fef8bf..6e45ff6aa347 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -29,7 +29,7 @@ RUN_DEPENDS= iso-codes>=0:misc/iso-codes \
PORTSCOUT= limitw:1,even
USES= compiler:c11 desktop-file-utils gettext gmake gnome libtool \
- localbase pathfix pkgconfig python:3.4+ shebangfix tar:xz
+ localbase pathfix pkgconfig python:3.4+ shebangfix tar:xz xorg
USE_CSTD= c11
USE_GNOME= cairo gdkpixbuf2 gtksourceview3 intlhack introspection \
libxml2 pygobject3
diff --git a/editors/jedit/Makefile b/editors/jedit/Makefile
index 2ac83b55e48e..f833cb3baffd 100644
--- a/editors/jedit/Makefile
+++ b/editors/jedit/Makefile
@@ -20,7 +20,7 @@ MACROS_DESC= Install default set of macros (highly recommended)
OPTIONS_DEFAULT= MACROS
OPTIONS_SUB= yes
-USES= cpe
+USES= cpe xorg
USE_JAVA= yes
JAVA_VERSION= 1.6+
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 7bf337ed0c26..9548f818663d 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS?= ${LOCALBASE}/bin/as:devel/binutils \
ONLY_FOR_ARCHS= i386 amd64
-USES= desktop-file-utils fpc gettext gmake iconv shared-mime-info
+USES= desktop-file-utils fpc gettext gmake iconv shared-mime-info xorg
USE_FPC?= chm cairo dblib fcl-base fcl-db fcl-fpcunit fcl-image fcl-json fcl-net \
fcl-registry fcl-res fcl-web fcl-xml fppkg gtk2 ibase iconvenc mysql \
numlib odbc opengl openssl oracle pasjpeg postgres regexpr rtl-extra \
diff --git a/editors/madedit/Makefile b/editors/madedit/Makefile
index ca25d7180cbd..a4f16c3ca900 100644
--- a/editors/madedit/Makefile
+++ b/editors/madedit/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
-USES= gettext pkgconfig dos2unix desktop-file-utils
+USES= gettext pkgconfig dos2unix desktop-file-utils xorg
USE_WX= 2.8
USE_XORG= x11
diff --git a/editors/picpas/Makefile b/editors/picpas/Makefile
index 636fc5604b50..e2835ed1ee35 100644
--- a/editors/picpas/Makefile
+++ b/editors/picpas/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
gtk2_CONFLICTS_INSTALL= ${PORTNAME}-qt5
qt5_CONFLICTS_INSTALL= ${PORTNAME}-gtk2
-USES= dos2unix fpc lazarus:flavors
+USES= dos2unix fpc lazarus:flavors xorg
USE_FPC= chm fcl-base fcl-image fcl-json fcl-registry fcl-xml pasjpeg regexpr \
rtl-objpas x11
USE_XORG= x11
diff --git a/editors/pluma/Makefile b/editors/pluma/Makefile
index 969120f524de..5260a43ecfcc 100644
--- a/editors/pluma/Makefile
+++ b/editors/pluma/Makefile
@@ -22,8 +22,8 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes
PORTSCOUT= limitw:1,even
-USES= compiler:c11 desktop-file-utils gmake libtool localbase \
- pathfix pkgconfig python:3.3+ shebangfix tar:xz
+USES= compiler:c11 desktop-file-utils gmake gnome libtool localbase \
+ pathfix pkgconfig python:3.3+ shebangfix tar:xz xorg
USE_XORG= ice sm x11
USE_GNOME= cairo gdkpixbuf2 gnomeprefix gtk30 gtksourceview3 \
gvfs intltool introspection libxml2
diff --git a/editors/ted/Makefile b/editors/ted/Makefile
index 8d2a87eda4fc..85cd16df0926 100644
--- a/editors/ted/Makefile
+++ b/editors/ted/Makefile
@@ -23,8 +23,8 @@ RUN_DEPENDS= gsfonts>0:print/gsfonts
WRKSRC= ${WRKDIR}/Ted-${PORTVERSION}
+USES= ghostscript:x11,run iconv pkgconfig xorg
USE_XORG= xext xft
-USES= ghostscript:x11,run iconv pkgconfig
GNU_CONFIGURE= yes
MAKE_ENV= DEF_AFMDIR="-DAFMDIR=\"\\\"${AFMDIR}/\\\"\"" \
DEF_INDDIR="-DINDDIR=\"\\\"${INDDIR}/\\\"\"" \
@@ -42,6 +42,7 @@ INDDIR= ${DATADIR}/dfa
OPTIONS_DEFINE= GTK2 DOCS
GTK2_DESC= Use GTK2 instead of MOTIF
+GTK2_USES= gnome
GTK2_USE= GNOME=gtk20
GTK2_CONFIGURE_ON= --with-GTK
GTK2_CPPFLAGS= `pkg-config --cflags gtk+-2.0 | ${SED} -e 's|-I|-isystem |g'`
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index 95d5dbaf7945..fad2eec7e194 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -23,7 +23,7 @@ BROKEN_armv6= fails to compile: call to min is ambiguous
BROKEN_armv7= fails to compile: call to min is ambiguous
USES= cpe desktop-file-utils gmake iconv localbase pkgconfig python \
- shared-mime-info shebangfix
+ shared-mime-info shebangfix xorg
USE_TEX= tex:run dvipsk:run
USE_XORG= xext
GNU_CONFIGURE= yes
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index e03d9ed4c4f6..73bd29e5c612 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell \
libquazip5.so:archivers/quazip
USES= compiler:c++11-lang desktop-file-utils dos2unix \
- ghostscript:run gl pkgconfig qmake qt:5
+ ghostscript:run gl pkgconfig qmake qt:5 xorg
USE_QT = core gui network script svg widgets xml \
printsupport concurrent uitools buildtools_build
QMAKE_ARGS= QUAZIP_INCLUDE="${LOCALBASE}/include/quazip5" \
diff --git a/editors/vigor/Makefile b/editors/vigor/Makefile
index 4e484f900a9c..94edbe98b372 100644
--- a/editors/vigor/Makefile
+++ b/editors/vigor/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/../LICENSE
WRKSRC= ${WRKDIR}/${DISTNAME}/build
-USES= ncurses tk
+USES= ncurses tk xorg
USE_XORG= x11
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--exec-prefix=${STAGEDIR}${PREFIX}
diff --git a/editors/xcoral/Makefile b/editors/xcoral/Makefile
index db6b6ea996e2..7e57a758c6ed 100644
--- a/editors/xcoral/Makefile
+++ b/editors/xcoral/Makefile
@@ -15,8 +15,8 @@ COMMENT= Multiwindow mouse-based text editor for X
LICENSE= GPLv2
+USES= bison compiler:c11 xorg
USE_XORG= x11
-USES= bison compiler:c11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/share
LIBS+= -lgnuregex
diff --git a/editors/xvile/Makefile b/editors/xvile/Makefile
index cd464faabe17..ecf0fdcfed9c 100644
--- a/editors/xvile/Makefile
+++ b/editors/xvile/Makefile
@@ -19,7 +19,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= reflex:textproc/reflex
-USES= pkgconfig shebangfix tar:tgz
+USES= pkgconfig shebangfix tar:tgz xorg
SHEBANG_FILES= macros/lxvile macros/lxvile-fonts perl/vileget
USE_XORG= x11 xext xpm xt
GNU_CONFIGURE= yes
diff --git a/editors/yudit/Makefile b/editors/yudit/Makefile
index 5b776c139ac4..d362338e2eca 100644
--- a/editors/yudit/Makefile
+++ b/editors/yudit/Makefile
@@ -12,8 +12,8 @@ COMMENT= Multi-lingual Unicode text editor with TTF support
CONFLICTS= netatalk-[0-9]*
+USES= gmake xorg
USE_XORG= x11
-USES= gmake
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes