aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2002-09-08 16:02:39 +0000
committerMartin Blapp <mbr@FreeBSD.org>2002-09-08 16:02:39 +0000
commitf2b32b838cf3c461f50b125e4849b3e0b361ae1b (patch)
tree3988b92882cde0fcb9376697c3597abeaf4c1fe6 /editors
parenta72ffc79f030e034ba6b769ed1fd1594fab252de (diff)
downloadports-f2b32b838cf3c461f50b125e4849b3e0b361ae1b.tar.gz
ports-f2b32b838cf3c461f50b125e4849b3e0b361ae1b.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-1.0/Makefile20
-rw-r--r--editors/openoffice-1.0/pkg-message8
-rw-r--r--editors/openoffice.org-1.0/Makefile20
-rw-r--r--editors/openoffice.org-1.0/pkg-message8
-rw-r--r--editors/openoffice/Makefile20
-rw-r--r--editors/openoffice/pkg-message8
6 files changed, 84 insertions, 0 deletions
diff --git a/editors/openoffice-1.0/Makefile b/editors/openoffice-1.0/Makefile
index d892c463fef7..5a825976955b 100644
--- a/editors/openoffice-1.0/Makefile
+++ b/editors/openoffice-1.0/Makefile
@@ -22,9 +22,13 @@ DISTFILES+= ${L10NHELP:S/$/:help/}
SORT?= /usr/bin/sort
CUT?= /usr/bin/cut
+AWK?= /usr/bin/awk
+GREP?= /usr/bin/grep
+MOUNT?= /sbin/mount
.include <bsd.port.pre.mk>
+PROCFS!= ${MOUNT} | ${GREP} ^procfs | ${AWK} '{print $1}'
INSTALLATION_BASEDIR= OpenOffice.org1.0
DIST_SUBDIR= openoffice
DICT_DIR= ${PREFIX}/${INSTALLATION_BASEDIR}/share/dict/ooo/
@@ -153,6 +157,22 @@ CONFIGURE_ARGS+= --enable-gcc3
.endif
pre-fetch:
+ @${ECHO}
+ @${ECHO} "REQUIREMENTS:"
+.if ${PROCFS}
+ @${ECHO}
+ @${ECHO} Check if procfs is running: YES
+.else
+ @${ECHO} -----------------------------------------------------------
+ @${ECHO}
+ @${ECHO} OpenOffice setup still needs a running procfs, which may
+ @${ECHO} not be activated. Please read the procfs\(5\) manpage and
+ @${ECHO} ensure the the following line is in /etc/fstab:
+ @${ECHO}
+ @${ECHO} proc /proc procfs rw 0 0
+ @${ECHO}
+ @${ECHO} -----------------------------------------------------------
+.endif
.if !defined(USE_GCC) || !defined(WITH_DEBUG)
@${ECHO}
@${ECHO} "OPTIONS:"
diff --git a/editors/openoffice-1.0/pkg-message b/editors/openoffice-1.0/pkg-message
index 6395b787b3e0..4260551a1dcd 100644
--- a/editors/openoffice-1.0/pkg-message
+++ b/editors/openoffice-1.0/pkg-message
@@ -16,6 +16,14 @@ installation.
1.2 OO.org installed as package
+First check if procfs is running. OO.org setup does depend on
+procfs and does crash without it. This dependency will be
+removed in future, but at the moment it is needed.
+Please read the procfs(5) manpage and ensure the the following
+line is in /etc/fstab:
+
+proc /proc procfs rw 0 0
+
If you have just installed OO.org as package, there is no
"make install-user" option available. Instead you'll have
to run as the user you like to use OO.org:
diff --git a/editors/openoffice.org-1.0/Makefile b/editors/openoffice.org-1.0/Makefile
index d892c463fef7..5a825976955b 100644
--- a/editors/openoffice.org-1.0/Makefile
+++ b/editors/openoffice.org-1.0/Makefile
@@ -22,9 +22,13 @@ DISTFILES+= ${L10NHELP:S/$/:help/}
SORT?= /usr/bin/sort
CUT?= /usr/bin/cut
+AWK?= /usr/bin/awk
+GREP?= /usr/bin/grep
+MOUNT?= /sbin/mount
.include <bsd.port.pre.mk>
+PROCFS!= ${MOUNT} | ${GREP} ^procfs | ${AWK} '{print $1}'
INSTALLATION_BASEDIR= OpenOffice.org1.0
DIST_SUBDIR= openoffice
DICT_DIR= ${PREFIX}/${INSTALLATION_BASEDIR}/share/dict/ooo/
@@ -153,6 +157,22 @@ CONFIGURE_ARGS+= --enable-gcc3
.endif
pre-fetch:
+ @${ECHO}
+ @${ECHO} "REQUIREMENTS:"
+.if ${PROCFS}
+ @${ECHO}
+ @${ECHO} Check if procfs is running: YES
+.else
+ @${ECHO} -----------------------------------------------------------
+ @${ECHO}
+ @${ECHO} OpenOffice setup still needs a running procfs, which may
+ @${ECHO} not be activated. Please read the procfs\(5\) manpage and
+ @${ECHO} ensure the the following line is in /etc/fstab:
+ @${ECHO}
+ @${ECHO} proc /proc procfs rw 0 0
+ @${ECHO}
+ @${ECHO} -----------------------------------------------------------
+.endif
.if !defined(USE_GCC) || !defined(WITH_DEBUG)
@${ECHO}
@${ECHO} "OPTIONS:"
diff --git a/editors/openoffice.org-1.0/pkg-message b/editors/openoffice.org-1.0/pkg-message
index 6395b787b3e0..4260551a1dcd 100644
--- a/editors/openoffice.org-1.0/pkg-message
+++ b/editors/openoffice.org-1.0/pkg-message
@@ -16,6 +16,14 @@ installation.
1.2 OO.org installed as package
+First check if procfs is running. OO.org setup does depend on
+procfs and does crash without it. This dependency will be
+removed in future, but at the moment it is needed.
+Please read the procfs(5) manpage and ensure the the following
+line is in /etc/fstab:
+
+proc /proc procfs rw 0 0
+
If you have just installed OO.org as package, there is no
"make install-user" option available. Instead you'll have
to run as the user you like to use OO.org:
diff --git a/editors/openoffice/Makefile b/editors/openoffice/Makefile
index d892c463fef7..5a825976955b 100644
--- a/editors/openoffice/Makefile
+++ b/editors/openoffice/Makefile
@@ -22,9 +22,13 @@ DISTFILES+= ${L10NHELP:S/$/:help/}
SORT?= /usr/bin/sort
CUT?= /usr/bin/cut
+AWK?= /usr/bin/awk
+GREP?= /usr/bin/grep
+MOUNT?= /sbin/mount
.include <bsd.port.pre.mk>
+PROCFS!= ${MOUNT} | ${GREP} ^procfs | ${AWK} '{print $1}'
INSTALLATION_BASEDIR= OpenOffice.org1.0
DIST_SUBDIR= openoffice
DICT_DIR= ${PREFIX}/${INSTALLATION_BASEDIR}/share/dict/ooo/
@@ -153,6 +157,22 @@ CONFIGURE_ARGS+= --enable-gcc3
.endif
pre-fetch:
+ @${ECHO}
+ @${ECHO} "REQUIREMENTS:"
+.if ${PROCFS}
+ @${ECHO}
+ @${ECHO} Check if procfs is running: YES
+.else
+ @${ECHO} -----------------------------------------------------------
+ @${ECHO}
+ @${ECHO} OpenOffice setup still needs a running procfs, which may
+ @${ECHO} not be activated. Please read the procfs\(5\) manpage and
+ @${ECHO} ensure the the following line is in /etc/fstab:
+ @${ECHO}
+ @${ECHO} proc /proc procfs rw 0 0
+ @${ECHO}
+ @${ECHO} -----------------------------------------------------------
+.endif
.if !defined(USE_GCC) || !defined(WITH_DEBUG)
@${ECHO}
@${ECHO} "OPTIONS:"
diff --git a/editors/openoffice/pkg-message b/editors/openoffice/pkg-message
index 6395b787b3e0..4260551a1dcd 100644
--- a/editors/openoffice/pkg-message
+++ b/editors/openoffice/pkg-message
@@ -16,6 +16,14 @@ installation.
1.2 OO.org installed as package
+First check if procfs is running. OO.org setup does depend on
+procfs and does crash without it. This dependency will be
+removed in future, but at the moment it is needed.
+Please read the procfs(5) manpage and ensure the the following
+line is in /etc/fstab:
+
+proc /proc procfs rw 0 0
+
If you have just installed OO.org as package, there is no
"make install-user" option available. Instead you'll have
to run as the user you like to use OO.org: