aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-10 14:18:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-10 14:18:14 +0000
commit2bb673380db73421ce021eb875c93b4822d3bcad (patch)
tree0994477d65fdc882763b5e7f68da33f5c3b6d218 /editors
parent0b2183233e448fe42fc890ecd0d8c5adcf5c1ade (diff)
downloadports-2bb673380db73421ce021eb875c93b4822d3bcad.tar.gz
ports-2bb673380db73421ce021eb875c93b4822d3bcad.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/texmacs/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index b30d43e07a23..d0a4ea943880 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -30,8 +30,9 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-fastalloc --enable-optimize="${CXXFLAGS}" \
+CONFIGURE_ARGS= --enable-optimize="${CXXFLAGS}" \
--with-iconv="${LOCALBASE}"
+
MAKE_ARGS= CP="${CP} -R -f"
ALL_TARGET= ${PORTNAME:U}
@@ -43,6 +44,12 @@ LIB_DEPENDS+= Imlib2.3:${PORTSDIR}/graphics/imlib2
CONFIGURE_ARGS+= --with-imlib2
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+CONFIGURE_ARGS+=--disable-fastalloc
+.endif
+
post-patch:
@${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|#!/bin/bash|#!/bin/sh|g'
@@ -53,4 +60,4 @@ post-install:
${CHOWN} -R ${LIBOWN}:${LIBGRP} ${PREFIX}/libexec/TeXmacs
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/TeXmacs
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>