aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2018-06-12 04:00:07 +0000
committerDon Lewis <truckman@FreeBSD.org>2018-06-12 04:00:07 +0000
commit5183d6d6ee0a225c3e1112e8b3a72ba71e2e03f6 (patch)
tree2abf702240ad25d281de74c6ab51442027a3b826 /editors
parent32aa25d3bc637e5615a562226e287afb5818fbd8 (diff)
downloadports-5183d6d6ee0a225c3e1112e8b3a72ba71e2e03f6.tar.gz
ports-5183d6d6ee0a225c3e1112e8b3a72ba71e2e03f6.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-devel/Makefile10
-rw-r--r--editors/openoffice-devel/distinfo6
-rw-r--r--editors/openoffice-devel/files/extra-patch-align1670
3 files changed, 8 insertions, 78 deletions
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index 45d45c2896a9..8dddad32e2fe 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -105,7 +105,7 @@ AOOVERSION2= 2
AOOVERSION3= 0
# From solenv/inc/minor.mk SOURCEREVISION LAST_MINOR BUILD
AOOTAG= AOO420m1\(Build:9800\)
-SVNREVISION= 1829757
+SVNREVISION= 1833124
#AOORC=rc3
EXTSRC= ApacheOpenOffice.ext_sources.${AOOVERSION1}.x.x.20150707.tar.gz
@@ -237,9 +237,6 @@ CONFIGURE_ARGS+= --without-commons-logging
.if ${COMPILER_TYPE} == clang
CPPFLAGS+= -I${LOCALBASE}/include
-. if ${COMPILER_VERSION} >= 40 && ${ARCH} == amd64
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-align16
-. endif
.endif
.if ${ARCH} == amd64
@@ -462,7 +459,6 @@ do-install:
${LN} -f ${EXECBASE} ${EXECBASE}-$${i} ; \
done
@${ECHO_CMD} "adding desktop support"
- @${LN} -sf ${XDGREL} ${STAGEDIR}${DESKTOPDIR}/${EXECBASE}
@cd ${WRKSRC} ; \
. ${FREEBSD_ENV_SET} ; \
cd sysui/$${INPATH}/misc/openoffice ; \
@@ -476,6 +472,10 @@ do-install:
${SH} ${CREATE_TREE} ; \
${INSTALL_DATA} apacheopenoffice.xml \
${STAGEDIR}/${PREFIX}/share/mime/packages
+ @cd ${STAGEDIR}${DESKTOPDIR}; for i in base calc draw impress \
+ javafilter math printeradmin qstart startcenter writer ; do \
+ ${LN} -sf ${XDGREL}/$${i}.desktop ${EXECBASE}-$${i}.desktop ; \
+ done
do-install-SDK-on:
${TAR} -s '|./[^/]*/||' -xz -C ${STAGEDIR}${PRINSTALLATION_BASEDIR} \
diff --git a/editors/openoffice-devel/distinfo b/editors/openoffice-devel/distinfo
index 55eaa0bee15d..aa0a3c2e6101 100644
--- a/editors/openoffice-devel/distinfo
+++ b/editors/openoffice-devel/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1524355278
-SHA256 (openoffice/apache-openoffice-r1829757-src.tar.xz) = b3aed2de74f2c1ba455c9819f5066180b498e2af8b66b0cbe57860472a2f881e
-SIZE (openoffice/apache-openoffice-r1829757-src.tar.xz) = 216040176
+TIMESTAMP = 1528673578
+SHA256 (openoffice/apache-openoffice-r1833124-src.tar.xz) = a1c68e2691da912f2e2df43e9babc2721c9cdea2cdc28982e22ee30d7158090d
+SIZE (openoffice/apache-openoffice-r1833124-src.tar.xz) = 216168344
SHA256 (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20150707.tar.gz) = 966a8333c83a18ddd84401389006d6e0b52b8175924b808b54b88211669985fa
SIZE (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20150707.tar.gz) = 28957004
diff --git a/editors/openoffice-devel/files/extra-patch-align16 b/editors/openoffice-devel/files/extra-patch-align16
deleted file mode 100644
index 6d778661e386..000000000000
--- a/editors/openoffice-devel/files/extra-patch-align16
+++ /dev/null
@@ -1,70 +0,0 @@
---- sal/cpprt/operators_new_delete.cxx.orig 2014-09-19 17:58:40 UTC
-+++ sal/cpprt/operators_new_delete.cxx
-@@ -68,7 +68,7 @@ struct AllocatorTraits
- {
- n = std::max(n, std::size_t(1));
- #if OSL_DEBUG_LEVEL > 0
-- n += sizeof(signature_type);
-+ n += 2*sizeof(signature_type);
- #endif /* OSL_DEBUG_LEVEL */
- return n;
- }
-@@ -77,7 +77,7 @@ struct AllocatorTraits
- {
- #if OSL_DEBUG_LEVEL > 0
- memcpy (p, m_signature, sizeof(signature_type));
-- p = static_cast<char*>(p) + sizeof(signature_type);
-+ p = static_cast<char*>(p) + 2*sizeof(signature_type);
- #endif /* OSL_DEBUG_LEVEL */
- return p;
- }
-@@ -85,7 +85,7 @@ struct AllocatorTraits
- void* fini (void * p) const SAL_THROW(())
- {
- #if OSL_DEBUG_LEVEL > 0
-- p = static_cast<char*>(p) - sizeof(signature_type);
-+ p = static_cast<char*>(p) - 2*sizeof(signature_type);
- if (memcmp (p, m_signature, sizeof(signature_type)) != 0)
- {
- OSL_ENSURE(0, "operator delete mismatch");
---- sal/rtl/source/alloc_cache.c.orig 2016-06-21 21:57:07 UTC
-+++ sal/rtl/source/alloc_cache.c
-@@ -894,7 +894,9 @@ rtl_cache_activate (
- if (objalign == 0)
- {
- /* determine default alignment */
-- if (objsize >= RTL_MEMORY_ALIGNMENT_8)
-+ if (objsize >= RTL_MEMORY_ALIGNMENT_16)
-+ objalign = RTL_MEMORY_ALIGNMENT_16;
-+ else if (objsize >= RTL_MEMORY_ALIGNMENT_8)
- objalign = RTL_MEMORY_ALIGNMENT_8;
- else
- objalign = RTL_MEMORY_ALIGNMENT_4;
---- sal/rtl/source/alloc_global.c.orig 2016-06-21 21:57:06 UTC
-+++ sal/rtl/source/alloc_global.c
-@@ -75,8 +75,8 @@ static rtl_cache_type * g_alloc_caches[R
- 0,
- };
-
--#define RTL_MEMALIGN 8
--#define RTL_MEMALIGN_SHIFT 3
-+#define RTL_MEMALIGN 16
-+#define RTL_MEMALIGN_SHIFT 4
-
- static rtl_cache_type * g_alloc_table[RTL_MEMORY_CACHED_LIMIT >> RTL_MEMALIGN_SHIFT] =
- {
---- sal/rtl/source/alloc_impl.h.orig 2014-09-19 17:59:16 UTC
-+++ sal/rtl/source/alloc_impl.h
-@@ -45,6 +45,12 @@ extern "C" {
- #define RTL_MEMORY_ALIGNMENT_8 sizeof(void*)
- #endif /* SAL_TYPES_ALIGNMENT8 */
-
-+#if defined(SAL_TYPES_ALIGNMENT16) && SAL_TYPES_ALIGNMENT16 > 1
-+#define RTL_MEMORY_ALIGNMENT_16 SAL_TYPES_ALIGNMENT16
-+#else
-+#define RTL_MEMORY_ALIGNMENT_16 16
-+#endif /* SAL_TYPES_ALIGNMENT16 */
-+
- #if 0 /* @@@ */
- #define RTL_MEMORY_ALIGNMENT_1 8
- #define RTL_MEMORY_ALIGNMENT_2 (sizeof(void*) * 2)