aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2006-11-03 15:37:04 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2006-11-03 15:37:04 +0000
commit28fe5b4d58197f15e9d9cf6a733a86d36d832160 (patch)
tree1fe33f22c18f122ac30897b15b8a12feb35e5896 /editors
parent628fb6cc188e09b525aafdfe588ca88fd3570183 (diff)
downloadports-28fe5b4d58197f15e9d9cf6a733a86d36d832160.tar.gz
ports-28fe5b4d58197f15e9d9cf6a733a86d36d832160.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3-devel/Makefile6
-rw-r--r--editors/openoffice-3/Makefile6
-rw-r--r--editors/openoffice.org-2-RC/Makefile6
-rw-r--r--editors/openoffice.org-2-devel/Makefile6
-rw-r--r--editors/openoffice.org-2.0-devel/Makefile6
-rw-r--r--editors/openoffice.org-2.0/Makefile6
-rw-r--r--editors/openoffice.org-2/Makefile6
-rw-r--r--editors/openoffice.org-3-RC/Makefile6
-rw-r--r--editors/openoffice.org-3-devel/Makefile6
-rw-r--r--editors/openoffice.org-3/Makefile6
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile6
11 files changed, 22 insertions, 44 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index cc9b285f6a14..acb0c2e4587c 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -257,10 +257,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@{LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -275,7 +274,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
diff --git a/editors/openoffice-3/Makefile b/editors/openoffice-3/Makefile
index fa4e3d167ad8..f34e9c250c84 100644
--- a/editors/openoffice-3/Makefile
+++ b/editors/openoffice-3/Makefile
@@ -255,10 +255,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -273,7 +272,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
diff --git a/editors/openoffice.org-2-RC/Makefile b/editors/openoffice.org-2-RC/Makefile
index fa4e3d167ad8..f34e9c250c84 100644
--- a/editors/openoffice.org-2-RC/Makefile
+++ b/editors/openoffice.org-2-RC/Makefile
@@ -255,10 +255,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -273,7 +272,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index cc9b285f6a14..acb0c2e4587c 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -257,10 +257,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@{LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -275,7 +274,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
diff --git a/editors/openoffice.org-2.0-devel/Makefile b/editors/openoffice.org-2.0-devel/Makefile
index cc9b285f6a14..acb0c2e4587c 100644
--- a/editors/openoffice.org-2.0-devel/Makefile
+++ b/editors/openoffice.org-2.0-devel/Makefile
@@ -257,10 +257,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@{LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -275,7 +274,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
diff --git a/editors/openoffice.org-2.0/Makefile b/editors/openoffice.org-2.0/Makefile
index fa4e3d167ad8..f34e9c250c84 100644
--- a/editors/openoffice.org-2.0/Makefile
+++ b/editors/openoffice.org-2.0/Makefile
@@ -255,10 +255,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -273,7 +272,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
diff --git a/editors/openoffice.org-2/Makefile b/editors/openoffice.org-2/Makefile
index fa4e3d167ad8..f34e9c250c84 100644
--- a/editors/openoffice.org-2/Makefile
+++ b/editors/openoffice.org-2/Makefile
@@ -255,10 +255,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -273,7 +272,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
diff --git a/editors/openoffice.org-3-RC/Makefile b/editors/openoffice.org-3-RC/Makefile
index fa4e3d167ad8..f34e9c250c84 100644
--- a/editors/openoffice.org-3-RC/Makefile
+++ b/editors/openoffice.org-3-RC/Makefile
@@ -255,10 +255,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -273,7 +272,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index cc9b285f6a14..acb0c2e4587c 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -257,10 +257,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@{LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -275,7 +274,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index fa4e3d167ad8..f34e9c250c84 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -255,10 +255,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -273,7 +272,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index cc9b285f6a14..acb0c2e4587c 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -257,10 +257,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@{LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -275,7 +274,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}