aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2003-07-29 04:26:22 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2003-07-29 04:26:22 +0000
commitac4ef3820bce26f3bbb3fb8b1baaeae42b7028ca (patch)
treee774043ee6ff3c3d53fd74afbfa1a6efb14d22e3 /editors
parenta64b51263a686de76321c6baecd611e2e35e3297 (diff)
downloadports-ac4ef3820bce26f3bbb3fb8b1baaeae42b7028ca.tar.gz
ports-ac4ef3820bce26f3bbb3fb8b1baaeae42b7028ca.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile8
-rw-r--r--editors/koffice-kde3/Makefile8
-rw-r--r--editors/koffice-kde4/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index e548e5bff33a..70f5defbd79d 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -32,10 +32,16 @@ USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
PATCH_WRKSRC= ${WRKSRC}/kword
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+pre-configure::
+ ${REINPLACE_CMD} -e 's@-pedantic @@g' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index e548e5bff33a..70f5defbd79d 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -32,10 +32,16 @@ USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
PATCH_WRKSRC= ${WRKSRC}/kword
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+pre-configure::
+ ${REINPLACE_CMD} -e 's@-pedantic @@g' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index e548e5bff33a..70f5defbd79d 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -32,10 +32,16 @@ USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
PATCH_WRKSRC= ${WRKSRC}/kword
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+pre-configure::
+ ${REINPLACE_CMD} -e 's@-pedantic @@g' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>